Opening ARC I repeatedly get "Poor Connection Try Again --- Retry" message

Trying to open ARC on my iPhone or iPad now produces a dialog box at bottom of screen with “Poor Connection Try Again Retry” message. I have excellent WiFi and 5G connections so wondering if this is a configuration problem. Hitting Retry does nothing. Roon App on desktop says Ready - Roon ARC can securely access your Roon Core. Worked fine previously so don’t know what’s happened. Can anyone help?

I had the same issue on my android phone and “fixed” it when I used the “reset Roon Arc” at the bottom of the “settings” page.

Not sure what caused the issue initially but I had a few updates of Roon and my network that happened just before the issue started.

Just worked like a charm. That was really simple, I feel a bit foolish. Thanks so much!

1 Like

Nah, it happened to lots of people and it shouldn’t. Also by resetting you lose all downloads in ARC

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.