Output to hqplayer broken / solved

Roon Core Machine

Asrock J4105, Debian 11, Roon Version 1.8 Build 846

Networking Gear & Setup Details

Wired switch, internet connection through wireless bridge

Connected Audio Devices

Hqp embedded 4,26.2, also 4.27.0
Ropieee w/ Allo Digione Sig

Also tried USB connection from hqplayer server

Number of Tracks in Library


Description of Issue

Cannot play the hqplayer zone: “Unexpected error communicating with audio device.”
Can play hqplayer with the hqpcontrol, works with naaplayer on ropieee and with alsa as well.

So it is clearly a problem in roon.
All other Roon zones do work.

This occurs since the core was updated to build 846.

Does anybody use Hqplayer? Seems broken after the update. Opened support thread, but no feedback so far.

I havent had any issues with hqplayer. Some folks have been having trouble with the latest version of desktop on windows. Perhaps try going back a release of hqp?

Hi Ben,

which version do you use? Today I installed the new version embedded version 4.27.0, had the previous one before. Both work fine with the HQP control app.
Restored the server with the Roon Core to 11/02 (build 831), everything ok with the old version.

Might depend on resolution or other variables. Opened a support thread yesterday, but no response so far.

been thru this on a couple threads including one with a lot of give and take between roon and miska. It all came down to 1 simple setting in hqplayer, discovered by another user. On the right there are 4 options. Be sure “Time” is selected. I think at one point, a version of hqplayer was installed with “Remain” selected. If you use Roon, use the “Time” selection.

The hostname of the hqp server was not resolved as it used to be with the old build. Works with the ip.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.