Peachtree Decco65 USB Windows

Core Machine (Operating system/System info/Roon build number)
Windows 10.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Roon fails to enable this driver, either WASAPI or ASIO. Any suggestions?

Hi @Robert_Rosen,

Just to verify, the device is seen in Roon but when you click Enable it doesn’t work? What happens exactly when you click enable?

Can you verify that the drivers are fully up to date?

Seen by Roon, but gives error Unable to enable device.

Hi @Robert_Rosen,

Do other outputs work as expected and this behavior is just limited to the Peach Tree DAC? Is the behavior the same if you reboot your Core? Can you please share a screenshot of your Roon Settings -> Audio tab?

I have a PC attaching to a Peach tree AMP/DAC via USB. If the AMP is not set to the USB connection, the drivers will show as not enable- able. I would verify that the AMP is set for USB.

1 Like

Only output that works is to my SONOS speakers.

System Output is silent.

Peachtree WASAPI driver is silent.

Peachtree ASIO cannot be enabled.

Another poster replied that I should enable USB in AMPS. Is this a Roon setting? I don’t see it.



You have your computer attached by USB to the Peachtree. On the peachtree, you need to have pressed the USB button to select USB as the input or the computer (or Roon) will not recognize the AMP/DAC.


1 Like

So, can I assume the Peachtree decco65 and it’s driver are not compatible with Roon?

Hooray! I got it working. In Device Manager, the Peachtree device showed a faulty driver installation. I completely uninstalled, then reinstalled, and the ASIO driver is now working fine with Roon. Thanks for your attention.


Yes, Peachtree’s drivers can be “finicky” on install. Glad you go it sorted out. :smiley:

Hi @Robert_Rosen,

Glad to hear it’s sorted out, hope you have a wonderful day!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.