Persistent Database error

Roon Core Machine

Mac mini Server 2011 i7-2635QM with 8 GB DDR3 and dual drive setup (
Roon & OS running on Samsung SSD 830 256, music library on Seagate SSHD ST2000LX001 2 TB)

Networking Gear & Setup Details

Ubiquiti-based network, with a Dream Machine Pro, UB-switches and multiple Ubiquiti WiFi-points. Core & most audio devices hardwired.

Connected Audio Devices

10-15 plus devices, audio reviewing & testing environment. Mainly Roon Ready-devices, but also Chromecast/Airplay & throught rooExtend.

Number of Tracks in Library

29.200 tracks

Description of Issue

Since a power outage, I’ve noted a database error upon starting Roon (the server reboots automatically each day). Restarting Roon Server on the Core machine solves the issue, but the next day chances are the error will return. Also, if I try to make a backup of the database, this fails and the error returns.

  • Multiple attempts restoring from backups, going back in time.
  • Followed instructions on removing old database from Library, and then restoring backup. Again, tried multiple times with older backups.
  • Removed Roon Server and re-installed.
  • Checked drives with Disk Management for errors (none). Memory seems fine too.

Nothing of the above resolves the issue permanently.

Any thoughts on next steps?


Try following the guide: Troubleshooting - “There was an issue loading your database”, endless loading at launch, or missing all audio devices

Cheers BlackJack, however I’ve followed this guide multiple times, each time restoring an older backup (ie, going back in time).

If you’ve tried restoring from all your older backups, and still have the problem, it’s likely that they all have some degree of latent corruption. Prior to build 880 it was possible to backup and restore a compromised database, but current builds perform an integrity check when a backup is initiated. If this check fails, Roon stops the backup (much as it seems to be doing for you).

Hopefully support will have something more encouraging to add, but I suspect your only solution will be to start over with a fresh database.

Hi @Jamie_Biesemans thank you for sharing this on Community - we’re sorry that you’re having issues with this! We’d actually like to take a better look into this by collecting the logs. Could you please complete the following:

  • Attempt to restore a backup
  • Let the backup fail once again
  • Immediately after the backup fails, please, grab a set of logs
  • Zip up the entire folder and upload it in our drive

Please be sure to let us know that you have uploaded the logs so that we can take a look. Thanks so much!

Cheers! Uploaded the logs, I’m curious if anything turns up.

Thank you! I’ve looped in our technical support team - once we have more information about this, we’ll be reaching back out!

1 Like

Hey @Jamie_Biesemans, thanks so much for your continued patience as our technical support team reviewed the logs :pray:t3:

They had found signs of corruption within the database. With the new integrity checks, Roon is detecting this when you try to make a backup.

We’re hoping that you’re willing to take screenshots or manually export playlists as XML and start with a clean installation. Can you please then confirm if the issue continues when you attempt to make a new backup?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.