Pi4 not showing in audio settings in Roon

A small update on my situation as well:

I tried a different USB cable and forced volume to 100 for a USB dac (which I guess is max?), and this time I could get it working using Airplay, but still didn’t show up as a Roon endpoint.

However, when using Airplay, the sound was good for a time, then would have crazy distortion for a few seconds before returning to working fine. Very strange behaviour!

Out of interest @David_McNaught what are you running your core on? I have mine running on my iMac.

Mine’s running on a windows 10 laptop, currently connected via wifi.

I tried to the PI on wifi and wired with no difference.

Same here. Wired or wifi no difference.

@Sam_King the fact that ‘something’ shows up when using Raspbian is because those are the onboard audio device(s). RoPieee disables that.

I’m getting the idea that this is really related to your DAC, or at least the cable. Have you tried that? Just a different cable?

Hi @spockfish. Ok didn’t know that re disabling Pi DAC. Can’t be cable issue as the Chord Mojo connects with a cable but the Dragonfly Red just plugs into the USB direct. Neither work. And @David_McNaught I think it was mentioned a Cirrus Key which also plugs in direct if I remember.

Hmmm… you don’t have another Pi by any chance?

Afraid not. This was my first one.

Edit…I don’t know if this helps at all but I have a cheap laptop that I have Linux Mint 19.3 XFCE installed and had Roon Bridge on it for a while. Both DACs show every time in Roon with that. I know it is x86 but thought I should add that.

Clear. There are a huge amount of people out there using USB with RoPieee on a Pi 4 (me included). I also never heard of issues with a Chord DAC (I have a Hugo 2 myself), so that’s not it.

Do you have a USB drive you can test with? Maybe there’s something wrong with the USB ports in general on your unit.

I know it’s working for a whole load of people as I did quite a bit of research first, including Darko.com which sold the idea to me - a small form streaming set up for £50 with a great sound - what’s not to like. That’s why I was surprised I couldn’t get it to work. Maybe something I’m doing but can’t figure it.

In a further twist I just thought I’d plug the Pi back in to check something. Still running Raspbian I just on a whim not expecting anything I plugged in my Dragonfly DAC and I’m now listening to music for the past 15 minutes!! The only thing I did was power it down for about an hour. I suspect when I stop play and swap to my Chord everything will disappear again but at least it answers your question about my USB ports - they seem to work. I was worried about that.

Hoe is your Pi powered?

I bought the official USB-C power adapter from Pi Hut with the Pi.

Further update. I swapped out the Dragonfly for the Mojo. Recognised by Roon and worked. It went flat (listening too much!) so swapped back to Dragonfly and still recognised and working perfectly. Also I ran aplay -l and now output lists all sound cards properly with detail including the USB connection.

Interesting… so it just started working?

Hopefully mine will do the same :smiley:

Can you send me feedback?

This is not comparable with the issue that Sam has, as it shows up in Airplay (which means the device is detected).

So please disable airplay and the other services so we can focus on Roon first.


1 Like

Yes @David_McNaught but using Raspbian and not RoPieee. The next test will be to see if this is maintained through an inevitable reboot.

1 Like

Thanks - I will do when I next get a chance to play (hopefully tomorrow or Monday evening).

So @Sam_King,

One more thing: what’s the exact type of your Pi 4? How much RAM do you have?

It’s a Raspeberry Pi 4 Model B with 2GB RAM.

It’s all stopped working again after a reboot. Very frustrating. Success is intermittent.

So with what DAC?

I prefer if you would take the Chord and test with that one. I assume the Chord is powered on it’s own?

I was trying the Dragonfly again as the Chord needs charging. But in the morning I’ll try a reboot and use the Chord first.

Edit…as a last attempt tonight to try and figure out what was going on I ran dmesg and saw lots of entries “xHCI host controller not responding, assume dead, HCI died, cleaning up” everytime I moved the Dragonfly around the USB ports. A bit of searching brought me to an Arch forum where they were discussing this in relation to a kernel bug which essentially is putting the USB ports to sleep randomly. It seems to get fixed and then breaks with a new kernel release. I ran rpi-update to get the latest kernel (ends 102) and tried the Dragonfly and it appeared in Roon. Moved USB port - still there. Rebooted and still there. I’ll keep you posted.