Pioneer N-70 Wasapi and Asio

Hello, I have a Pioneer N70. I had to rebuild my pc.
Before that I had two Audio Zone: Pioneer N70 Wasapi and Pioneer N70 Asio.
This because one for PCM (Wasapi) and one for Native DSD (Asio).
Now I have re-installed Roon and the system automatically recognize only Pioneer Wasapi and I don’t know (remember) how to setup a Pioneer Asio Audio Zone (I also don’t understand why it recognise only wasapi)
I have Windows 10 64 bit
Could You help me?

Hello @fabio_cartelli,

Thanks for contacting support, I’d be happy to assist here. Have you by any chance installed the Pioneer driver yet? This could be the reason why only WASAPI shows up, for ASIO you may need to install the driver. Please let me know if installing the driver allows you to select ASIO.

I have installed Roon on Synology NAS (DS920+).
I cannot setup my Pioneer N-70A for Direct DSD (connected via USB).
Also DoP does not work.
Can you help?

Sorry but I no longer owe the Pioneer.
I can’t help you

I’ve owned the Pioneers N-70 A and AE some years ago and can say, that they didn’t support DoP.
Also all the Linux Kernels don’t support direct DSD with the Pioneer and so you’ve to setup a Windows Client with the ASIO driver and Roon Bridge installed for playing DSD without resampling to PCM.


Many thanks for the feedbacks. No way to setup it up using another DAC configuration?

You can read out the USB ID for the Pioneer, patch the kernel source and recompile the kernel.
But I don’t think you’ll get all the sources for your needed kernel.
On the other side, mostly using PCM and not DSD makes not a great difference.
As mentioned setting up a small Windows Roon endpoint (for example with Zotac Mini PC) isn’t a great deal…

It works. Installed Pionner USB DAC Drivers on my Windows 10 laptop. also created a new output in Roon via this end point. I can now directly stream DSD via my USB to my DAC.

Yes Asio requires a driver.