Pioneer XDP-300R not playing hi-res or MQA

Core Machine (Operating system/System info/Roon build number)

NUC 8i7 running latest build of ROCK and ROON build 416.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hi-spec Netgear managed switch (multicast enabled), Draytek 2860 router, Ruckus managed Wi-Fi network.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian 218>Meridian 7200SE, multiple Chromecast; all working ok.
Trying to add my Android-based Pioneer XDP-300R portable audio player.

Description Of Issue

The Pioneer XDP-300R doesn’t seem to be able to play 24-bit FLAC files via the Roon app, and MQA files (both local from ripped MQA CDs and streamed from Tidal) are being downconverted to 16-bit/44.1kHz. I have tried all combinations of the audio settings for the XDP-300R endpoint within Roon, but none of them seem to allow me to play in high resolution. Note the XDP-300R has a built-in MQA-capable DAC and both the Onkyo Music app and Tidal app are able to play both high-res and FLAC and MQA files correctly (both local and streamed).

Is this a case of the Roon app not being aware of the hardware DAC within the device and is reverting to using the processor’s DAC instead? Is there a workaround?

I’ve seen there are a number of other older threads regarding this player but none of them seem to be addressing the high resolution issue.

Roon is downconverting 24-bit to 16-bit (both FLAC and MQA)

Have tried both options for the ‘Enable MQA Core Decoder’, but presume it should be off in order to do hardware rather than software decode?

24-bit FLAC files (local) throw a ‘Failed to initialize the audio device’…the same files play fine at high-res with the Onkyo Music app.

TIDAL app is decoding streamed MQA correctly (MASTER icon)

Onkyo Music app is correctly decoding MQA from local rip of MQA CD.

While you wait on Support, a couple of questions.

How is the Pioneer connected to your system? It it USB from a Remote computer?

The Signal Path shows OS Mixer, which kind of indicates you Enabled System Output in Settings > Audio instead of the Pioneer device. Just a guess though.

Could you post a screenshot of your Settings > Audio tab?

Cheers, Greg

It’s connected via Wi-Fi. Roon app is acting as both remote and endpoint (ie in the same manner that a phone/tablet would), so Settings>Audio states “Connected to this Phone”.

The pioneer only does standard android output via roon if you are network connecting it No high Res and no MQA. I’ve got one, worst bit of kit I ever bought.

…but it does both high-res and MQA in the Tidal and Onkyo Music apps, so it is only the Roon app that ‘appears’ not to be able to.

As far as I know, Roon can only access the device’s internal Android OS (the same issue with other High Res based phones like the LG). The other software have their own ways to bypass Android’s internal audio system, ones that are not open to other players. So Roon is being downgraded to what Android’s audio system can handle.

That’s as I suspected…not the end of the world as the Pioneer is predominately used away from home when Roon wouldn’t work anyway. In the few times I do use it at home (mainly in the garden) I’ll just have to keep using the two other separate apps for local or streamed music.

Hi @Tennant,

As other user have mentioned, it appears that you are using the Android OS mixer here which is limited in sample/bit rate. We are currently in the process of overhauling our Android App and the changes we make may help with this issue as well, but I can’t say for sure. The best place to track our Android progress would be in the Release Notes Section of this site and once the updated build has been tested and published we can take another look at this specific issue.

– Noris

Hi Tennant,
I use also a XDP-100R with Roon/Tidal but I could see that all 24bit versions are reduced to 16bit.
If I try to use 24bit files I get the message that initializing the audio device failed.
So far I found no solution for this problem.

Hi @Wolfgang_Schuh,

Thanks for your interest here. As previously noted, we are currently working on some improvements to our Android App. I can’t say for sure if it will help with exactly your issue/device, but I would suggest keeping an eye on our release notes section for when it goes live. Thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.