Play/Stop stops responding

Roon Core Machine

Synology DS1821+ (16GB RAM - CPU 7%, RAM 16%)
DSM 7.0.1-42218 Update 2
Roon Server Ver: 20211105

Core database on dedicated SSD Volume 2 “RoonServer” Share
DS1821+ all 4 GB ports aggregated to Cisco Switch

Networking Gear & Setup Details

Xfinity Internet
Cable Modem: MB8600 Docis 3.1
Router: TP-Link Archer C5400
Switch: Cisco SG200-26
4 GB Ethernet ports aggregated to Synology NAS
1 GB Ethernet port to TP-Link Router
1 GB SPF to Lumin X1

Connected Audio Devices

1-Sonos Port WiFi
2-Sonos 5 WiFi
6-Sonos One Wifi

Windows 10 Pro - Roon App V1.8 (Build 898)
Connection: GB Ethernet hardwire
SoundBlaster AE-9 sound system
Using Windows WASAPI

iPad Pro 9.5" IOS 15.3 Roon App V1.8 (Build 898)

iPhone 11Pro Roon App V1.8 (Build 898)

Lumin X1
Connection: 1GB SPF

Number of Tracks in Library

11,084 Tracks

Description of Issue

Roon app play/pause button stops responding about 3-5 minutes after Core reboot
When this is occurring, I cannot get to a “Device Setup” screen for any audio device.
If I click on the zone icon at the bottom right (left of volume control), the pop up list shows the zone device with the volume gif to the left of it like its playing. The pause button to the right of the device is non-responsive
If I restart the Core on my Synology NAS, everything works fine for about 3-5 minutes. i.e I can select one or more zones, play different music in a zone or group zones but after a couple minutes, the system stops responding and whatever is playing continues to play until it comes to the end of the queue. Then I cannot start something new.

Note, if I have not started music in the 3-5 minute window, then I cannot play either.

The remainder of the app appears to work. Ex:

  • I can disconnect and reconnect to the Core, but the problem persists.
  • I can search my library and select a new artist/album/song. If I press play the song does not start and the last played song still shows in the player at the bottom of the screen.
  • I can go in and out of any of the settings (except as noted above device setting)

The Roon app sees my network, core and all devices. When the core is stopped and restarted, the Roon app sees it immediately.
My Sonos devices show up twice in the app, once as Sonos devices and once as Airplay devices, it sees my PC and recognizes the Lumin X1 as a Roon Ready device.

When the problem occurs, it manifests on my iPad, iPhone or PC version of the Roon app all at the same time. In other words, it does not appear to be dependent on the instance of the app or the device that the app was running on when the problem occurs. To be clear, when the problem is occurring the same current song shows on any instance/device, cannot get to a device setting on any instance/device, the zone icon shows that a song is playing whether it is or is not on any instance/device

My Lumin App is on the same network and can stream media from the same Synology NAS to my Lumin X1, flawlessly
The Linn App is on the same network and can stream media from the same Synology NAS to my Lumin X1, flawlessly
My Sonos App is on the same network and can stream media from the same Synology NAS to my Sonos devices, flawlessly
iTunes uses Airplay to play to my Sonos devices flawlessly
My PC can stream from the NAS flawlessly

When you say Roon app do you mean the exact same problem occurs on EVERY single Roon Remote?
All the iPads and iPhones you listed?

If so that would seem to indicate that it is not an app issue per SE but something endpoint or Core related maybe.

Correct. It occurs on any instance of the app on any device. It appears to be either a problem with how the app communicates with the Core or how the Core interprets commands and communicates back to the app. I am new to Roon (in my 14 day trial). If remote is the how one calls, what I think of as the app, I apologize for mixing the terminology.

Going to have to leave this one for @support .
Hopefully they will have some ideas for next steps.
Or any of our other community members are welcome to chime in with any thoughts.

1 Like

If you are new to Roon and just set up the Core, then it might be going through Audio Analysis which is an extremely heavy CPU load. Restart Core, go to Settings / Library and turn “Background Audio Analysis Speed” to OFF. Then see if the application stays active.

I have the impression that link aggregation may not work for Roon, but I’m not 100% sure.

Follow Rugby’s steps. In case that still does not fix the problem, move the Roon Core to Windows 10 PC and disable the Windows Firewall (or add two exceptions).

Hey @Donald_Landwirth,

Thanks for connecting with the Roon community and support while on your free trial. We’re glad to have you :blush:

We appreciate all the details you’ve shared about your setup and the description of the issue you ran into.

The suggestions made by the community so far are very insightful (thanks all :pray:). If I may, what is the CPU of your Synology Core?

Did you by any chance had a moment to try using your PC as a Roon Core? Was there any change?


Thanks for your reply. The DS1821+ CPU is AMD Ryzen Quad-core 2.2 GHz. (And yes I did not see AMD on the list of supported CPU architectures and did not see the DS1821+ on the NAS list either :-)). I will try switching to a PC, however I don’t typically have a PC running 24/7. Not that I’m listening to music 24/7, but then I will always have to consider whether a PC is running. The NAS, on the other hand is always up. But to test functionality, for sure I will give it a try.

@Rugby the core finished its analysis in about 14 hours. I had Background Analysis set to 6 cores while it was doing its initial analysis and was not trying to stream at that time. The NAS was showing about 65% CPU unitlization during the analysis. After the initial background analysis was done I set it to Fast 3 cores (out of 8). As reported in my initial post, CPU utilization is around 15%. I will try turning it off and will report back. Thanks for the suggestion.


1 Like

Thanks for your reply. I find it hard to believe the aggregation would make a difference. The Synology OS presents a single port and IP address to applications. Packets do get split at lower levels of the stack, but they would be reassembled by both the switch and Synology OS before being sent up the stack to a client’s port, in the case of a switch, or the Core application, in the case of the Synology NAS.

I think I’d be seeing other problems on my network if there was a problem with the Ethernet stack, which I am not. The net performance is excellent. As reported the same setup is working fine with the LUMIN, Linn, Sonos and Airplay software.



@Rugby and @beka,

In the spirit of trying to isolate one thing at a time. Before offloading the core from my Synology to a PC, I tried some tests with Background Audio Analysis Speed (BAAS) On (3 cores)/Off/Throttled

I have also discovered that the choice of data file is making a large impact as well. If I choose a file that was downloaded from iTunes (or ripped from a CD by iTunes) as an ACC 44.1kHz (at any kbps rate), it will cause a single zone or all zones to fail depending on BAAS setting.

Note: The Lumin app will not play ACC 44.1 files on the Lumin X1 either as they are not supported. However, the Apple IoS player and Sonos App can play these files to Sonos devices.

First Test – BAAS turned off

I restarted the Roon Core and turned BAAS off in the Remote on my iPad.

This seemed to have a significant impact. I was able to play different music in any individual zone for seemingly as long as I like. I could start, stop change songs, artist, albums. All good. I ran into two issues

Issue 1

Grouping Sonos Zones

Grouping Sonons Zones, while music is playing in the first zone causes music to stop and the remote loses connection with first device. A message pops up in the remote saying it lost connection with the zone (I didn’t catch the exact wording since it was momentary). When I ungroup, I can resume playing in the first zone. If I pause music first, then add a second or third zone to the group, it works OK. If I pause music and ungroup one or more zones, it works OK. If I ungroup one device from a group while music is playing, it causes all zones in the group to fail and any remote device cannot control them again until another restart of the core.

Issue 2

AAC 44.1 files causes total failure

I have ripped some CDs using iTunes into AAC 44.1 kHz 257kbps files. Also purchased music from iTunes is saved as AAC 44.1 files of various kbps rate. If I play any song from an ACC file, all zones stop responding. If other music is playing in another zone, it continues to play, but the remotes cannot stop or communicate with the playing zones. When I shut the Core down, the music continues to play. When I restart the core and the remotes reconnect, then I can stop and start music again. Note: this behavior is worse than with BAAS on with 3 cores (repeatable with BAAS on or off).

Issue 3

After a zone fails due to an ACC 44.1 kHz file launched from my PC Windows remote, the remote will not play or pause music unless I close and restart the app after the Core reboot

Here is an example of some music paths while working:

Signal Path High Quality
Don’s room two Sonos One (paired)
Processing speed: 38x
(WAV) - Source –

  • WAV 192kHz 24bit 2ch

Bit Depth

  • Conversion – 24bit to 64bit Float

Sample rate conversion (green dot)

  • 192kHz to 48kHz

Bit depth conversion

  • 64bit Float to 24 bit


  • Sonos


  1. Signal Path: Lossless
    (WAV) - Source –
  • WAV 96kHz 24bit 2ch

Lumin X1

  • Roon Advanced Audio Transport

Leedh volume control

  • 7


  • Analog output
  1. Signal Path: Lossless
    (WAV) - Source –
  • WAV 192kHz 24bit 2ch

Lumin X1

  • Roon Advanced Audio Transport

Leedh volume control

  • 7


  • Analog output

PC/ SoundBlaster AE-9

  1. Signal Path High Quality

(WAV) - Source –

  • WAV 96kHz 24bit 2ch

This PC

  • Roon Advanced Audio Transport

System Output

  • OS Mixer
  1. Signal Path High Quality

(WAV) - Source –

  • WAV 192kHz 24bit 2ch

This PC

  • Roon Advanced Audio Transport

System Output

  • OS Mixer

Second Test – BAAS turned on (3 cores)

I restarted the Roon Core and turned BAAS on again in the Remote on my iPad. This pretty much repeats what was initially reported. I could start, stop change songs, artist, albums in individual zones for a while. If I pause music first, I was able to add a second Sonos zone to a group and play. Ungrouping a zone causes the remote to lose control of all zones.

Playing AAC 41.1kHz files causes a specific zone to fail

Third Test – BAAS turned on (throttled)

All of the problems originally noted and seems to be even worse than having 3 cores.

Next Test
Will install the Core on my PC later today or tomorrow and will report back then….

1 Like

Synology comes with a ffmpeg that cannot handle AAC.

See this:

Even if you can do something with the Synology AAC problem, I’d still recommend you move the Roon Core to Windows.

I never suspected your Ethernet network was faulty. I suspected Roon cannot run on link aggregation. That’s a huge difference.

That is not true. Lumin app certainly supports Tidal AAC. If you bought some AAC files and they cannot be played, please don’t buy AAC anymore. You should only buy FLAC / ALAC / WAV / AIFF / DSF / DFF.


Thanks for your reply and the info on ffmpeg.

I have installed the Core on my PC and indeed it can play AAC files on the Lumin X1. I stopped purchasing AAC files last year. I am only purchasing FLAC now and or ripping my LPs to 96KHz 24-bit FLAC files.

I should note that until Friday, I was using a DS1815+ and only the Lumin App. The Lumin app could not play my AAC files from the DS1815+ either. The DS1815+'s power switch was failing (2nd one to fail within 2 years of service) so I switched to the DS1821+. Fingers crossed that the DS1821+ will last longer than 2 years.

As an aside, I purchased my Lumin X1 in November and I am totally delighted with it. Super happy with the purchase. The only reason I’m looking at Roon is because I’m trying to see if it is better than the Lumin app. The Lumin app is steadily improving and I’ve leaned how to use it. Roon has more robust metadata features and hopefully will allow me to control both the Lumin and my Sonos devices. BTW, the Lumin App is talking to the same NAS and those files pull from the NAS into my switch across the aggregated path and go out to the Lumin across the SPF link.

I will respectfully disagree that aggregation would cause a problem up at the application level for the Roon Server. I’ll keep an open mind and if there is some evidence to support that, I’ll believe it. But it seems like all that should be resolved in the IP stack before being presented to an app, so the app shouldn’t have to do anything differently to send or receive network traffic. The aggregation should be a black box.

Thanks again, Don

@Rugby @beka,


Once again, a lot to report. Sorry for the long messages, but trying to be thorough.

I removed the core from my Synology NAS opting to start clean on my PC rather than attempt migrating anything that could be problematic.

Installed the core on my PC, pointed it to my music files on the NAS. Installation went fine. Would have preferred that the install allowed me to choose my database location, but more on that later.

Bottom line, when the system is up, it is working much better. Even AAC files are playing on all zones, including the Lumin X1 (as @wklie predicted).

However, since I already had the remote client installed, the core would not startup unless I was logged in and had the remote client on my PC launched. So, I uninstalled the client and core on the PC. Rebooted and installed the RoonServer only. Added the RoodServer shortcut to my startup and the Core now launches when I turn on the PC. My iPad, iPhone and other Remote clients can access the core without me having to be logged into my PC.

There is still a problem with grouping and ungrouping Sonos zones while music is playing. For example, if music is playing on one Sonos zone and I add a second zone to the group it stops the current zone and adds the new zone. I may or may not see a message “Roon lost control of the audio device”. Once I hit play, both zones start playing. If I add a third zone while playing the two zones, it stops all Sonos zones and I may see the “Roon lost control of the audio devices” message or the entire group clears all selections and reverts to the first zone only. In other words, music always stops and the remote app shows only the first zone. Then I have to press play again. If I try to add more than one Sonos zone at a time, it always fails and loses all zones or all but the initial zone.

The same thing may happen while music is playing in a group of two or more Sonos zones. If I remove one or more zones from a group, the music halts and one or all zones are removed from the group.

Occasionally while adding or removing, all zones are disconnected and the remote client will not even hold onto the initial zone. It will prompt me to select a zone.

If music is stopped while I add or remove Sonos zones, it seems to be OK. I can add or remove one or more zones at a time. When I press play, all zones work as expected. The problem only seems to occur when adding or deleting zones while music is playing.

If music is playing in a non-sonos zone at the same time, it doesn’t seem to affect the non-sonos zone. (which had been occurring when I was using the Synology NAS).

The bottom line is that things are working better now. My library’s Background Audio Analysis Speed has not completed analyzing, so perhaps by tomorrow, when that is complete, things may improve with the Sonos devices as well. I will post another update.

Having said all of that, I would still vastly prefer to run the Core on my NAS. I do not want to have to leave my PC running 24/7. Afterall, since I have a NAS, which is running 24/7 and has bandwidth for an app like the RoonServer, why not use it? If a future version is available and compatible with the DS1821+, please feel free to reach out to me for beta testing. Please be sure to include the capability to read and write to an external eSATA drive (which apparently, for the sole reason of the lack of Synology’s DSM to allow the device share to be named RoonServer, is not possible)

Installing the Core data outside of AppData\Local

Caveat, the following is one man’s opinion. I understand if no one else agrees but, being the type of person who thinks that everyone is entitled to my opinion, I’ll share it. :smile:

I think it is a mistake not to allow users to specify where their Core database resides. Even if it is not anticipated to be more than 120GB. I can’t think of any other software that doesn’t allow the concept of data being separated from the program files and allowing end-users to configure the data location. The only exception that I’ve found is that iTunes backup on a PC defaults to a location in AppData (however, there is a way to move the backup location). But even then, iTunes allows me to move my music library to any location I want.

As one who has worked on PCs since virtually day-one, I’ve seen my share of crashed systems. I’ve developed an architecture where all of my PCs have two or more drives. One drive for system and apps (C:) and the other drive(s) for data (D:, E:, etc.). I use my Synology NAS Drive software to sync all data drives in real time and use backup software to backup my system drive weekly. My theory is if a system crashes or if I replace a system, I can start with a fresh system drive with settings and applications restored from backup, or build a new system with new application software. Then I simply install my data drive and point the restored or new system at my data. Conversely, If a data drive fails, I simply put in a new drive and move data over from the NAS.

With this methodology, I never have to fish around looking for data in some AppData folder where the tree structure is too complex and or random and it would be easy to lose something important. In addition, I always change the MyDocuments folder to point to a folder on one of the data drives. In that regard, some new software doesn’t attempt to put data somewhere in my C:\users\AppData tree.

The net result is it allows me to use a small SSD like 256GB or 512GB max for the C: drive and larger drives for data. I never have to worry about my system drive running out of space because I always know how much room I have for apps and how much room I have for data. The two are not merged onto one drive.

Therefore, while I am OK with the RoonServer software being on my C:\ drive for now, I would much prefer to have the database on a separate drive. Even if that other drive is a small 64 to 128GB SSD. In a future version of the server, please add the capability to relocate the database.

Stepping down from my soap box…

Roon does not allow you to relocate the database drive. If you want to suggest that Roon provide the option, you should copy part of that post and use it as the basis for a post in the Feature Suggestion section.

I’m sure Roon had their reasons for the decision decision, although I am not privy to them. With computers there are usually “ways” of getting what you want. If you really care and are technically inclined, then you might look around the Tinkering section for posts discussing the topic of database location.

OK, will do on the feature suggestion. Thanks.

After some emails with @crieke, I reinstalled the latest version of the RoonOnNAS core, was able to mount the core on my eSATA drive (yay!) and the system has been quite stable for over 1 week now. There are still some instances where adding or removing a Sonos device while music is playing that can cause the remote to loose connection with the devices, but it is no longer halting and I do not have to stop and restart the core, nor close and restart the Remote client.

I plan to turn off the link aggregation between the NAS and Cisco router to see if that is part of the problem @wklie (oh and BTW, I did move the AMD 5.0 version of ffmpeg file into the RoonOnNAS/bin file and AAC files are working great on my Lumin X1, as well)

Finally, per the instruction with RoonOnNAS, I backed up the database from my Windows desktop core and tried to import that into the NAS core, and that failed at about 4% of the way. I tried making new backups and repeating the process, but was never successful.

Bottom line is the Core is working, I delighted to have this running on my NAS vs a desktop and I’m very happy with Roon in general. I will report more in a few days, but wanted to make this post in order to keep the thread alive.

Thank you Christopher for your help and support!


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.