Playback issue with Pro-Ject Stream Box S2 Ultra and Mcintosh MA6700

Hi - this is my first post so apologies if I’ve incorrectly directed this or broken/ignored any protocol!

I’m in need of some help with a frustrating issue that I can’t resolve.

I have a second system where I’ve successfully been using a Squeezebox Touch into the coaxial digital input on a Mcintosh MA6700. I’ve recently acquired a Pro-Ject Stream Box S2 Ultra to replace the Touch but have encountered the following (assume all playback is from Tidal):

  • There is always a fairly long delay before the first track selected plays – not an issue
  • Sometimes the first track will try to play, skip and play the second, but you can then skip back to play the first
  • On some Tidal playlists it attempts to play all tracks but ends up skipping almost all of them

Having looked at the signal path I’m pretty confident that the issue lies in ‘mixed’ Tidal playlists – e.g. ones that combine MQA and redbook. Once a playlist of redbook starts playing it will continue as expected, usually after the second track, but anything mixed throws a spanner in the works.

I’ve preformed the following tests:

  • The same SB S2 Ultra with the same USB cable into the same USB input on the same Mcintosh amp but using Tidal via the Pro-ject app rather than Roon – seems to work fine. This might indicate Roon being the culprit
  • The same SB S2 Ultra with the same USB cable into a different DAC (Ayre QB-9 Twenty) using Roon into analogue inputs on the Mcintosh amp – rock solid. Which might indicate an issue with the amp’s USB input

I’ve tried pretty much all combinations of Mixer, Buffer size etc (been working on this for best part of a week) so I’m at a bit of a loss. I’ve looked on the forum for any issues with the SB S2 Ultra but none of the discussions seem to answer/address this particular problem.

Any suggestions/ideas on how I can get the combination of Roon, SB S2 Ultra (Roon Ready) into the USB input on the MA6700 (Roon tested) to perform as expected?

I should say upfront that I’ll need handholding through anything other than the most trivial of all things techie!

Many thanks

Hello @Michael_Egerton, and welcome to the community! We’re happy to help, but do you experience this same issue with local content?

Hi - many thanks for responding. I only have three albums of local content - all ripped CDs at 16/44 and played without problem.

While not a proper solution I’ve found a workaround since the original post - I’ve set it so that Roon upsamples everything to 192. My (uninformed!) thinking was that somewhere between Roon and the Mcintosh’s DAC something wasn’t recognising or switching sample rates properly.

It would be great if this could be fixed properly but given the DAC is’t MQA able I don’t think this will negatively impact the SQ in anyway in the current set up. In fact that DAC upsamples all incoming signals anyway so if Roon does a better job/lightens the load I guess it might actually be a positive (not claiming to have tested or noticed any difference).

Kind regards

Some users of that DAC have fixed USB issues by adding a Resync Delay of 100 or more ms.

1 Like

Hello @Michael_Egerton, rugby makes a great suggestion here. Could you please give that a try and let us know if things improve?

Hi Rugby/nuwriy - many thanks for the suggestion. I changed the resync delay (pushed it all the way up to 10000ms in steps). I think it might have marginally improved the ‘play rate’ but not the silver bullet I’m afraid.

When time allows I might set up a Macbook as an endpoint into the same USB input to see if the issue repeats. Possibly too early to say/a bit unfair but I’m starting to think the Mcintosh might be to blame here.

Best rgds

Hello @Michael_Egerton, and thanks for the update! Testing with another machine is always a good idea. We could also take a look at your logs to see if we can gain more insight. Could you please reproduce the issue one more time and reply here with a timestamp (the date and time you experienced the issue) then use the directions found here and send us over a set of logs using a shared Dropbox link. Please also let me know what track you were playing at the time and we’ll take a look!

Hi Nuwriy - apologies for the delay in getting back to you. I think I’ve managed to send the logs that you’re after. Let me know if not as this is the first time that I’ve ever Zipped anything or sent a Dropbox link (assume I’m a Luddite/like a grandparent who thinks a dishwasher is the work of the devil when it comes to IT!)

I reset the Pro-Ject to the default settings other than the Resynch delay (500ms) as suggested by Rugby. I was trying to play a Tidal playlist (Dusty Desert Music) at 12:48 on the 23rd. It tried to play but skipped the first few tracks. I think it started playing at track 7, then skipped to c. 12 and seemed to settle down. I had a look and all the tracks it played seemed to be 16/44.1.

Obviously let me know if you need anything else or I’ve made a hash or doing what you asked.

Kind regards

Hey @Michael_Egerton, haha your comment has made my day! Thanks for capturing the timestamp, can you post a link to the logs you uploaded via Dropbox here? When you open the folder you put in dropbox, there should be a share option and a button to create and copy a link.

Hi nuwriy,

Apologies - I think I tried to share via your email, I did warn you. Here’s the link:

All the best

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.