Playback Issues, playbar not active and whole album does not play, roon radio stops

2 issues

  1. playback always stops, the queue is full of music but at best playback stops after 2 songs, album, playlist, my files or qobuz it is universal. Turning on radio does not help, turning off radio does not help. I uninstalled and reinstalled, did not help.
  2. playback bar never initiates, no progress is shown while music is playing. I can click along the bar and get different sections of the song but it remains unaffected showing no progress.
    Windows 10 I7 6700 skylake , Asus H110-A/M.2, 32 gb ram, local storage SSD 860 EVO 1 TB 411 albums
    fidelizer - network player setting. hqplayer to rpi/pi2aes, i2s to Sonnet Morpheus
    Network ethernet to Cisco 100 mb switch or Trendnet 1 gb switch,
    rpi/pi2aes from same switch, internet from switch/ethernet, powerline networking to netgear r7800 router downstairs.
    hqplayer directly plays fine with no interruptions, 10 to 11 mbps rate
    throughput is not an issue

Issues do not occur when playing back to default, graphics card, monitor, soundbar

see above

Hey @Clark_Mobley,

Thanks so much for following up on your post. I’m sorry we didn’t get back to you until right now - it’s our first day back after a holiday weekend in the US. We’re catching up :slight_smile:

You mentioned:

Issues do not occur when playing back to default, graphics card, monitor, soundbar

When does the issue occur?

I see you’ve tried a few troubleshooting steps. Was any of them trying to reinstall Roon? :nerd_face:

Issue occurs when I playback thru hqplayer to my pi2aes naa endpoint. HQPlayer has no issues when using it directly for playback.
I did reinstall Roon twice, the second time with Revo unistaller and I was able to clear out registry entries that had been left behind. Even this “fresh” install was not complete as after Roon was installed there were indications that it was aware of previous history (from the cloud?). I have created a new database and attempted to restore old databases, a bit of a problem as when selecting one thru roon, they all showed the same date and even browsing them from roon was different then browsing them via Windows, different files and folders being available.
I have changed 1 symptom, when picking a song from a ripped album, invariably, the next song starts playing, but the progress bar is still broke and playback still stops at 2 songs tops.
Open to ideas.

Hey @Clark_Mobley,

Thank you very much for your reply and explanation of the steps you’ve taken. I’ve looped in our technical team so they can help with more insight and possible next steps.


Hi @Clark_Mobley ,

Powerline adapters have caused issues with Roon in the past, have you by any chance tried to bypass the powerline adapter and connect the Core + Pi directly to the router via Ethernet and the behavior is the same?

What are you using on the Pi, do you have Roon Bridge, DietPi, Ropieee installed? What happens if you try to bypass HQPlayer and play to the Pi directly through Roon, does the issue still occur?

I have always used powerline networking. It has never presnted an issue and not it does not present an issue while using hqplayer directly. By passing it is not feasible nor worthwhile as it is not the problem.
I have ropieeexl installed with the naa option for hqplayer. It has worked flawlessly until recently.

Roon just seems to lose track of what it is doing. If I select an album to play, roon will invariably jump to the second song but will still show the first song as the one that is playing, again with an inactive progress bar. It mishandles the actual data as if it has lost the index for it’s varied functions, play progress, song selected, next in queue, etc. Something is scrambled. Instructions on creating the data properly would be most helpful, I think.

Roon thru usb will have to wait. I know roon plays to windows default setup just fine.

Hey @Clark_Mobley, you mentioned it was working flawlessly until recently. Do you recall anything about your setup that changed around that time?

It would be really helpful if you could try the troubleshooting steps that @noris recommended:

  1. Bypass the powerline adapter
  2. Try bypassing HQPlayer and play the Pi directly through Roon

We’re not suggesting you do those two things permanently, we’re just trying to narrow down where the source of the problem might be. Thanks!

Configured ropieeexl for roon and everything works fine.
It had been working fine when configured as naa and roon played thru hqplayer.
Roon pc is on wifi (I had already tried this). Powerline networking is still in use for the pi. It has never been a problem and ethernet is preferred for the connection.
Playback is fine from HQPlayer direct to the pi when configured as naa so ropieeexl works when using naa on the pi. I can only think the interface between roon and hqplayer has gotten borked somehow. It is generally a straightforward connection, just enable hqplayer and go, ropieeexl enable naa and go, except it is no go currently. I will have to play with this to get it back to a working state but Roon is doing it’s job now playing to a roon endpoint on the pi so I’ll take it.
Thanks for you help