Playback issues with the dCS Upsampler (Build 298)

HI @Joseph_Gerardi ----- Thank you for the report and sharing your feedback with us, the insight is appreciated!

I have moved your posts regarding this behavior over to “this” thread where we are tracking this issue. Our tech team is currently looking into this behavior to try and determine what the cause could be. I have the details of both yours and @G997’s setups (thank you again for the PM) which I have been added to my report.

Additionally, I would also like to enable diagnostics on your accounts so I have an up to date set of Roon logs for my report. If I may kindly ask you both to please reproduce the issue and note what was being played/the time the error occurred I will enable this feature on your accounts.


1 Like

Hi Eric,
It is possible to get a link to download a previous version of Roon from a month or two ago?
Perhaps I can deny the upgrades for awhile. ?

[personal information removed by support]

Found my old Roon download.
I will reinstall.


Hi @Joseph_Gerardi – as Eric mentioned we are looking into this issue, and we apologize for the inconvenience.

Downgrading Roon is not supported, and in some cases can cause database corruption. We strongly recommend against it.

We appreciate everyone’s patience on this.

Hi Mike,
OK, I will use it as is for awhile.
Let me know if you would like to remote into it or anything,
I am home after 6:30 PM Eastern.



I discovered a strange problem with playback of 16-bit tracks. When I try to play those tracks it takes about 10 seconds for the playback to start. Interestingly this does not affect any 24-bit tracks nor DSD files, where playback starts pretty immediately.

When RADIO starts and 16-bit track is chosen to be played, sometimes the tracks starts to play (of course after 10 seconds pause) and plays only 1 or 2 seconds and the sound is ceasing completely. In this case I have to press stop and play again, this usually helps. I have not noted this kind of problem with previous version of ROON.
This error persists and is regularly repeatable in 100% trials on Vivaldi Upsampler (we have 2 sets) and Vivaldi ONE (one set).

Where the problem can be ?

Best regards

Thanks Joe!

@Jaroslaw_Orszanski - sorry for the trouble here, I moved your post over here, where we have been discussing this issue.

To give everyone an update, we did make some progress today identifying the cause of this regression. We are still looking into a fix and how soon testing can begin so it can be rolled out, but identifying the underlying cause is a critical first step.

We will let everyone know as soon as we have more information, and we appreciate everyone’s patience.

I just wanted to add that I’m seeing similar issues with my dCS Network Bridge. Here’s a screenshot of the version section of the app:

Additionally, the dCS app’s currently playing track metadata is wrong.

1 Like

Hi Mike,
Amazingly, after a few restarts Roon is working when I press the buttons with no delay.

But - I have another problem now.
Roon sees my dCS Network Bridge as “airplay” now and is reducing all resolutions to 44.1 with a convoluted process.

Please help. I cannot even play any of my higher rez files.
I need my ethernet connected dCS Bridge to work normally - without Airplay.

Thank you,

Hi Mike,
Why would this not work?
The program worked fine before the updates.

Roon is now doing only “Airplay Streaming” to my ethernet connected dCS Network Bridge.
I’m crippled here.

Please help.

Go into your Audio settings in Roon and you’ll likely see your bridge under Roon Ready devices with a blue “Enable” button next to it. Press that and then “Save Settings” in the pop-up that appears and you’ll get your bridge back in it’s normal form.

Scroll down a bit more to the AirPlay section and click the gear icon next to your bridge and click disable. That will turn off the AirPlay device.

You’ll go back to having playback start delays on 16 bit content but that will be corrected very soon.

Got it back.
But I do still have the delay.

Thanks for your help.

Fix is coming. Soon.

Yup, just a quick update for @G997 @Joseph_Gerardi @Jaroslaw_Orszanski and any other dCS users experiencing this issue.

We did some testing on Friday and determined that this regression was related to a low-level networking change. We put a fix for this into testing on Friday, and hope to release a surgical build to address this regression in the next few days.

We appreciate everyone’s patience!

1 Like

Hello, this is my first post. We are experiencing an issue with our Roon system. This is a new wrinkle that did not happen at first. When we select a track to play there is a 10 second delay before the chosen track actually plays. I have been able to get the lag down to 1 second if we change our dsp engine settings for sample rate conversion. If we have this feature disabled the lag occurs at 10 seconds of delay before a track plays. If we enable sample rate conversion the player behaves properly. Delay is about 1 second. This occurs on my Rossini as well as my dCS Network Streamer. I do have a couple of BluOS devices here as well and they work fine. No lag regardless of sample rate settings.
My system consists of:
Roon core running on an HP desktop computer.
Music files located on a Synology NAS drive
All dCS pieces are hardwired to my network
Computer and NAS are hardwired to my network
Network router is a Luxul XWR-3100V1

We suspect this problem may have begun after a recent update to our Roon which is set to auto update. However, we cannot be sure.

Hi @Miguel_Velez,

This is a known issue and is in the process of being corrected. As @mike mentioned above the issue has been identified and a fix is going through testing now. Assuming all goes well there will be a Roon update which corrects the problem in the coming days.

Hi All,

Roon build 300 is rolling out now and this will correct the playback start delay that you’ve been experiencing.


Yup, thanks for your patience @G997 @Joseph_Gerardi @Allan_Hsu @Jaroslaw_Orszanski @AmusedTDBuild 300 is rolling out now.

Big thank you to the incomparable @AMP for helping us nail this one so quickly!


Now there is a delay shuffling from a 96 file to a 44.1 file (resync set to 0)
In the past the delay was always going up in resolution…
When will this ever be solved???

Looks like Build 300 fixed this problem for me with my Network Bridge. Thanks for the update.