Playback Jitter/Distortion/crackling for 1-3 seconds every 10-20 seconds

Core Machine (Operating system/System info/Roon build number)

iMAC intel quad core 3ghz 16gb ram OSX Big Sur 11.0.1 (20850) Roon 1.7 build 667 (latest)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Xfinity Router, have tried both WiFi and Ethernet, there is no difference in the issue…

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Blusound Node 2i, Connected to External Pagoda DAC via optical (also tried coax), (also tried without DAC straight RCA, but same results) going to Rega Amp, (also tried different amp), Zu Speakers.

Description Of Issue

I am new to Roon, and this problem is there from the first song i played. I have tried ALOT of things including suggestions on this forum and google searches.

No matter what i play, whether local file or qoboz, the music distorts/jitters/stutters every 10 seconds or so, very easily reproducible. I can play (and have been for years) from Itunes Via airplay to the bluesound or the qoboz app just fine. never had a problem i have hi speed network close, but i tried both WiFi and Ethernet, but it does the exact same thing on both.
I have tried changing just about every setting in both the blusound app and the roon settings. As a test i also just tried through a headphone amp and its fine, so the issue seems to be with communication between blusound and roon applications. I have used the blusound without any issues for years, and even now, if i just use Itunes or QoBoz through bluesound there is No issue. It was only introduced when trying to use Roon. I am very technical so have tried troubleshooting for hours, but am out of ideas.

Please Help!!!

Eric M
Sausalito, CA


Welcome to the forum. I am just another user, but while you’re waiting for support to show up, I thought I would ask whether you have a managed switch in your system somewhere. When someone can play from the native app (like Blusound) but not through Roon, it is often a network issue somewhere in the chain, Roon is far more demanding on your network than most applications, which often leads to issues,

no managed switch. plays fine from bluesound just not roon… i am seeing lots of other users with the same issue. my network has never had any problems. i’ve even tried ethernet to rule out network issues.

thank you. i’m open to any other suggestions

Your core machine is an iMac. Can you play from its internal speakers without the same distortion? Just trying to figure out where in the chain the issue is occurring.

Yes. Plays fine through mac or through my headphone amp attached to the USB on the iMac. thanks for any assistance you can offer. :slight_smile:

If it plays fine from the core and the issues still arise if you go from the Node directly to your amp, then it would seem that the Node 2i is the issue. Based on other comments in the forum, I think that these units don’t always work well with Roon.

Do you have the latest BluOs installed on the Node?

Good News!
I found another post here with same symptoms that suggested a Bluesound factory reset, so i just tried it and it appears to have WORKED?!?!@?#! i kind of can’t believe it. but give that a try: Steps pasted below:

You will know the factory reset is successful if the player returns to Hotspot mode (wireless connection - the LED will turn solid green).

If the player is connected to your network through a wired Ethernet connection, it will simply connect as if it was a new player (LED will turn solid blue).


Eric - Please keep us updated on whether fix continues to work. I have a virtually identical set up and situation (no glitches in blue sound player or iTunes but glitches timed just like yours in Roon). Don’t want to reset my Bluesound players unless I am sure this is a permanent fix. Thanks.

you should do it. it sounds dramatic, but it’s easy to do and reconnect to your services. happy to help if you have trouble after the reset. it’s been such a relief after signing up and thinking i would have to cancel :)… good luck.


1 Like

Hi @Eric_Markowitz,

Thanks for letting us know that the factory reset helped with this issue! If you have any further difficulties with Roon, please just let us know and we can take another look. Hope you enjoy trialing Roon!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.