Playback keeps failing via SOtM Roon Ready Endpoint


I am currently facing an issue where playback fails constantly with messages like “Roon has lost control of audio device” (sometimes I don’t even see the message, but it fails anyway).
I would like to understand how to troubleshoot where the issue is, since I have fully uninstalled Roon and reset my Roon Endpoint and nothing changed.
Prior to my Roon Endpoint update, I was running both Roon Core and Endpoint in the machines where they are today, for more than one month without a single issue.

Core: Mac Mini Late 2014 (i5, 8GB) -> CAT5e cable -> TP Link TL-SG105 switch
Endpoint: SOtM sMS-200 Ultra Neo (with sPS-500 power supply) -> CAT6 cable -> same switch
DAC: T+A DAC8DSD (previously Chord Hugo2, but even the T+A worked for days with no issues) connected to SOtM via QED Reference USB Cable
Music Folder: Synology DS216j+ -> CAT6 cable -> same switch
Music Streaming: TIDAL HiFi

So, what changed? I tried to get NativeDSD through a firmware update on my SOtM unit, and while testing the same I ended up with an issue on the boot SD card, which led me to reinstall the bridge completely from a new card.
Since that moment I cannot get a stable playback even without DSP. Before this situation I had scenarios like playing music 36h straight (during DAC burn-in) with DSP upsampling to DSD128, and no issues.

I am not saying this issue relates to Roon software, but if you could assist me troubleshoot it, I would appreciate - I have little-to-none relevant information to share…

Meanwhile SOtM asked me to configure my network differently because they say that having my router both as Gateway and DNS server is incorrect, but at least here in Portugal this is the setup every ISP has on the equipments they install at customer homes… And, again, this did not happen before - not even once…


1 Like

First, you may want to isolate the problem to which component is the cause. BTW, I agree with you that there is no issue with using your router for both Internet gateway and DNS server.

  1. Eliminate Tidal streaming as the issue. I’ve been getting error messages lately when trying to stream Tidal. Put some music on your Mac Mini, get Roon to scan it, and then try streaming from your onboard music. If you can stream for hours with no issues, then Tidal may be the issue for you.

  2. Eliminate the SOtM as the issue. Connect your Mac Mini to your DAC via USB and use Roon Core to stream directly to your DAC. If this works, then it’s most likely your SOtM that is the issue.

  3. What firmware update did you do? I’ve got a SOtM sMS-200 Ultra (non-NEO) and it has been streaming DSD for years without a firmware update. When you had the issue with the boot SD card, did you get a new one from SOtM or make a new one yourself?

I hope this helps.

1 Like

Thanks so much for those inputs, Karl. Commenting on that:

  1. “local” music comes from my NAS and has drops also. I’ll try to move some to the Mac’s HDD and see it anything changes. I was also considering “simplification” by removing the switch for now and have all equipment straight to my router

  2. Yep, this would be the next logical thing. Haven’t given up on the sotm yet (always trying something else) and therefore haven’t done it. I’ll try it today

  3. a) Unit came with 0.4.22 (and kernel 4.14). While trying to get DSD512, May from SOtM asked me to update to beta versions 0.4.23 and kernel 4.18. Release notes for 0.4.23 say it is the one that adds DSD512 and updates Roon Ready. DSD512 was still not available (lacking driver for T+A, SOtM currently working on it) but playback worked flawlessly
    b) SD Card was suddenly dead (too much attempts on fw update? could it really be that?). Replaced with an EMTEC 16GB class 10 (up to 85MB/s). Image burned as per SOtM’s instructions, via Windows (Mac image didn’t work and Computer Audiophile feedback suggests the same). In the meantime, to be sure that image was not flawed (as the mac), I have again updated to beta 0.4.23 and kernel 4.18. But since the old card died, no luck on playback.

According to T+A, this DAC is not compatible with Linux. And having read the years worth of Linux/DSD issues with this DAC I would never use it with Linux. If you really want DSD512, then setup a Windows PC, run the T+A drivers, connect USB. Done.

Thanks Rugby. Nevertheless, it shows as supported in sotm’s Linux (V2.0). Are you aware of customer feedback stating otherwise?

Well this has been a crazy evening:
1 - remove switch - error continues
2 - remove sotm - error continues
3 - use audirvana instead of roon - error continues
4 - move files from NAS to HDD - error continues
5 - replace mac mini with ROCK (NUC) - error continues

When I reached this point, only dac and usb cable were the same. So, I removed QED Reference USB and inserted T+A’s OEM cable. I am now playing tidal for 20min without interruption… Could it be a faulty/wrongly attached cable? I’ll leave the other one a bit more, then revert to QED…

My experience with SMS-200 is that the OS can become corrupted and result in all sorts of arifacts.

If all else fails, try re-flashing the OS.

1 Like

Well… confirmed: 2h listening to music with no cuts. USB was either faulty or got loose somehow (perhaps when I moved SOtM to remove its SD card).

Today I’ll get the full chain back on - my Mac, switch, NAS, SOtM - and still leave T+A’s OEM USB cable. I will then move to QED’s the following day, and assess its behaviour.

Thanks so much, guys!

1 Like