Playback randomly unable to resume if left stopped for any period of time

Roon Core Machine

Roon Server (Roon version 2.0 build (1182))
Lenovo ThinkStation P500
Ubuntu 22.04.1 LTS 64bit
16.0GiB Ram, Intel Xeon 3.5GHz x 12core

Roon Client (Roon version 2.0 (build 1182))
Mac Mini Late 2014
macOS Monterey 12.6.2
4GiB Ram, Intel i5 1.4GHz x 2core
Using internal optical audio output

Roon Remotes
iPhone X, iPad Pro

Networking Gear & Setup Details

Roon remotes over WIFI on Netgear R7000P
Roon Client Hardwired ethernet to Netgear R7000P
Roon Server Hardwired ethernet to Netgear R6300

Both Netgear routers are linked with ethernet - with the R6300 functioning as extension to R7000P (same subnet etc and using exclusive IP ranges from each other).

Connected Audio Devices

Optical audio output to a Denon AVC A1 SE Amp.
The mac mini is not used for anything else. It’s a headless device.
I have tried an external usb>optical device and this was the same.

Number of Tracks in Library

Local library 48561 tracks, 1272 Artists, Mostly FLAC format
Streaming from Qobuz

Description of Issue

Problem: If music is stopped the remote is unable to recommence playback of the same album or any new material (from local or from streaming).

Frequency: This does not happen all the time. It is random and sometimes can be within an hour of the last play, sometimes overnight. Only once have I observed it while actively playing music and wanting to pick another track during a session. I tend to play an hour or so of music a day and stop for meetings randomly. On an average day I’ll see this problem 1-2x.

Observations: The play head stays at zero. Clicking on the signal path coloured dot shows a processing speed of ‘x’ i.e. not processing. I usually see 29.5x speed etc when pulling files off my local server. There appears to be a timeout before it tries the next track, maybe 10seconds or so. I have been typically holding the pause button at the end of each play session to try to release the control over audio devices in the Mac Mini.

Resolutions: The only way to fix this issue is to close Roon Client on the Mac Mini and then reopen it. Then play can be started from Roon Client locally or from any of the roon remotes.

Signal path

Welcome to the community, @Glen_Johnson.

A couple of things comes to mind:

  1. Is your core suspending to RAM?
  1. The processor in your core (Xeon) cannot cope with the DSP, i.e., processing speed drops below 1x. Can you try playing without using the convolution filter? Does the problem reoccur.

What model Xeon processor do you have?

Hi Martin,

The server that Roon is on is pretty powerful. It also runs Plex and manages a lot of heavy duty transcoding without any issues. Specs below:

The problem was happening before I started using a convolution filter. I’ll try turning off all DSP and see how I go for a few days. My feeling is that it’s the Mac Mini that’s the problem - Not the Lenovo Ubuntu Server - as the problem is resolved by quitting and reopening Roon on the Mac Mini.

The reason I ask is to establish if you have 12 cores or 12 threads, and the single thread performance. My Xeon E3-1225 v5 has reasonable single thread performance (2087), but doesn’t perform as well as a Core i3-8109U of the same period (2125.)

Yes, you are right, it doesn’t have 12 cores. It has 6.

CPU Specifications

Total Cores 6
Total Threads 12
Max Turbo Frequency 3.80 GHz
Intel® Turbo Boost Technology 2.0 Frequency 3.80 GHz
Processor Base Frequency 3.20 GHz
Cache 12 MB Intel® Smart Cache

Since you have the Intel Xeon E5-1650 v3, you should be fine, albeit don’t expect the same performance as a comparable Core i3.

What happens if you disable all DSP?

Here’s the Ubuntu server task/CPU load with no DSP and no upsampling 1 second after starting a new track via remote on my phone through the mac mini client.

Here’s the Ubuntu server task/CPU with DSP doing convolution and speaker correction + upsampling to 96kHz. This load is sustained for about 5 seconds after starting a new track playing and then it settles down to idle like the above one.

I really don’t think the Ubuntu server is being pushed too hard here.

My question required a simpler answer. :slight_smile: Does it play, or do you still have the issue?

If you do, then we need to look elsewhere for the problem.

Hi Martin, Given that the problem has been random, but typically at least one per day, I have needed more than a day to test it. So far, with all dsp and upsampling off for the last 36 hours or so, I haven’t had the ‘paused/no-replay’ problem at all. I’ve tried multiple different remotes and clients and not restarted the client on the mac mini at all. I’m going to turn upsampling on and then trial it for another 2 days to see if it stays stable.

1 Like

Since enabling upsampling (but not DSP) I’ve had another day of stable playback and been able to resume from pause without issue. I’ll now turn the DSP filters back on (convolution and speaker settings) and see how I go for another day.

I’ve enabled the DSP filters (convolution and speaker settings) and given things a detailed thrashing for the last 24 hours and have not had a single problem. For clarity: everything that was turned on previously is now back on and the problem is no longer occurring.

Well that’s good news although unsatisfactory in terms of understanding what was the cause.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.