Playback stops after 5 tracks

Roon Core Machine


Networking Gear & Setup Details

Netgear pgc510p
Cat6 ethernet

Connected Audio Devices

X45 Pro

Number of Tracks in Library


Description of Issue

Since the latest update, when playing a 6th track the roon shows that’s it’s playing, however no playback on the x45. It shows the track on the x45 display, but no runtime counter or audio output.

Switching the input on the x45 triggers on the room that the input switched on the device. Then when press play on roon, the track that was previously ‘stuck’ plays fine, until the next 5 tracks have played, where it becomes ‘stuck’ again.

Have restarted all devices, reinstalled roon os on Nucleus, no change.

Hey @Garry_Paternoster,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

I wanted to follow up on this thread to see if you were still running into playback issues on your X45? Please make sure you are up to date on the newest Roon Build and let me know if your issue continues.

If it does, please share the name of the song that you experience stoppage with. I’ll be monitoring this thread for your reply :pray:

Ben, I am running the latest build and software upgrades on both and until the latest upgrade all was well and stable this only started happening after the upgrade. It is very frustrating it is no particular track and appears to happen more or less when you search through the track library that precipitates the problem as it will play full albums if left to run on it’s own. Nothing has changed with the setup otherwise as it is a very straight forward setup, if I use the X45 pro Neo software it runs perfect but this lacks the Roon usability interface.

Hey @Garry_Paternoster,

To confirm, it is no longer specifically the 6th track in your queue that playback stops? Rather, its when you are streaming audio while scrolling through your track library?

For tracking purposes, please share the name of the song as well as the date and time that you experience stoppage with :+1:

Ben, the situation is a follows bit a little hard to describe correctly as it appears to be non specific to any particular track. I am only talking about tracks in my library as I do not stream from any services it is a straight forward setup with my X45 Pro as the end point. If I start room on my tablet to select an album or track most times it will play straight off no issue. If I let the album play through or let Roon chose the music no problem it is when I select another track or album that the problem starts by either advancing to the next track it will nearly always stall. By tapping the pause all button in the lower right hand corner stopping all functions then selecting the play button usually having to tap it twice the track will play. During the non playing process the track bar will oscillate back and forth for a few seconds before it usually then plays but not always and this does not always happen and is why it is so frustrating. Prior to the second last upgrade the entire system was very stable but as soon as the update installed issues started to happen and yes in the beginning it was about every fifth track it would happen. It is possible the last update changed something that now the fault exhibits as now described, is it possible there is a conflict with a recent CA firmware upgrade although using the x45 Pro control interface everything functions as it should no issues so I ruled this out initially. Does Roon check comparability with manufacturers firmware prior to release of upgrades or is it just Russian roulette no news is good news? Any help sorting this would be appreciated as I am a lifetime subscriber and a 150+ hour a month listener and generally love the Roon product, looking forward to any answers thanks.

Hey @Garry_Paternoster,

Thank you for the detailed update on your issue!

A follow-up question for you: does this issue only occur on your Lenovo TB-X606F? If possible, can you test out other remotes to see if the issue occurs?

And following up on that, does this issue occur when playing music on Roon Arc?

Write down the date and time the next time this happens and we’ll enable diagnostics on your account to take a deeper look (otherwise, it’s like searching for a needle in the haystack).

Thanks, Garry!

Ben, tried the app on my phone (Samsung A53) same problem and also activated ARC to see it this made any difference with the same result across the two devices. Whatever the issue is it happens the same on any of the devices and also once you minimize the app on either of the devices and then try to operate it again bringing it back to action a process the screen is frozen. To get it to respond at all you need to close the app then reopen it again and it works?

Tried a number of tracks and albums across the night with the same stalling fault only rectified by tapping the Pause all button then tapping the play button twice to return function of the music. I will make not of the times and tracks when next listening to report the further specific tracks but at this stage it does not matter what track is played the same fault is the result, will further update to night when listening thanks.

Ben, started tonight listening session as follows.
7:43pm Gary Numan prayer for unborn, pressed play button purple light went out nothing happened. Pushed play again music played.
7:47pm pushed next button Starset something wicked, purple light went out nothing played, tapped play button again music played.
7:49pm selected home menu, selected Katatonia Austerity purple light on progress bar active no sound, tapped pause all button then play button twice started playing?
7:54pm song abruptly plays next track unprompted Katatonia Atrium Roon Focus is active.
7:58pm plays next track Skyharbor Celestial, 8:01pm select next track plays Ok Bia in heart wake.
8:04pm select Katatonia Lacquer purple light on progress bar moves No Sound, tap pause all button then tap play button twice music plays.
8:09pm Roon Focus plays Broken by Voices from the fuselage no issue.

Listening now 9:47pm Roon playing a selection of tracks with no selection by me no issue until I want to select Artist or tracks manually problem as previously described happens as described every time. Repeating the same actions restores the music playing very frustrating , as noted before prior to ARC upgrade everything was working fine and stable since then withe the following upgrades things have changed as described.

Hope this helps find the issue.

Hey @Garry_Paternoster,

Thanks for the additional information. A follow-up question for you: does this issue occur if you stream audio from the system output of your A53 or Levono?

With that, lets clear your RAATServer database. You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the RoonServer in the WebUI to generate a new RAATServer

Before restoring anything, please test to see if you encounter the same issue :+1:

Morning Ben, after an overnight rebuild answers as follows.
Does the same issue happen with streaming to tablet or A53 Yes.
Checking this morning there has been no change to the issue except for the following, commands from the tablet or phone are almost instant never been like this before. When restarting the music after tapping the pause all tab if you do not wait a couple of seconds nothing happens when tapping the play tab, can take six or so taps to work.

If you wait a couple of seconds then tap it plays on either the first or second tap, progress bar and purple light do not appear to vanish or oscillate like previous and all history has been wiped. So based on this situation there is still a major issue with the systems operation. Am I the only one running a CA X45 Pro end point? Is there a comparability issue with CA’s latest firmware upgrade and the Roon ARC OS as this only happened after this role out prior it was fine without issue.

Operating the X45 using the CA Neo interface does not present any operating problems that I have found but there is obviously some compatability issue causing this situation now with the system. Unfortunately I do not currently have another Roon end point device that I can test with, appreciate your ongoing efforts with this but it does need to be sorted thank you.

Hey @Garry_Paternoster,

Thanks for the update.

Are you not able to stream audio from any of the system outputs of your remotes? I ask this to see if you’re seeing this issue no matter the endpoint. If you’re able to stream audio normally from the output of your Lenovo or your SM-A536E, or perhaps a computer being used as a remote, then the issue is tied to the X45 directly.

With that, I don’t see any information around how your X45’s are connected to your core - can you provide more information about this?

Beyond that, we’re still not seeing any direct indication in your core logs around what might be happening outside of your typical network errors. If you haven’t yet, I would give both the x45 and your router/network a hard reboot (leave it unplugged for a few minutes) and reboot.

If you could again reproduce the issue and share the track name and the date+time the issue happens, that would be helpful.

Good afternoon Ben,
further experimentation with my system has revealed the following, I managed to stream to the Lenovo tablet without incident on all functions so I believe this now rules out a ROON specific fault. I also opened up the CA Neo-X system on the tablet and while using the usual Roon program it appears that all issues magically stop? Close the Neo-X program and the issues return but how this interaction happens I do not know, I can use the Neo-X program or Roon and there is an Audible click from the X-45 when the switch is made but both operating systems function when independently selected. I will need to email Mr Kim with this problem to see if this has been reported by anyone else as in the past with some other issues concerning the X45 Pro I found him to be very helpful, will keep you advised of the progress in the new year thanks again.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.