Playback sync issues

Roon Core Machine

Windows 10 desktop, i7-9700K CPU 3.6GHz, 32GB RAM

Networking Gear & Setup Details

Eero mesh network (WiFi)

Connected Audio Devices

BlueSound Node (Roon ready)
BlueSound Pulse M (Roon ready)
Sonos Amp (via Sonos streaming)

Number of Tracks in Library

About 2,000 tracks

Description of Issue

I’m having trouble getting my devices to play in sync with each other. Even if I group my two BlueSound devices together in Roon which are supposed to be Roon-ready, they are off by half a beat or so. When these devices are in earshot of each other it’s quite distracting. I mostly listen to Internet radio, but the problem persists even when playing my own library.

I tried fiddling with the Resync Delay and Zone Grouping Delay settings, setting them both to 1000ms, but it didn’t seem to help.

Is there a trick to this, or something else I should check?

hi,
Can you test with them ethernet connected? Your core desktop then the devices

The core is already on Ethernet.

It would take a really, really long cable to reach the living room setup which isn’t portable… I’ll have to think of something creative there…

Something I noticed yesterday is that even when just using the Bluesound app the two Bluesound devices would not sync properly. Might be a Bluesound issue as opposed to a Roon issue. (A feature idea would be the ability to add a delay to specific devices to give us a way to compensate for issues like this)

Just go to your router with some small speakers… or head phones. Just to rule out one thing…

Yesterday for the first time grouped a usb from Mac mini core with a iFi Zen streamer, switching back and forward from the preamp they were in sync (probably not exactly but with no noticeable difference)

Never used bluesound, but does the app have a way to group devices?

Right, I’ll try with headphones & report back. Thanks :slight_smile:

Yes, Bluesound has its own grouping feature, and that doesn’t sync up either.

I have never tried group zone delay but maybe works. But I do not know how you should measure the delay

Oh, maybe that’s what that setting is for! I’ll give it a try, thanks for pointing that out.

1 Like

Sounds like what you need. Hope it works
Traian

Hey @Frank_Kane,

I wanted to follow up on this thread to see if @Traian_Boldea’s suggestions were helpful? Thank you @Traian_Boldea for your help on this thread regardless! These are all excellent things to test :+1:

1 Like

Thanks for checking in! Afraid the issue persists; nothing I’ve tried seems to get grouped players in sync. I’ve adapted by just playing one device at a time, or keeping the volumes low enough so different zones in the house don’t interfere with each other.

I have found that grouping my players in the BlueSound app and playing through it doesn’t sync properly either, so I suspect the issue is at some layer below Roon at this point.

1 Like

Hey @Frank_Kane,

Thanks for the update, and I’m sorry to hear you’re still running into issues! From your testing so far, it is very possible the issue is outside of Roon.

Either way, I’m curious how your endpoints are connected to your router - are you able to test hardwiring them to your network?

Have you tried setting up Roon (or another streamer) on a different core device, and test if the same issue occurs?

If you can, please grab a timestamp (date,time) of when this issue occurs (when playing Roon) and share that information here. We may be able to find a hint as to what the issue is.

Lastly, I would triple-check that the firmware is up to date on each of your endpoints :+1:

1 Like

OK, I bit the bullet and dragged both BlueSound devices to my office and hooked them up to wired Ethernet on the same hub as the Roon Core. And… they are in sync!

I find it hard to believe that my Eero mesh network is introducing hundreds of milliseconds of latency. Perhaps the real issue with with my A/V receiver that the Bluesound Node is connected to. In the office, I’m listening via headphones hooked up to it directly which might also be a relevant difference.

In the problematic configuration, the core (ROCK on an Intel NUC) is hard wired to the network, but the two BlueSound devices are on wifi.

1 Like

Good news :slight_smile:
Can you try at home? maybe with a cheap switch? Try with and without the A/V
I hate cables but wifi never works so reliable

Sorry I wasn’t clear - it’s my home office I was talking about. Same network.

And yes, next test is using headphones while connected to the receiver… unfortunately running wired ethernet to the players in their intended zones just isn’t possible the way our house is built, as much as I’d love to. I’m hoping it’s just some DSP mode on my receiver that’s to blame.

Thanks for your continued help :slight_smile:

:slight_smile:

There are some flat ethernet cables easier to install. Or maybe try to get the bluesounds as close as possible to the wifi.
You are welcome,
I have 2 endpoints in sync (pretty close to each other) and it would be annoying to notice delays

Well I put the devices back where they were, and tried hooking up headphones to the BlueSound Node to take the receiver out of the equation. I still heard about a 100ms delay compared to the BlueSound Pulse speaker. So I guess that does point to the wifi network after all, somehow.

If anyone on Roon’s end wants to investigate further, I did that at about 4 PM Eastern time today (Jan 25). I checked and the devices’ firmware seems to be OK.

1 Like