“Playback was interrupted because a track failed to load” Linux Core

Roon Core Machine

Model: VMware Virtual Machine running on vSphere Hypervisor 6.7 U3
CPU: Intel Xeon CPU E3-1240 V2 @ 3.40GHz (4 vCPU’s assigned)
OS: Alma Linux 8.6

Networking Gear & Setup Details

Core connected with ethernet to a UniFi USW 16 PoE switch
Bridge connected with ethernet to a UniFi USW Flex Mini switch
Remotes connected through WiFi (Android Phones or Windows devices)

Description of Issue

A few months back, I posted an issue regarding a compatibility issue between Roon and Open VM Tools:

After migrating my Roon Core from Debian 10 running on a Hyper-V server to Alma Linux 8 running on ESXi Hypervisor 6.7 U3, Roon seems to experience some weird issues when the open-vm-tools package (Open source version of the VMware Tools package used for interaction between the guest OS and the hypervisor) is installed on the core.

Without the package installed, I’m able to play anything without issue. When installed, I get the “Playback was interrupted because a track failed to load” error message, no matter I try to play something from Tidal or from my local library.

Devices are all on the same subnet.
Core and bridge have a static IP
Firewall & SELinux are disabled on the core.

Someone moved my thread to the tinkering section stating that “VMware isn’t a supported platform”.
I have to disagree. My Roon core is running on Linux which is a supported platform regarding Roon’s official documentation. Running an operating system on bare metal hardware or a virtual machine shouldn’t make any difference given Linux is a supported guest operating system within VMware Hypervisor.

So there are no issues running Roon on Linux in your VM.

So there are issues when the open-vm-tools package is installed.

Which IMO brings us somehow back to: “VMware isn’t a supported platform”

Roon is not tested or developed to run on virtual machines and the installation of the open-vm-tools, which are tied to the use case of running as guest OS under VMware, then what should Roon support do to help you? When it works with the pure Linux installation without the open-vm-tool, use it that way. Also other users of this forum may not have ran into this issue or do not use your setup it seems as you got no response on your first thread. Just creating a new thread for the same issue in the wrong forum category again is unlikely to help you resolve your issue.

Just my two cents.

Hi there,

Thanks for the reply.

I get your point, but Open VM Tools is basically a driver package for the guest OS.

If I follow this logic, if Roon Core was installed on a bare metal Windows machine and some compatibility issues were detected with a specific driver for an ethernet card. Would my thread be sent back to the tinkering section?

Running into compatibility issues when providing a cross-platform application is something common, but the way such support requests get handled are less.

And if I may be picky, it seems there’s no clear mention about Roon’s position on their support pages regarding the use of Roon Core on a virtual machine.


Sorry @Owlmerely, but @BlackJack is correct - Support will not be able to help you with an installation run in a VM. That is not a standard installation tested and supported by Roon Labs. Your best chance is that someone in the #tinkering category has tried this and solved the issue for themselves.

I’m going to close this Support request. I hope that you will get some reactions from the tinkering community for your issue.

Hi Goeff,

Thanks for reply.

But as mentioned earlier, this should then be stated somewhere into the Roon System Requirements page or somewhere else in the official support pages. There’s no mention about Virtual Machines not being officially supported.
The only page I found regarding the “No VM Support” statement is a forum post regarding the use of ROCK on unsupported hardware, which is not my case.

Best regards,