Playing, but no sound after downloading latest Roon for Android [Solved]

I am experiencing a real oddity: After downloading latest version, roon will not grant any sound, even though roon itself is progressing through the track.

All other media players on this device is working properly (with sound).

In the previous version, Roon was playing, then stopping for some seconds, then playing again, while competing media players could play the same track without errors (fetched from a usb HDD connected to Roon server)

What could possibly be the reason? Why isnt roon discovering and reporting that it is in trouble?

Others with the same problem on Android?

Problem solved:

As old roon version was playing with glitches, I downloaded a new version, causing this silence. The possible reason could be that roon disabled the device audio out (a LG V10), however the default out WAS showing as current choice and nothing wrong was seen in the audio setup.

Thus, I deleted Roon, and reinstalled. Now the default out was showing as disabled. After enabling, things are ok again.