Please help: Keep losing connection to ROCK

Core Machine (Operating system/System info/Roon build number)

Operation System Version 1.0 (build 227)/Server Version 1.7 (build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Xfinity high speed cable router. NUC is connected via CAT 5 cable. All endpoint devices are wireless.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Various endpoints that are affected by the issue equally

Description Of Issue

Several times a day, all wifi devices lose connection to the ROCK, which is a recently built Intel NUC8i5BEK with a 500 GB Samsung 970 EVOPlus and 32 GB DDR4-2400. NUC video output is hooked up to my TV on HDMI 3 so I can monitor it. Even when I lose connection, the display continues to show that ROCK is running with an IP address of either or (will change sometimes after I force a reboot). Forcing a reboot always brings back the ROCK on all wifi devices until I lose it again, which is typically not more than a few hours.

I am running an external 500 GB USB 3.0 2.5" HDD for my personal music files. Also running Qobuz and Tidal via subscription. No other devices are connected to the NUC.

When all devices lose connection to the ROCK, sometimes Fing will find the ROCK and sometimes it will not. When the devices lose connection, I also lose the ability to get to the ROCK via the IP address. A reboot always solves the problem but this is obviously quite frustrating. Any help would be appreciate.

Thank you.

Update: Just lost connection to my ROCK server while listening to Roon on my TV that is connected directly to the Xfinity router via CAT 5. The other device connected to the router is the NUC. The music stopped suddenly and I did troubleshooting. Tried restarting router with no luck. Tried disconnecting attached USB drive with music files. No luck. Tried disconnecting CAT 5 cable from NUC with no luck. Screen still shows that the NUC is running with IP address of but I cannot reach that address on any devices and Fing shows the ROCK is offline. I then did what I always do, force a hard reboot of the NUC which immediately solved the problem. Could this be an internal problem with the NUC?

Hi @Gooey,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the problem occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi Dylan. Just lost the connection on all devices at approximately 09:02:20 EST on Nov 24, 2020. Both my wife and I noticed it on two different devices running different music streams. A hard reset of the ROCK immediately brought everything back up. Thank you.

Hello @Gooey,

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hello @Gooey, I received your report and took a look around the timestamp you posted. I found what looks to be DNS related networking issues so I wanted to know what DNS you are currently using, if your NUC is operating well outside of this issue, and whether or not you can reach the WebUI when the issue occurs. Please let me know!

Hi @nuwriy, When the issue happens, I cannot get to the WebUI. I have installed Fing on my iPhone and when it happens, the NUC appears offline. I use Xfinity for my cable. Network shows the following:
Local address
ROCK is currently assigned but sometimes it’s (assigned dynamically)

That is not a valid address. It can sometimes happen if there are two DNS servers on a network. Do you have two routers in your network?

I got that from Fing. Just looked up the DNS server on my Xfinity app and it shows this:

DNS Mode: DHCPv4
Primary DNS:
Secondary DNS: 2001:558:feed::1

Just returned home after being out from 1435-1750 EST. Sometime during that period, I lost connection to ROCK.

Lost connection again sometime between 2000-2145 EST.

Hello @Gooey, could you please try switching to Google or Cloudflare DNS and seeing if that helps?

Hi @nuwriy, I just set up Cloudflare. Let me know what else you need me to do.

Hi @nuwriy, At 5:09 PM EST, lost connection to ROCK. This was after having switched to Cloudflare DNS 3 hrs ago. When I checked the NUC display, it was a page full of text I have not seen before. I waited for a few minutes then did a reboot and ROCK is back up.

Is a Comcast DNS. You might try changing that to if you are using as your Primary DNS.

Thank you @Rugby. I have changed my primary DNS to and secondary to

So I am confused about something. When asked by @nuwrly to change to Google or Cloudflare DNS, I looked up how to change DNS on my Mac and subsequently went into Advanced settings and changed it. I then decided to check to Xfinity app to see what it says about my network. It reports that the DNS Server is as follows:
Primary DNS
Secondary DNS 2001:558:feed::1

Seeing this made me think I have to change the Ethernet DNS, so I disconnected the CAT 5 from the NUC and attached a MacBook to it instead. I then changed the Ethernet DNS setting to and

I guess I’m confused. Do I need to call Xfinity and have them change the DNS?

Lost connection to the ROCK again last night sometime between 9:00 PM EST on 11/27 and 5:50 AM on 11/28. Checked Fing and the ROCK showed it was offline. For what it’s worth, my new PecanPi Ultra, installed yesterday, did indeed show it was still connected to my network and it immediately connected to the ROCK upon reboot of the NUC. Thanks.

At 8:33 AM EST on 11/28, lost the ROCK for about 30 seconds then it came back on its own this time.

At 5:36 PM EST on 11/28, lost the ROCK while listening to Roon. Checked Fing and it showed ROCK was offline. A forced reboot immediately brought it up again.

At 7:49 PM EST on 11/28, lost ROCK again while listening to Roon. Fing shows ROCK is online this time but I cannot connect to it via any device or via the web IP address.