Please try this simple test if you subscribe to Qobuz (and Roon)

After getting my Roon up and running very nicely with my own flac library, I ran into a curious problem when connecting to Qobuz. I wonder if anyone else can reproduce it.

Here are the steps to try:

  1. Search for ‘copland in the beginning’

  2. Qobuz will offer as its ‘Top result’ a recording called American Voices, which has this composition by Aaron Copland. Click it.

  3. You should now see the following: ‘1947 / In the Beginning, for mezzo-soprano & chorus / Composed by Aaron Copland / 8 recordings / Modern, 16 minutes’ followed by the usual blue ‘Play now’ button. Click it.

  4. I get an immediate error from Roon, ‘Tracks played are unavailable’. Huh?

  5. If you now scroll down on this page you’ll soon see those ‘8 recordings’, all of which are perfectly playable.

This seems like a small but irritating glitch. Thoughts?

(Yes, I have indeed tried to isolate the precise conditions for this error. I think it needs to be a recording that doesn’t exist on your local library and has multiple versions available on Qobuz. Even when I can identify a piece meeting these two conditions, the ‘X recordings’ result is not reported for some mysterious reason, even though there are indeed many on Qobuz, and hence the glitch doesn’t occur.)

1 Like

It is the same here, using Android remote, Qobuz and Tidal.

Interesting, thanks. I wonder: is this a Roon bug or a Qobuz bug? (I don’t subscribe to Tidal. Are you saying you found the same glitch with a Tidal recording?)

Same error message here.

Looks like a bug. Nice find.

Qobuz and Tidal are versions for the same album. I don’t know the version Roon is trying to play at point 3 in your scenario.

I have followed your process, but what you find is a Composition.
When I click play now I get the same error message.

Now I see 9 ( nine), not eight) Recordings if I look down, and all of them do play.

So , the question (or issue) is why one cannot play the Composition in Roon.
In Qobuz, the notion Composition does not exist as in Roon, which means it is a Roon issue.

Yep, same result for me. “Tracks played are unavailable”.

Sometimes Roon finds tracks/albums/compositions that are unavailable on Qobuz in the sense that you can download them if you are a Qobuz subscriber, but not stream them.

For example, Roon gives this as a result for Mendelssohn Violin Concerto with the “Only Complete Recordings” switch set. But it isn’t completely available.

Hi Daniel. Not sure exactly what you meant by ‘versions for the same album’. But no matter, I only subscribe to Qobuz. I was asking you if you encountered this glitch for Tidal (as I encountered it for Qobuz).

Hi Dirk. Thanks for trying it out. Yes, I realized that I had found a ‘composition’. But that doesn’t seem to be determinative: other ‘compositions’ found on Qobuz play just fine using the steps I gave.

I agree that this is very likely a Roon bug, not a Qobuz bug.

Hi Jez. Interesting, thanks for checking.

I haven’t run across any music in Qobuz that can only be downloaded and not streamed. In fact, I just tried out your exact example and am now happily streaming Isabelle Faust’s excellent recording of the Mendelssohn right now. Not sure why yours shows up as ‘unavailable’. Do you actually subscribe to Qobuz?

I have no real experience with compositions, but what I do understand is that one should not mix terminology. In classical Roon uses Compositions and Works, compeletely different from Albums and tracks.
That being said, in practice most Compositions will include more than 1 track.
Maybe you should try to find another 1 ‘track’ composition, and check if it shows the same behaviour.
It is also possible there is just some (meta?)data error in Roon, where the Composition cannot be linked with (one of) the individual tracks.

I would report this at @support

For me the result is different - it shows the composer Aaron Copland (I subscribe to both Qobuz and Tidal). Same when search only through the Qobuz tab.

Thanks ricgf. But did you really search for “copland in the beginning”?

Hi Dirk. Can you explain further what you mean by ‘in classical [music] Roon uses Compositions and Works’? That may be true (although I haven’t seen this formulation anywhere) but it makes no sense: there is no sensible distinction between a composition and a work. To be clear: while I can’t speak for the non-classical music world, in classical music these two words are synonyms. If Roon is using them to mean something different that’s just a bad decision on their part.

But are they?

In this case, also unavailable.

My own guess is that in Roonish a “Composition” is the composition itself and not a specific recording of that composition. Hence it makes no sense to play that composition before choosing a specific recording.

I can accept that logic to some extent. But the logic falls apart in the face of the search result, which shows a picture of a specific album, right next to the usual blue “Play now” button. Any normal human would believe they could play this composition. Roon’s response should certainly not be “Tracks played are unavailable” (which doesn’t even make syntactic sense; they must really mean “Tracks selected are unplayable”?)

What a mess!

Hi Steven,

Interesting find and I can corroborate. A bit of a wild guess, but one of the eight recordings listed as available is actually not playable when selecting it individually from the recordings list. It’s the performance by the Choir of Merton College, Oxford, released January 10, 2011 which yields ‘This album was not found.’ I wonder if this has something to do with it.

Both Roon and Qobuz’ own app do include the corresponding album in the results for a search for e.g. ‘Merton College’, and this version is playable, including the specific track shown above. So somehow the album/track reference in the recordings list for the composition seems to be incorrect or malformed.

The message ‘Tracks played are unavailable’ makes no sense whatever it is triggered by, so definitely worth you flagging this to Roon, if it hasn’t been done already.

Thanks, tonedeaf. I too wondered if a single unavailable version spoils the whole bunch. But you’re right, it doesn’t really matter. It’s just incorrect behavior regardless. I’ll report it once I figure out how to cross-post this conversation to Support.

1 Like

@support should do the job, so it will be seen now I would think.

1 Like