Poorest sound quality when playing through Sonica DAC

Using the latest Roon build.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Linksys Velop WiFi to connect Roon Core on MacBook Pro to network

Description Of Issue
I am new to Roon and plead total ignorance but I can hear significant differences when playing the the exact same track (DSD64) with identical headphones directly from the Core via an Oppo USB HA-2 DAC (using this same method the SQ via Audirvana was even better, but that’s a different topic).


However the poorest quality was when I connected the Roon Core via USB to my Oppo Sonica DAC and then to an Arcam-rHead (w/balanced XLR cables) and then to the headphones. You can
see why here:

I can’t tell whether this is a Roon issue or hardware issue (faulty USB-C to USB-B cable?) but when re-setting up the Sonica (after deleting it) I could not get Roon to recognize the input method. It wants to use Airplay no matter what I do. Suggestions?

Well, my first suggestion is show a pic of your Settings/Audio. It looks like you are using OS Mixer when you should be using CoreAudio out for SQ.

Hi @Mark_Ellenbogen,

Welcome to the forum! It looks like your playing via System Output and Airplay, both which don’t support DSD playback in the native form and the content is downsampled to match the maximum sample rate of these zones.

I would navigate to Roon Settings -> Audio and take a look for the Oppo native driver, enable it and set Roon to output to this zone instead. More information on audio setup can be found in our Audio Basics Setup Guide.

Not 100% sure if this is what you mean but here is settings/audio:

Your Mac core doesn’t appear to be seeing the usb connection to the sonica dac, which on the Mac will only support up to dsd256 but it should work. Instead of a usb-c to b cable try a usb a-c cable and a usb c to a adapter

I can try this tomorrow with my sonica dac and my 2018mbp but it’s 1:25am here now

The sonica you are showing in other roon devices is the networked airplay instance…it’s going to sound horrid

Thanks @wizardofoz - I’m a bit confused about the cabling because the rear panel of the Sonica DAC’s only USB input is a usb-b, so I can get a usb a to b and then put a c adapter on the end of the “a” to plug it into my MacBook (where roon core resides and has 4 usb-c’s). And, yes, it sounded horrid.
Thanks @noris, but - alas - I have no idea where to look for the Oppo Native driver. I did read the Audio Basics Setup Guide but it did not help (me, at least). Still can’t see the light at the end of the tunnel, but I hope to!

1 Like

You could use an Apple usb-c to A adapter too but rather expensive. I have the HA-1 and 2 (not SE) also and like them a lot…I have a lot of dacs…and a couple of Oppo sonica speakers too

Hi @Mark_Ellenbogen,

It doesn’t look like the USB input for the Oppo is showing up under “Connected to Core”. It’s possible that its an issue with the USB connection, but I would check to see if you have any firewalls or Antivirus active that might be blocking Roon, this could also be a reason why the DAC does not show up with the native driver.

You can use these instructions from Apple to add Roon and RAATServer as exceptions to the native Mac Firewall, and I would try temporarily disabling any other Antivirus or Firewall software you may have (McAFee/Kaspersky/Bullguard/Little Snitch/ect.) as a test to see if the “Connected to Core” field populates with the Oppo.

1 Like

thanks very much @noris - adding roon to the firewall and disabling the antivirus software seemed to work - as the following then showed up under the Sonica when the cable was connected (nothing wrong with the cable, as I initially suspected):

1 Like

Glad to hear the firewall suggestion helped @Mark_Ellenbogen!
Since switching to the native Oppo driver, does the system work as expected and sound proper?
Shall I go ahead and mark this one as [Solved]?

It does sound much better. Consider it solved. Thanks @noris

1 Like

That’s fantastic news @Mark_Ellenbogen, I marked your thread as [Solved].
If you have any other issues, just let us know, hope you have a great Roon experience!

If you have a USB-C to USB-B cable it should work ok. not sure why the firewall would affect USB connection that’s probably not what fixed it and I’m not aware of any MAC drivers for Sonica DAC either so would not expect AV programs to affect USB either.

Sounds like you are up and running anyway so all is well…now go enjoy some tunes :stuck_out_tongue:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.