Popup screen keyboard issue with Windows 10 (build 1903) [Ticket In]

Core Machine (Operating system/System info/Roon build number)

Windows 10 build 1903 all patches, most current roon client and core

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Since updating to Windows 10 build 1903 a popup keyboard inside roon sort of blocks entering text. After clicking the search icon the textbox pops up (expected) followed by a screen keyboard (unexpected) which closes immediately (unexpected) followed by closing the textbox (unexpected).

It does not seem to be the windows screen keyboard, which I have deactivated. Upon activating the windows screen keyboard the same thing happens as with the physical keyboard.

This behaviour is true for all kinds of text entry like naming devices etc. It renders roon almost completely useless (no search, no music).

Hi @Joachim_Herbert,

I wanted to touch base with some good news, which is that our technical team has been able to reproduce this behavior and we’ve opened up a bug report with our developers.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved. Thanks again for the report!

– Noris

Hi @noris, this is good news indeed. As more and more people are moving to build 1903 this will be a real issue, so it is good to see the team is working on it.

1 Like

Just adding in my 2 cents:
I have the same issue on 2 Windows tablets: one is a Surface Pro, the other is a Lenovo laptop that can be turned into a tablet. In tablet mode this issue appears, in desktop mode it doesn’t.

I also have this behavior in the Qobuz Windows app, BTW.
Not in other apps that I’ve tried.

just noting that this problem has a major negative effect on the user experience. I’ve had to stop using my Windows devices in tablet mode, as the lack of ability to search or perform other functions requiring the pop up on screen keyboard is just too annoying to deal with on a regular basis.
Hope this issue can be taken care of in a minor bugfix fairly soon, instead of waiting for a big update.

Hi @danny2,

Thank you for your interest into this issue.

I took a look at our internal tracker today, and I can see that your ticket is still in our development queue. This means our developers are still planning to look at this, but we don’t yet have a timeframe for when that’s going to happen.

Once the ticket has been scheduled and work begins, I’ll have a better sense of timing here. Thanks in advance for your patience!

I’m running Windows 10 build 1903 and also got this problem. It at first seemed to make Roon unusable on my computer (fortunately can still use it on my phone). However I figured out a workaround, other Windows 10 users might appreciate, until the bug is fixed (soon I hope!).

I normally run Roon full screen, but if I shrink the app down to its minimum size (i.e. it takes up about 2/3 of the screen on my 1080p monitor) then the touch keyboard pops up but doesn’t cause the text window to close (and it stays up). With the keyboard up, I can go into its settings menu (settings icon on top left of keyboard) and select a different smaller keyboard (I selected the first option to the right of default). Once I have selected this option, the touch keyboard pops up smaller.

Then I can use Roon full screen, and when I go to enter text, the keyboard pops up, stays on screen, and doesn’t get in the way too much. I can pretty much ignore it. For me that’s a reasonable workaround. I think the touch keyboard will retain the settings (I hope). I can close Roon client and restart it, and the keyboard settings are retained.

Thanks for this. Too bad the Roon guys couldn’t give us the workaround.

When I tried your workaround it worked, but the small keyboard was too small for me. But my screen is higher resolution, and I also found that if I make the Roon window about 90% size, the full size on screen keyboard pops up and works normally. You just have to play with the size of the window till you get the max size that doesn’t cause the popup screen window issue to reappear.

Not having the Roon window 100% size is slightly annoying, but much less so than the popup keyboard issue.

Glad that helped. In my case I don’t even want the keyboard to appear at all. I have a real keyboard (it’s a workstation) and I can’t think of any other software that pops up the onscreen keyboard. I didn’t remember ever even seeing it before. I can see if you are using a tablet you need it. I hope the Roon engineers realize it causes issues even for non-tablet users by popping up the keyboard unnecessarily.

Hi @Joachim_Herbert / @danny2 / @sharpnine,

We’ve recently released Roon 1.7 (Build 500) which includes changes that should improve this behavior. Please give it this a try and let us know how it goes!

You can read the full release notes here:

The Team at Roon Labs

I actually looked for that in the release notes as soon as I saw the update and while it was installing…
On my two devices it has solved the problem, thanks. Maybe hard to believe, but it was VERY annoying.

@noris Not a solution for me, I’m afraid. The behaviour has changed slightly.

  1. When I touch the search icon, the Search field opens up with a blinking cursor.
  2. Touching in the Search field brings up the screen keyboard, as expected.
  3. A fraction of a second later, the Roon screen flashes, appears to change size to a much smaller window before redrawing itself to the full screen real estate a fraction of a second later (the Windows titlebar remains visible at both sizes).
  4. The Search field disappears (as a result of this redraw?).
  5. Once back to full size, the Roon screen appears to be redrawn once again.
  6. Following this redraw, the on-screen keyboard disappears - presumably because the Search field is also no longer present.

This is on a Lenovo ThinkPad 10 tablet running Windows 10 Pro, version 1903, build 19025.1051. It is using Roon build 500 32bit. I have to use the 32bit, to avoid the issue with the Intel HD Graphics driver and OpenGL.

Edit: Also happens with a Surface 3 tablet running Windows 10 Home, version 1909, build 18363.476 with a 64bit version of Roon.

Edit 2: If the Roon window is put into fullscreen mode (F11), then the onscreen keyboard will work as expected. This does mean that the Tablet Taskbar is lost, but I can switch windows and reveal the Taskbar by swiping from the left, so this is an acceptable workaround.

Resolved here. Thank you.


@danny2 / @Joachim_Herbert - Thank you for confirming the issue is resolved on your end.

@Geoff_Coupe - I appreciate the additional feedback here, I have forwarded your remarks to the technical team for a closer look at this behavior.

Sorry. Spoke too soon.

  1. Surface Pro 6- works as intended (64 bit Windows);
  2. Lenovo 2 in 1 Laptop:
    a) In Physical orientation as a Laptop: works when Windows is both in “Tablet” and non Tablet mode.

b) But when I fold the screen either flat or in “tent mode”: behavior returns when Windows is in “Tablet” mode. If I take Windows out of tablet mode but continue to use the touchscreen as I usually would with the screen folded as a tablet, the behavior doesn’t manifest.

Hi @danny2,

Thanks for confirming that this issue still occurs for you in some situations.
I have forwarded your remarks to the technical team and we’ll look into it further.

It’s been over a year. Is this issue any closer to being solved?

Yes, it has been fixed for quite a while now. Don’t know though if the fault was microsofts or roons.

Isn’t fixed for me. I still get the popup keyboard disappearing and jumping in and out when I try and do a search.

Hi @danny2,

Is this still the same pattern of the behavior?

We made some changes here a while back which should have helped, can you confirm if you have this setting enabled?

1 Like