Port forwarding issue ARC with Shaw TG4822 modem and Netgear RAX70 router

Roon Core Machine

Windows 10

Netgear AX8 RA70
Shaw Modem (in bridge mode)

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?
    Modem: TG4822 (in bridge mode)
    Router: Netgear AX8 RA70

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

USB SSD drive

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“24.xx.xx.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I can send screen shots of Roon ARC error, Port Forwarding configured on router, static IP set on router and UpnP turned ON on router.

Hi @leftside (Rob),

Sorry to hear you have trouble to get Roon ARC working.

  1. Could you tell me what the brand name is of the TG4822?
  2. Is the TG4822 only a modem or does it also have router possibilities?

Kind regards,


Hi Maarten,

There is no brand name. It’s a modem supplied by the ISP. It has router capabilities, but when it arrived I called support, told them I had my own router and the modem was put into bridge mode by the ISP.

Hi @leftside (Rob),

In your first post you wrote:

In your last post you wrote:

As mentioned, i’m no expert, but if i read it, both devices are in bridge mode? Could you check if the router (Netgear AX8 RA70) is in bridge mode?

Kind regards,


Sorry - my mistake - just the modem needed to be put into bridge mode. There is no bridge mode on the router. I’ll update my original post.

And as an addition:

  • My internet is working perfectly ok
  • Roon is working ok (apart from not being able to connect to ARC)
  • Networked devices on my network can connect to Roon Core ok.

The only problem is connecting to ARC.

1 Like

I have screen shots from Roon and my Netgear router, but they reveal networking information so I don’t want to post them up here.


I took a look at the manual of your router and i will describe what i should do. You can check it in your port forwarding rule.

I followed below instructions:

  1. On the port forwarding service page, click Add Service
  2. In the Service name field, enter ie Roon ARC
  3. From the protocol menu select TCP
  4. In the External port range fill in the port number which is shown in the Roon APP under Settings → Roon ARC
  5. Uncheck the checkbox Use same port range for internal port (this is what i did on my router).
  6. In the Internal Starting Port & Internal Ending Port fill in the port number which is shown in the Roon APP under Settings → Roon ARC
  7. In the Internal IP Address fill in the IP Address of your Roon Core (this number is also visible in the Roon APP under Settings → Roon ARC
  8. Hit the Apply button.

Restart the Roon App and check under Settings → Roon ARC if there are still errors. If so, it also may a good idea to reboot your core.

Hope it helps.

Kind regards,


Thanks for trying to help Maarten. I did all of that (screen shots attached).

Seems like a lot of people are having issues connecting with ARC. I think I’ll wait until the Roon software is updated and these bugs are ironed out before I attempt again.

Thank you Maarten!

I have a different modem/router, but also from Shaw. I missed setting the protocol to TCP. I did that and restarted Roon and my Roon ARC is Ready!

1 Like

Hi @Spencer_Blaiklock,

That’s good news!!!

Enjoy Roon, at home and on the go!!

Kind regards,


1 Like

Hi @leftside,

Please accept my apologies that you’ve been waiting for so long for a staff response to your issue.

Looking at the screenshot you shared of the UPnP port mapping assignments from your router, it’s very likely the issue you reported was in fact a bug that we’ve since pinned down and resolved. The most recent release of both Roon 2.0 and ARC (released today) contains a fix for this issue which might resolve your problem and allow for port forwarding. Please see the Release Notes here.

Port assignments were defaulting to the wrong range in certain rare cases, causing port forwarding to fail both when automatically or manually configured correctly. I suspect if the port range Roon has chosen starts with 24 in your case, that it was certainly a range reserved by your ISP and not available for port forwarding.

I recommend updating to the latest version of Roon 2.0 and ARC on all devices in your network, and then attempting to configure this rule again with the updated port assignment listed in Roon → Settings → ARC. Let us know if that doesn’t help.

We’ll be standing by for your response, and thank you again for your patience.

Still doesn’t work I’m afraid.

Hi @leftside,

I’m sorry to hear you’re still having issues. Diagnostics from your account indicate that there’s a persistent layer of NAT blocking the port forward. This NAT layer is either due a persistent misconfiguration in the settings above, or Shaw has implemented carrier-grade NAT/IPv6 address formatting for your account.

The team will investigate on our end to see if we can help pin down the issue if it’s in your local network. Would you mind clarifying the following to help expedite our investigation?

  1. Have you been changing the port assignment manually in Roon → Settings → ARC, in particular to ports in the 25000 - 35000 range? There is still evidence in diagnostics of these ports being assigned.
  2. Do you know if there are any reserved ports on your modem/router from Shaw? These might be for additional port forwards you have in place (gaming or other remote streaming, for instance), or they might be ports Shaw has reserved. If Shaw has reserved ports in the range Roon ARC will prioritize (55000 - 60000), it’s possible Roon can’t locate an open port before the operation times out.

In the meantime, I suggest reviewing the instructions shared by @Maarten_Duits above for your particular modem/router Bridge mode and manual port forwarding configuration. I also suggest you reach out to Shaw directly again, patience allowing, and pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a routable public IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

Hi, as you can see from above I set the port to 55002.

“Have you been changing the port assignment manually in Roon → Settings → ARC, in particular to ports in the 25000 - 35000 range? There is still evidence in diagnostics of these ports being assigned.”

  • Where do you see that evidence?

I don’t know if there are reserved ports on the Shaw modem.

When I have time I will call Shaw.

Thanks for your assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.