Primary Artists, alphabetical issue

Good morning. I’ve been spending a lot of time in recent months tidying up my music collection, checking artists (including primary), release dates, mastering versions (i.e. remaster versus original) and so on. I’ve got to know Roon better as a result, especially in editing albums sometimes to display the way I would like them to (e.g. editing Primary Artist).

However, one issue I can not figure out is how to tell Roon where to “file” alphabetically an artist with two Primary Artists. For example, say you have The Boatman’s Call by Nick Cave & The Bad Seeds. Roon automatically lists this with two Primary Artists, NC&TBS and Nick Cave. Reasonable enough but it lists it alphabetically under C for Cave, Nick. Is there any way to override this please? I can remove Nick Cave as a Primary Artist but would prefer to have another way of doing this. Changing the Album Artists to be NC&TBS/Nick Cave in that order does not make a difference.

Any ideas please? Many thanks.

Did you try to change the setting from “Name for artist sorting”?

Hi @ctbarr

You’ll want to edit the Album Artist field instead of the Primary Artist Link. This will allow you choose how you have this sorted.


Many thanks but I had tried this before. If the Album Artist is shown as NC&TBS it still files alphabetically as Cave, Nick. Only removing Nick Cave fully as Primary Artist will place it under N alphabetically. By the way, I can repeat this with some other albums with two Primary Artists whereby Roon ignores my preference.

I’m not quite sure I fully understood your problem. Do you want to change the sorting only for the one artist or was that just an example?

Generally you change the alphabetical sorting in the general settings:

For a single artist you can change it at the artist page (not the artist at the album page):

Thanks but I understand all that.

The problem is I want to be able to tell Roon under which Primary Artist to sort.

The album is by Nick Cave & The Bad Seeds. It should be under N.

Roon adds Nick Cave as a Primary Artist and then overrides the Album Artist choice by filing it under C for Cave. The only way I can see to override this is to remove Nick Cave as a Primary Artist whereby Roon files it back under N again.

There are other examples (e.g. “Jonathan Richman” and “Jonathan Richman & The Modern Lovers”) which cause the same behaviour. It feels like a (minor) bug to me!

Hi @ctbarr

Can you share a screenshot of your BROWSE SORT PREFERENCES?

Hi @ctbarr, I’m checking with the team on this and will follow up. Thanks!

@kevin In Dylan’s absence, any update on this please? Seems quite easy to fix (in theory at least!)