Pro-Ject streamer and USB DAC = no sound

I’ve recently been using my Roon Nucleus with a Pro-Ject Stream Box S2 Ultra and a Topping D10 USB DAC. It worked very well and was quite simple to set up.

Today I received a Pro-Ject DAC Box S2+ mini USB DAC to complete my digital system. The streamer is Roon Ready, the DAC is Roon Tested so I expected a very simple, no fuss, set up procedure.

Having removed the Topping DAC, I plugged in the new Pro-Ject DAC but no sound was heard and the USB input light was flashing indicating ‘no signal’. I though this odd as the system had been working just fine with the Topping DAC.

Using the menus in the Stream Ultra app, I checked all the settings and noted that the DAC Box S2+ was already identified as being connected to the Stream Ultra. Still no sound.

In Roon, the Stream Ultra is currently recognised as my endpoint, and the DAC Box S2+ is shown as being connected to the streamer. The Device Settings only allow up to DSD128 whereas the packaging says DSD512 is possible. I’d be happy with DSD256 but either way, I have no sound now.

Nothing I try can make it work. I’ve tried rebooting the Nucleus, switching it all on and off again, and still nothing. Can anyone help?

Please forgive me if this sounds stupid, no offense is meant.

I have several Pro-Ject Stream Box S2 Ultras and here are few things that might be causing the problem.

  1. perhaps you are using the incorrect USB output from the Stream Box. Please make sure to use the USB output labeled “DAC” on the left side of the rear.

  2. In the lower left hand corner of the main Roon screen make sure that the volume for the Pro-ject streamer zone is set to 100

After that I’m at a lose for ideas.

1 Like

Hi, and thanks for your reply.

I’m using the same USB type A output which I used with the Topping DAC, so the correct one.

Roon shows volume as 100 too.

I just have no idea what to do. The USB input light just keeps flashing indicating ‘no signal’.

Remember CD players? Bliss :grimacing:

If you look at the screen shot in my previous post you will see the “audio” window from the settings menu and there you can clearly see that I have three active “Roon Ready” devices. All these devices happen to be Pro-Ject Stream Box S2 Ultras. Please make sure that your Pro-Ject Stream Box S2 Ultra is showing up under the settings -> audio.

I would also think that you might get more response if you moved this thread over to the Support section.

1 Like

Thanks again. My Stream Ultra has been playing tracks as my selected endpoint but no sound comes from the DAC. So yes, it is visible in Settings/Audio and appears at the bottom right with volume at 100.

I just tried plugging the DAC into my Nucleus directly via USB and after setting up, the same thing happened - flashing LED and no sound. I’m now beginning to assume that the DAC has a fault and needs to go back to the dealer.

I’ve no idea how to move my thread but I’ll look into it…

Well at least now you know that problem has something to do with the DAC, so concentrate on that.

My Pro-Ject StreamBox S2 Ultra was working just fine connected to my Topping D90 DAC with USB. Then 3 days ago it stopped playing anything and when I try to configure the StreamBox, it does not recognize that the Topping is attached. However the StreamBox still recognizes an older Pioneer DAC that I originally had set up.

Sounds familiar. Make sure the Stream Box firmware is up to date and also your Roon version. My one went nuts when the new Roon version came out recently but has been fine since I updated it’s firmware.


Was there any change in behavior after checking the firmware?
Does your Topping still work when connected directly to the Core, bypassing the Stream Box?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.