Problem linking to Qobuz

Roon Core Device

2021 16" MacBook Pro OS Monterey 12.4

Networking Gear & Setup Details

WiFi connected via Ethernet

Connected Audio Devices

Headphone>AudioQuest Cobalt USB DAC > USB-C port

Number of Tracks in Library

5800 tracks

Description of Issue

In the Roon Desktop Mac App when I select settings>services> and attempt to configure Qobuz by logging in, after I input my username and password to connect Roon I receive a red color error message “Network error: Please check your connection" . I know my network is working because I can login to my Quboz account and directly stream music. Help would be appreciated as this the second time I have had problems with linking to Quboz this month. The first time I was able to avoid linkage problems by using my Email address rather than the User Name that Roon asks be entered. Now, I receive the “Network error message”. I only use Roon to play my albums stored on my computer that are not available on Quboz or Amazon. Playback is through Headphones not external speakers. I am hoping for a less “buggy” user experience. Suggestions for resolving this connection issue will be appreciated.

You need to use the email associated with your Qobuz account.

Hi @Leonard_Borden ,

Did logging in via the email address work? Let us know!

Yes it did. this was then second time that I had experienced a connection problem. The first time the problem was caused by my incorrect use of my Quboz user name instead of my email. After following the advice I received in response to my original post the connection was made. This second event happened even though I entered my email address. I waited 24 hours and tried again and the connection worked. So I am glad it worked but since I used my email address both times I have no idea why the problem went away with the passage of time. When I experienced the problem I did use my email address but still had the connection?error message. Thanks for the followup.

My original post regarding the connection problem was on 07/019/22.


I’m glad that worked for you. I’ll leave the thread open and monitored so you can return should your issues return.

Best wishes,

1 Like

For the past two days I’m having a very similar problem as Leonard_Borden reported. Qobuz suddenly stopped working so I went to settings>services> and saw Qobuz was no longer configured. When I attempt to configure Qobuz by logging in, after I input the email associated with my Qobuz account and password to connect Roon, I receive a red color error message “Unexpected error: Please check your account details" . I know the email and password used are correct because I can login to my Quboz account in a web browser and directly stream music.

Roon core: SonicTransport i7 controlled with Roon app on MacBook Air

Network and setup: core connected to network via Ethernet, ultraRendu connected to network via Ethernet, uRendu connected to DAC via USB cable, DAC connected to integrated amp via XLR cables, amp to speakers.

Similar here. Roon will play qobuz through airplay linked homepod but not through rendu/mytek dac. Will play radio through both. logged in with email. can log in to qobuz directly and stream on same network.

I fixed my problem by re-booting both my music server and uRendu. I was able to sign in to Qobuz after doing the re-boots. I don’t know if it was the server or uRendu that needed the re-boot because I did both at once instead of one at a time with a test in between.

1 Like

Hi @paul_lavers,

Try rebooting both your Rendu and Mytek and see if the issue persists. We can dig deeper if it doesn’t do the trick for us.


1 Like

Ok seems to have done the trick. Odd that worked with radio stream though! Tried limiting Qobuz quality but that had no effect.

1 Like