Problem with playback of Flac 96 khz 24 bit on Chromecast audio

As the title suggests, Roon output of 96 Khz 24 bit flac files does not play through my chromecast audio. The Chromecast audio is connected to a Polk Woodbourne through optical cable; and the Chromecast recives data through wifi. My router is a Netgear Orbi configuration which is pretty powerful as routers go (i get full bard everywhere in the house and way beyond). Chromecast recives 44.1/48khz 16 bit or even 44.1/48 khz 24 bit files fine enough.
The song seems to be progressing on the Roon program but no sound output is heard.

Said Polk speakers also has airplay natively but of course this will downsample the 24/96 files.

Again Roon outputs to the AV Chromecast (not audio) connected to my living room TV fine enough; but obviously downsamples 24/96 flac files.

Any troubleshoorting available for this?

I’ve looked online for specs for the optical input for the Polk Woodbourne but haven’t been able to find anything.

The user manual refers to “Optical (digital) cable for TV, DVD, Blu-ray or gaming console”. I wouldn’t necessarily expect those devices to output 96kHz optical. They are more usually 48kHz.

Have you seen any confirmation that the Woodbourne will accept 96kHz optical ? Do you have any other source that outputs 96kHz optical that works with the Woodbourne ?

Edit: The reason I’m asking about the Woodbourne is because I have a Chromecast Audio and it played 96kHz optical fine into my DAC without any special settings.

Assuming your Polk does support 24/96, I would check the optical cable. Any tight bends, kinks, poor termination (which may not be visible superficially) or badly fitting connectors (which are not unusual with Toslink) could affect performance. Easily tested by trying a different cable.

Thanks both Andy and Chris. I realized the issue, was that I very foolishly assumed that the problem was at Chromecast end, whereas it should have been clear to me that since I am using the optical output, it is the Woodbourne in-built DAC what does the D/A conversion. I didn’t think of looking at whether the optical input of the woodbourne is 24/96 capable. It clearly seems not (though like you, I couldn’t find any specific literature).

I replaced the optical cable with an 3.5mm aux cable (the woodbourne has an aux input as well) and the 24/96 file played out of the speakers fine. So clearly the chromecast is receiving 24/96 signal and the woodbourne cannot handle it.

Now the only issue remaining is how to force Roon to downsample the stream to 24/48 such that it plays through optical? I much prefer connecting my chromecast through optical to Woodbourne, since (a) to my ears, sound through the optical cable is superior (especially in terms of punch and dynamic range at lower volumes) and definitely gets much louder if required (b) I can play and pause through the speaker remotes (which is not possible with aux-in); © this speaker is my guest room and the spare aux can be used easily by guests with their portable devices (though not so relevant these days with mobiles ditching aux output).

Unlike other regular end points, the chromecast audio setup page does not seem to provide the option to limit max sample rate to 48 khz. The 96 khz file is transferring in all its untouched lossless glory and the woodbourne is clearly incapable of reading that!

This is not a big deal, as this speaker is in my guest room as said above, and it is rare that I would stream 24/96 files to it (which is why I am realizing this issue after owning the Polk for 4 years and Roon for more than 2). But I would like to be able to stream such files to the speaker (down-sampled if necessary) rather than have to change the chromecast output to aux cable.

Thanks both again!

Under Device / DSP / Sample Conversion. Set the conversion to Custom and then select the outgoing target sample rate for each source sample rate.

1 Like

Hi @Samsuddha_Majumder,

Glad you were able to troubleshoot the issue and locate the issues as the DAC and not the Chromecast. To provide a visual of what @Rugby mentions, this screenshot should help with getting the setup you desire:

Thanks Daniel and Noris. That’s helpful and solved the problem


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.