Problem with Roon when playing Qobuz on NUC8 ROCK

Core Machine (Operating system/System info/Roon build number)

Intel NUC8i7BEH , RoonOS, Latest stable build downloaded from ROON
8 GB RAM, 256 GB M.2 SSD

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

AT&T BGW210 main router.
NUC ROCK Roon core: directly connected to router by Cat8 ethernet cable.
(new unit, latest BIOS update, Roon OS Version 1.0 (build 219) stable

Audio Devices (Specify what device you’re using and its connection type)

Cambridge Audio 851N Network streamer (connected via WiFi to router)
iPad Pro used as Roon remote, connected via WiFi to router
Dell PC (as test output device) (connected via WiFi to router)

Description Of Issue

Roon + Qobuz work well when core runs on my PC.
Roon + Qobuz do not work when core runs on the new NUC ROCK.
when selecting a track, Roon endpoint software plays 1 or 2 seconds of the track, then jumps to the next track and keeps jumping from track to track until the end of the playlist.

With NUC as core, and tried to play Qobuz to my PC’s output … same behavior as described above.

When running ROON core on my PC, Qobuz works well and track plays correctly on PC’s audio output. Qobuz works well by its own app, at all resolutions.

I’ve seen several threads in this forum discussing this problem - but no solutions. Network speed gets blamed. My home service is very fast.

Please advise - thanks,

Update: Qobuz does play when using the new NUC ROCK as core. But one needs to try several times for each song, getting the message “Qobuz media is taking too long to load”. Eventually, it plays.
When using a Windows10 PC as core, Qobuz and Roon run flawlessly, and fast. But the PC is connected to the network via WiFi, whereas the NUC ROCK is connected by ethernet cable to the router ! As a test, I connect the PC by ethernet cable to the router and it still works great.
So where is the network bottleneck ? If the problem was with my WiFi, running the core on the PC via WiFi would be a problem - but it works nicely. The NUC ROCK has the best and fastest connection to the network … and it stutters. Any advice or troubleshooting suggestions will be highly appreciated.

Hi @Hector_G, you won’t like it but that still sounds like a network issue. A general statement about the speed of your home service hides a lot of details. When you stream the data is routed to the core and then the endpoint. It’s the internal connection between these that’s getting maxed out not your home broadband. How are the NUC and PC connected to the network? It could be another cause but I’ve had similar issues and a network bottleneck has always been the culprit.

Is your WIFI using the 5Ghz or 2.4Ghz band ? I also had playback issues on my Bluesound streamer when it was connected in 5 Ghz, but since I switched to 2.4 everything runs smoothly again. Worth a try if this is something you can change in your network setup.

Interesting you mentioned - I had that problem some time ago on a network streamer. Air Play gets confused on some devices when both the 5 GHz and 2.4 GHz are present. After separating both WiFi networks and assign them different names the problem disappeared. But so the network I use for music is purely the 2.4 GHz, so my current problem with Roon and Qobuz is not solved by that. Thanks.

Thanks for your reply. Agreed, it is a network issue - but where and why ?
The NUC core is directly connected to my main router via CAT8 ethernet cable. The endpoint (Cambridge Audio 851N) and remote (iPad Pro) are connected via WiFi to the same 2.4 GHz network. This type of connection should not create problems, but it does. If the makers of Roon would tell the world that all elements on the sound chain must be connected to the network on a particular way to work properly, fine, I can live with that. But I’m not breaking any rules, I have good hardware and a good high speed internet service … It should work, shouldn’t it ?
Any advice on how to troubleshoot or solve the problem will be highly appreciated !

I would try this:

  • Make sure that ROCK is using DHCP.
  • Set router to use Google DNS.
  • Set router for media prioritization for ROCK.
  • Restart everything (router, ROCK etc.).
  • Try another Ethernet cable.
  • Make sure that ROCK has no background activity, like scaning your library.

Your Cambridge and Qobuz are working fine using PC as a core?

Roon + Qobuz also work unstable for me. At the same time, Roon + Tidal works well. In native Qobuz application, everything works quickly. Something in Roon + Qobuz is unstable.

@DanielAvasilichioaei reply is a good place to start though changing your router’s DNS servers and prioritisation may be a challenge depending on your tech experience. If I were in your shoes I’d hope that I had a faulty network cable between the NUC and the router. If you have a bog standard CAT5 or CAT6 cable around do try it and try a different port on the router while your at it. It might not solve the issue but it’s a real possibility and the easiest fix. Given everything else is WiFi my feelings are similar to yours, it’s unlikely to be the network bandwidth elsewhere. To be sure, Qobuz works well when you use the PC as the core and your Cambridge Audio endpoint?

Thanks for the suggestions! ROCK is set to use DHCP. Question:

  • How do I set the router to prioritize the ROCK ? I can enter the router settings page and change things such as IP, DHCP … but I do not see any setting that would allow me to prioritize media.
    Other notes: since it’s a new NUC, the library is empty.
    Cambridge + Qobuz + Roon work perfect when the core is on my PC … which is connected via WiFi, while the ROCK is hardwired to the router.
    Restarting the ROCK does help … until it gets silly again.

Yes - Qobuz+Roon+Cambridge works perfectly when using PC as the core, despite the fact that the PC is connected via WiFi, while the ROCK is hardwired to the router. I’ll try different cables and ports today.
How can I change DNS server or prioritization in the router ? My router is AT&T BGW210 and I can log into the router settings page but have not seen where or how change priorities. Thanks.

Hi @Hector_G are you sure it’s a network connection issue? If the content’s on a local SSD then that makes little sense as you’ve tested the network connection and tried different cables and the like. Do you have a USB DAC that you could connect directly to your NUC? That might help isolate the issue as it removes the network. If it’s not the network I wonder if your NUC is overheating and throttling, SSDs can overheat as well. What case and NUC are you using?

I see it’s an 8th gen i7 so will need some keeping cool, is it the standard case? Also what make is the M2 and is there still plenty of space on it?

Finally, it may help to restrict posting to a single thread: Issue with Roon + Qobuz + NUC :wink:

Hi @Hector_G. Good news about the DAC. Given there’s only us chatting here let’s see where this goes and then move the thread. The NUC and SSD will work with Roon fine, provided they’re working well.

A standard case means it shouldn’t be running hot unless faulty. I wondered if you’d built into a custom case. A bad thermal contact between cooler and CPU when building might leave a machine that runs hot.

Do you happen to know how much free space is on the M2? A full system HDD is another possibility.