Problem with Teac UD501 ASIO [fixed]

I’ve just installed roon and hqplayer with trial account but I’ve some problems.
I use Windows 8.1 and Teac UD501 DAC

  1. When I try to enable my teac UD501 asio driver as output I get these message

    Normally I use Jriver without any problems with asio drivers
  2. If i use HQplayer standalone it works but when i add hqp as networked zone when i start playback doesn’t work, it hangs showing 0:00 time.

The only way I can get roon playing is with default system output.

Can you help me?



just an update.
I managed to make HQPlayer working with Roon.
Roon also works with Jplay.
I still can’t figure out how to make Roon working directly with teac asio usb drivers.

Can anyone help me?


Hey Andrea,

Does the dac work with the Wasapi driver in roon? I have a ud-501 and if memory servers, I had to have the dac on before I started Roon to select the Asio driver. If I power cycled the dac, I would have to restart Roon. Unless your looking for native Dsd, I found the Roon Wasapi driver to work better.

Thank you David,

I don’t want to use wasapi because it doesn’t play DSD
Also I had the DAC on before i Start roon
Anyway It’s very strange I can’t enable asio drivers because they work in every player I have tried.

Are you using the latest driver? I see Teac has a newish one, not sure if it has any changes besides new device support though. Btw, you can play dsd through dop method in the Roon waspi driver.


Yes I have latest driver installed.
For wasapi I forgot to set exclusive mode.
Now I can play DSD with DoP.

UPDATE I found a way to make asio working: I disabled system output and close any other software which could use dac (browser, etc). I switched off and on dac then I started roon and now It works.

Thank you for your help!



Sorry for the slow response here @Andrea_Tacchetti – glad you got this working!