Problem with volume on Homepod Minis [Roon Investigating]

Roon Server Machine

Mac Mini 2018 3,6Ghz, 8GB RAM, Mac OS 14,1,2

Networking Gear & Setup Details

Asus ZenWIFI XT9, two routers in mesh. Fixed IPs on everything.

Connected Audio Devices

Hegel H390, 2 Homepod Minis

Number of Tracks in Library

6032 Tracks

Description of Issue

Whn I connect to any of the Homepod Minis with Roon, it starts playing at max volume. When I set it at fixed volume in device settings, it is not possible to adjust volume on the Homepod Mini. It just goes right back up to Max after dipping just a little.
When set at Device Volume, nothing happens when I try to adjust volume via Roons + or - buttons or the slider.

I have trtied reinstalling Roon Server, and RAAT server as suggested elsewhere, no difference.

I have heard from others that single Homepod Minis are supposed to work, and I just cannot imagine what I am doing wrong. Can you please help?

I have the same problem, and there are more threads about the problem of not being able to control the volume with Roon for HomePod minis. But there are no answers or solutions to the problem. Now is the time for someone from the Roon team to try to solve this problem! Not being able to use my HomePods with Roon is very annoying.

Yeah, at this tile I am researching alternatives, for Roon.

Same with HQPlayer

Hi @Jim_Rasch and others,

We are still actively looking into this issue and gathering additional information from Roon logs. If this issue happens again, please take note of the specific date, time, and track playing.

Once you let me know this info, I’ll go ahead and enable diagnostics for your account so I can review the logging for clues.

If you’d rather do it yourself manually, please use the directions found here and send over a set of logs to our File Uploader.


This happens every time. I have uploaded a log file. December 15, from 9:40 and outwards you’ll see me playing to two HomePod minis(badet and soverommet) via airplay. They both start out playing at full volume, and I I try to adjust volume but nothing happens. Please advice

Hi @Jim_Rasch,

Do you have “Sound Check” enabled in the HomePods settings?

It was enabled under the Homepod settings, at least what I think it is in Norweigan. I Found no such setting in the settings menus for the Homepod itself.

I turned it off, and restarted the Homepod Minis but it makes no difference.

Hi @Jim_Rasch,

What is the current homepod version you’re running? Apple seems to have fixed this issue after updating to Sonoma 14.1 and HomePods to 17.1

Next, please disconnect your Ethernet cable and use the wifi connection for your Homepods and let me know if the issue persists.


FYI, current OS version for HomePod mini is 17.2 and 14.2.1 for macOS Sonoma. Problem is unchanged, volume cannot be adjusted, always 100%. Roon is still trying to kill HomePod’s…
Getting tired of not being able to use the speakers, hoping for a solution soon!

@Niqlaz, if you have a similar problem, please post your own request in the Support category.

FWIW, I am able to adjust my HomePod minis’ volume from within Roon when I set them to be the System Output via AirPlay on either my MBPro or my iOS devices. May not be the most elegant but it works fine for how I use them. Same OS versions as what you have.

Hi @Jim_Rasch,

I wanted to check in on my previous reply to see if the issue persists after a firmware update? Thanks for letting me know the issues persists for you @Niqlaz.

If you set the homepods as your system output on your device, and then connect Roon, does the issue still occur? Have you also tested out different network connections with your Homepods as well?

If you do reproduce the issue, getting a fresh song name, date, and time would be helpful. If you’d like to submit a set of manual logs for our review, use the directions found here and send over a set of logs to our File Uploader.

I have tried setting Homepod Mini as output on the server machine. What happens is that the server machine releases that sound output as soon as Roon takes the Homepod Mini when I start playing. I have tried with all units updated, but I find nothing is changed. I still cannot control volume on my homepod minis from Roon. When I start playing from Roon the volume goes off at 100% threatning to ruin my speaker(s).

Hey @Jim_Rasch,

I may not have been clear enough in my above reply - my apologies there Jim! My thoughts were:

  1. Connect the homepod to the system output of your MacBook air (for example) - this occurs completely outside of Roon. Say if you wanted the homepod to play audio from youtube, you’d connect it and run it as the system output for the MacBook air.

  2. Once you’ve set it up as the system output for the MBA, head into Roon and select the same system output of your MBA as your endpoint. Ignore the Homepods and connect to the Macbook air (which then your MBA will still use the Homepods as its audio source.)

Do you experience the same issue when doing this?

1 Like

When going around this way, there is no issue. Just tested witht he MBA . The workaround I sometimes use is to do this with my iPhone/app. That also works.

Thanks for letting me know @Jim_Rasch - I’ve forwarded the info to our development team. :+1: