Problem with waveform bar and disabling audio analysis features

Since I’ve installed 1.3 (any build) I’ve problems with waveform bar.
For example even when a song has been analysed (I see all volume levelling values in file info) many times happens that I see only a flat line and not the waveform.
If I try to re-analyse the track nothing happens.
Also I have a lot of tracks and I don’t care for replay gain and R128 values but this kind of analysis it’s a heavy CPU load for something that means nothing to me.
So is it possible to disable this feature of audio analysis? in few words it means that I’d like an option to go back to 1.2 kind of audio analysis that worked perfectly for me (non heavy CPU load and working waveform)

Thank you in advance

In Roon’s Settings --> Library …

  • Background Audio Analysis … can be adjusted to how much CPU it is allowed to use (from off to 8 cores).
  • On Demand Audio Analysis … can also be adjusted.

Though note the waveform bar display is dependent on Audio Analysis having been completed for the given track.

Let’s drop a prompt for @support to follow up with you on that.

Thank you Carl

Anyway I know those settings Carl and in 1.2 keeping Background Audio Analysis off and on demand analysis fast I never had problems with waveform; form the first playing I could see waveform for any files
With the same settings I’ve problem with waveform; often the waveform don’t show at the beginning of the song but at the end or after second or third playing.
it seems to me that new audio analysis is very slow (I’ve core i7 2600k) and considering that I don’t care at all for r128 values or replay gain I’d like to turn these feature off even in on demand analysis hoping to have waveform working well as with 1.2.

Personally I doubt you’ll get what you want as obtaining the data for the wave forum display and audio analysis are linked.

Calculating the R128 values is more computation intensive … there’s not a lot to optimise … it is what it is.

My advice would be to enable audio analysis at max speed over night when you’re not using the system … iirc it took about 4 nights to complete on my lib (circa 250K tracks) and once complete that’s it job done for existing albums.

That’s the point Carl. For me R128 values is just CPU waste so I’d like an option to disable it.
I was just fine with audio analysis in 1.2 and I’d like to have it back, that’s it.

Hey @Andrea_Tacchetti – we can look into the waveform issue here, but you’ll need to let analysis complete first.

If you’d like us to look into that issue, I would recommend following @carl’s advice:

If you’d prefer to disable analysis, @carl’s post above explains how to do that. And finally, if you’d like additional options related to analysis, can you open a feature request?


Just to be sure: you do know that Tidal tracks always have a straight waveform bar?