Problems connecting to Mytek Brooklyn and Aurilac Aries

Hi, I installed Roon yesterday and am having difficulties getting my devices connected. I am running the Core on an HP WIndows 10 laptop (Intel core i5 processor), My devices include the following:

Mytek Brooklyn DAC
Aurilac Aries streaming bridge
Synology NAS

I have been able to set up the Core, NAS, Sonos, and ipad. I am having problems connecting the Mytek and the Aries. When I initially installed Roon and went though the set up I noticed the aries and Mytek showed up on the device list, and connected to the core, however the aries no longer appears. The Mytel does show up in the connected devised list, but says “device installation failed” next to the name. When I try to rety, nothing happens.

Thanks in advance for your help.

Problem solved. I had my Aries configured for wired and changed to wireless.

1 Like

Hi @john_dottore ---- Thank you for the report and sharing this observation you have made with us. The insight and feedback are both very appreciated!

Moving forward, can you please confirm that you have “Roon” selected in the lightning DS app? Furthermore, while it may seem a touch elementary, since noticing this issue have you tried rebooting no only your Roon core but the Aries and any relevant networking hardware as well?


I did have the Roon selected in the lightning app and also rebooted. The issue was that I was running my Aries in world mode and had to change to wireless. As soon as I did my Aries was found on Roon and everything worked perfectly after that.

PS I am really enjoying using Roon

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.