Problems connecting to Roon - Orbi Mesh

Core Machine (Operating system/System info/Roon build number)

Mac mini 2014 MacOS 10.15.4 Roon 1.6 Build 157

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

KPN Experia Box to Orbi AX6000 Router, wireless backhaul to 2 Orbi Satellites.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I’ve having problems with Roon ever since I switched to a new Orbi wifi system. My Roon endpoints will not find the Roon Core if they are connected to one of the satellites. Upon starting Roon on my MacBook Pro, it continuously searches for the Roon Core.

If I select to connect to a different core, it will show that the connection repeatedly tries to get to the Core on the Mac mini but fails, then a few minutes later it does connect. Once connected I am able to play stuff, but all Qobuz artwork does not show “Unless” the album has been added to my library…

On my IOS devices I see different behaviour. iPhone has no issue whatsoever. iPad has similar issue to MacBook Pro, but once it finally gets connected it does ‘slowly’ load all album artwork from Qobuz.

I’ve read multiple posts here about disabling IGMP Proxy settings on the Router, however this is impossible, as my Orbi’s are running in AP mode (box provided by ISP is a router and I cannot set this to bridge mode), so I have no choice but to run the Orbi’s as AP’s without doing some serious networking.

Any idea of what I can do to remedy the situation. It does work, its just a bit flaky. Never expected this trouble simply switching AP’s :frowning:


1 Like

Hi @YYZ,

Generally we have found that Orbi devices tend to function pretty well with Roon, but we haven’t seen many reports of Orbi being used as access points only, so it’s hard to say what might be causing the bad behavior here. With Orbi we’ve found that the IGMP Proxy setting mentioned in our Networking Guide is necessary for proper behavior of multicast traffic (which is necessary for Roon), but since that setting can’t be changed there may be others to look out for.

On both the Orbi and the main router, I’d make sure that multicast is allowed. The exact settings may vary, and you can feel free to share some screenshots here so we can take a look.

Hi Dylan,

I think I have found the problem here. On switching to my new Orbi wifi system, the IP address of the core machine has changed (was not on static IP). But Roon endpoint is constantly trying to connect (and fails) to the old IP. So I’m in an endless loop. Course of action? Reinstall? (and then setup a static IP)…

This is what I am seeing from MacBook Pro connecting to Roon Core

It just cycles through trying to connect/failure - but the IP address given is not the IP address of my core…

Have you configured some devices with static ip addresses? It’s conceivable that the new networking has allocated addresses that conflict with existing static addresses - depends how you set up static addresses.

Only static IP’s are assigned outside of DHCP range (for multiple synology devices). All the rest are on DHCP. What seems to have happened…when I swapped in the new wifi, i neglected to power down my mac mini with my roon core. In this process the mini received a new IP address, but for whatever reason Roon running on my MBP continues to insist that the core is on the old IP address. Its still in same subnet - so I don’t quite understand why its not seeing the core as it should ‘discover’ it. Roon on iPad and iPhone are working as expected and are connecting to core under new IP address.

Have tried blowing away Roon running on MBP but its still picking some config up that is pointing it to the old IP…

I’d power everything down and start again… but I suspect you’ve already done that…

The wireless on the old router is definitely off?

Nope, but finger is on the ‘delete core’ button !

Hi @YYZ,

I would try reinstalling the Roon app on this Mac controller:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location (on the problematic mac)
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App to generate a new Roon folder
  • Verify if you are then able to connect to the Core

Did that yesterday, on the controller Macbook Pro, in fact I deleted everything (I thought) and reinstalled - same result - immediately goes to look for core on .2.6 when the core machine is .2.8…

Hi @YYZ,

If you temporarily connect both the Core and the Mac Client directly to the router, bypassing the Orbi satellites, are you able to connect properly?

Hi Noris,

Re-reading your post here, I had assumed when you said Roon Controller that you mean’t my MacBook Pro client which is accessing the Roon Core, which I completely uninstalled and reinstalled (without solving the issue). However re-reading your instructions I think you mean’t for me to reinstall RoonServer on the core Mac mini. If this is the case, then I should navigate to the RoonServer folder and rename it as ‘old’ and then reinstall RoonServer?

I’ve taken the scorched earth route, I don’t use playlists and I don’t have so many albums from streaming added to my library (recently moved to Qobuz). But I have the same problem. Deleted core (RoonServer and RAATServer folders from Core machine, deleted application), deleted Roon and RAATServer folders from MacBook Pro, deleted application. Deleted IOS apps. Reinstalled RoonServer on MacMini. Reinstalled Roon on MacBook Pro and IOS.

As soon as I start up Roon on the MacBook Pro, which should be a clean install of Roon connecting to a clean install of RoonServer, I get the same thing - its trying to connect to the wrong IP address:

Then I go to iPad and start new Roon app, it successfully finds the new Roon Core

So somewhere, buried deep in macOS Catalina, Roon has put something that is telling it where to look for the Core - but I don’t know where…

Update: I’ve tried installing Roon on another Mac in the house (that hasn’t had Roon installed) - same issue with that client. So the plot thickens. Appears this is definitely some sort of networking issue, but I have no idea what…I am going to try to reboot the whole house at some point in the next 24 hours (whenever that is possible with the entire house working/schooling from home…)

Were you able to try noris’ suggestion to plug everything into the router?

Not yet - waiting for a moment when I can disrupt the working household…

1 Like

Just for fun, I unplugged the Ethernet connection from the core to the access point and switched to wifi…after cycling through a few failed connection attempts it then found the core over wifi, and I’m now connected on my MacBook Pro to the core (over wifi). It is the Orbi Router (in AP mode) which is the device on the IP address which was causing the problems, so I am led to believe that a problem exists with the Orbi allowing Roon to access the core (wired). It could also be the built in firewall in the Orbi which is completely not configurable. I’ll spend more time screwing with this, and will try putting an unmanaged switch between the core machine and the Orbi Router. But for now, I fully believe this is some sort of weird networking issue to do with the Orbi Router not allowing certain applications (Roon) to work as their are supposed to…to be continued - And thanks everyone for your help so far.

and what the $&%#(@#&$* - stick an unmanaged switch between Roon Core and AP - and everything works…Pointing this all towards Netgear now…

1 Like

Try taking it out again and see if the fault comes back*… network may have sorted itself out.

*although it might be safer to leave well enough alone and put some music on :wink:

1 Like