Problems playing High Resolution

*Core Machine (Operating system/System info/Roon build number)
Windows 10, i.5 Roon 1.6 / build 401, 13,000 tracks

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Plus Net Router connected by 5e ethernet to both Core and Bluesound Vault 2

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Bluesound Vault 2 with RME ADI2 dac to integrated amp, everthing controlled by an Asus tablet.

Description Of Issue

I recently acquired the RME ADI 2 DAC and was so pleased with the improved quality I upgraded my Qobuz account to studio. It became apparent there was insufficent bandwith so I also upgraded my bandwith by moving to Plusnet Fibre, who provided a new VDSL router… This provides on my last test 38 mbs which exceeds comfortably the 20mbs recommended by Qobuz

When playing, both Qobuz High Resolution and the downloads in the Vault 2 using the Bluesound App there are no problems. Using Roon, High Resolution will not play, or plays for a few seconds and skips tracks. If the Roon settings for the Vault 2 are limited to 24/44 everything plays although sometimes it stutters at the start. The stuttering has now spread to some CDs.

I have a very few High Resolution downloads, they used to play satisfactorily but now in Roon the same behavour occurs.

I have removed the RME from the chain but that makes no difference. I have rebooted the router, core computer and Vault 2.

Having read the knowledge base I suspect the new router is the problem , is there any way of veryfying this is the case before buying a new one? Or could there be another cause


Thanks for the post here and for letting us know the issue details. You hinted towards this but I just want to confirm explicitly – this same behavior occurs with your high-resolution downloads that are saved locally as well?

If this is the case I would suspect a hardware issue somewhere along the line too, is the behavior the same for multiple zones? If you try to output the high-res content or Qobuz content to “System Output” for example, do you notice any issues with the stutters? When this issue occurs, does Roon display any error message?

38mbps is a bit lower speed than would be ideal, so I can’t quite say if this is the root cause but getting your local library streaming to be stable would be my first suggestion here.

Can you check to see if your router has any of the “Router Specific Settings” we mention at the end our Networking Best Practices Guide in case it requires a similar change? Specifically I would search for IGMP Proxying & make sure that Multicast is on and configured properly.


Yes the downloads saved in the Vault 2 also have the same problems when played through Roon…

When High Resolution is played through “System Output” there is no problem. There are no error messages.

I will have a look at the Router again but could not see much that was relevant, it is supplied " free" by the internet provided and said to be worth only £40, so it clearly is not a very top of the range item…

Everything including the locally saved items play with no problems when using the Bluesound App rather than Roon…


Thanks for confirming there’s no issue with “System Output”. If the settings that I mentioned are not possible and since you mention that the router is provided by an ISP and is sold at such a low price-point, you’ll probably want to replace this regardless with something much better.

We have had good feedback from clients that make use of the Netgear Nighthawk line of routers, but any consumer-grade router with multicast ability will likely be a step up from the current one you have. If in doubt, I would suggest getting a router from an easily return-able source (such as Amazon) and check to see if that helps with the issue.

The Bluesound app working is a good data point, but the technology used to stream in Roon vs the Bluesound App are quite different, so it’s not exactly a good comparison. Do let me know how the tests go.



Just to let you know the problem has been solved, not by a new router, I never got round to buying one, but instead the latest upgrade solved the problem somehow or other.



Thank you for the update. If you have any further issues do feel free to reach out to us again!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.