Problems upsampling to Amanero USB (Combo384)

Here’s a strange one - well to me anyway.

Asrock z97 itx
Core i5 4570s cpu 65 watt tdp
Sandisk ultra 3d 240gb ssd
streacom fanless 240 psu
16gb hypex ram 2x8gb
Matrix audio X-Hi pci usb 3.0 + ifi 9v psu
streacom fc05 chassis

Running SnakeOil OS (Ubuntu 16.04.2 LTS)
Latest Roon 1.5 (Build 339) stable (64bit)

I run direct via USB from the Matrix audio X-Hi pci usb 3.0 output into the DAC.

I’m trying out a new DAC from Ciunas Audio - the ISO-DAC (
This uses an Amanero board I believe and is identified in Roon as ‘Combo384 Amanero’ which is what I expected.

Within Roon when the DAC is identified it shows that the DAC will support up to the following:
[RAAT::Combo384 Amanero] [alsa] [hw:CARD=Amanero,DEV=0] supports PCM format 384000/24/2
[RAAT::Combo384 Amanero] [alsa] [hw:CARD=Amanero,DEV=0] supports PCM format 384000/32/2

After a few hiccups early on everything is connecting and playing fine - until I try upsampling.

If I set the device to the maximum Sample Rate reported for the device

and enable the DSP Engine to use a Sample Rate of ‘Max PCM Rate’ then I get no music whilst the track progresses within Roon.

If I drop the maximum Sample Rate for the device to 192

then music is played but it sounds slower than normal (like it is going through treacle)

If I then change the DSP engine settings to ‘Max PCM rate (Power of 2)’ everything is back to normal speed.

As an experiment I tried the same steps using a Roon Core setup on a Windows 10 laptop with the appropriate Amanero drivers installed and experienced exactly the same ‘problems’.

Any suggestions/ideas?

Hello @Dave_Harrison,

Definitely a strange one. I’ve been doing some research on this DAC, and come across a few similar reports in this thread

Unfortunately, we do not have this DAC in house to try and replicate the behavior you are seeing. I would recommend reaching out to Ciúnas for guidance on this issue. If you are able to find a solution, please share so we can document and have it for future purposes!


Hi Dave
I also have the Ciunas ISO DAC , think it sounds superb.
I tried to replicate your settings , at 32/384 I get no sound also but it sounds great at 32/192.
I have it set to Max PCM rate and Smooth,Minimum Phase.
I also have volume levelling set to Auto.
I have a Microrendu in front of the Ciunas .
If you want me to check anything else let me know.
Good luck with it

If I’m not mistaken 44 kHz content cannot be upsampled for certain algorhytms to 192, look for content in 48 kHz and see if it plays correctly

I also have read the dacs showing 32 bits internally can do only 24, don’t know if it may be your case

Hi Dave
Have you tried listening to the Ciunas fed at your files native sample rate . I find that it sounds fantastic that way , loads of prat.
I only tried upsampling to try and replicate your issues but in my system I definitely prefer the native sample rate.
No volume leveling either , so bit perfect.
Best regards

I’m looking into this issue & so far I’ve discovered that the Amanero USB does not sense samplerate change in the audio fie being played when using the DS (Direct Sound) pathway in Foobar - it does when ASIO or KS pathway is chosen. In other words the 24.5792MHz clock should be used when playing 48, 96, 192, 384KHz audio files & 22.576MHz clock should be used with 44.1, 88.2, 176, 352KHz audio file playback. The correct clock should be enabled by a signal that is not being produced when DS pathway is used in the playback software

As I reclock the I2S signals just before they enter the DAC using two low jitter clocks (one for each speed family), this means that when paying files in the 48KHz speed family it is still using the default 22.576MHz clock because no disable signal is generated that will turn off the 22.5762MHz clock & enable the 24.576MHz clock

This appears to be the cause of the slow playback problem with the 48KHz speed family playback.

Not sure how this applies to Roon - as I have only tested it with Foobar - does Roon use DirectSound pathway?

Edit: I see it is using ALSA from the above screen shots - I will have to check into this further

Just to add 352KHz & 384KHz don’t play using Foobar ASIO or KS
But like Tony posted, I find no difference between 44.1 & 176KHz or 48 & 192KHz (but I might be biased :grin:)

44.1 & 48Khz files played through the ISO-DAC (& the previous Ciunas DAC before it) sound like high resolution to me

I’m getting a better fix on how to make my hardware 100% immune to this issue & should have a definitive fix soon.
The problem is it’s a rare enough issue & I can’t recreate it myself. I suspect it depends on some specific electrical conditions that certain systems may exhibit. Further investigation needed though

1 Like