Problems with connecting to roon

Core Machine

Rpi4 model b Rev 1.2

Network Details

I have EVW32C Ubee router.

Audio Devices

I am using rpi4 with external DAC - RaspyPlay4 but since there is no that DAC in list I took it off and tried without it as well.

Library Size

Don’t have library, I will connect it with Tidal.

Description of Issue

Hello guys, I am new to Roon, I followed many tutorials on internet but without success.

I used Volumio but since I am not very satisfied with it I was about to try Roon. I made account today and I tried to install it on my rpi4. Everything seems to be OK but when I start to search Roon core with my phone it’s just in loop and never finds device.

I tried ropieee and vitos, both seems to have same problem. I also tried two different SD cards.
Tried both ethernet and wireless same problem.

All ideas are more than welcome.

Best regards

Roon requires a pc or Mac to run the core. Raspberry Pi and an OS like Ropieee etc are only roon endpoints. I think you maybe need to reread some of the help info here


What OS are you using?
Which hat are you using? You will need to tell the OS that.
Usually it goes into /boot/config.txt
Any blacklisted devices that need to be commented?
You will need to install roonbridge on the raspberry pi once the hat is recognized to allow roon to control it. You will still need a pc or mac to act as your core as noted elsewhere.

1 Like

sorry for late reply guys, i managed to connect everything. i mixed up core with endpoint…such a dummy.

thanks for clearing things out.


1 Like

Glad you got it working, that’s all that mattered.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.