Problems with dsd128 playback

I have an lps 1.2 and ISO Regen with your adapter plug into an EMM labs dac2x v2 that supports dsd128 over USB.

My source is a MacBook Air running Roon Core
1.7 ghz intel core i7
macOS high Sierra
Version 10.13.6
8 gb 1600 MHz ddr3


ISO regen


EMM Labs dac2x v2 xmos core u8 output

While playing dsd128 files Dropouts were occurring between every 15-30 seconds. During dropouts Roon is only using 15% - 20% cpu. I adjusted my settings and still got dropouts. Then I removed the ISO Regen and all the dropouts went away.

Any thoughts on why the ISO Regen in the signal path would impact dsd128 playback?

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue


Hi @Carlos_Zaidi,

What does the Signal Path look like with the ISO regen in the chain? Can you post a screenshot using these instructions? Are you using the newest firmware on the ISO regen? Have you tried a different USB cable?

Here’s an image without the ISO Regen because now my ISO Regen with lps 1.2 won’t power up. I’m using a siltech USB cable that worked fine previously with the regen at dsd64 but not dsd128. Everything works fine without the ISO Regen in the path so I can only assume the problem is with the regen.

Thanks for your response!

Picture with iso regen in and working as long as red switch in regen in is in ON position??

Hello @Carlos_Zaidi,

According to the ISO Regen Documentation:

The red switch on the REGEN should normally remain in the down
position, towards the letters ISO. Only in very rare cases (typically
in systems where no component is grounded) will you need to try
the switch in its up (“ON”) position, which defeats the unit’s isolator
chip. Such instances will be discussed on our website.

Are you perhaps running into one of these special cases where the switch is required to be on the ON position? I would check the ISO regen documentation and possibly contact them to see why turning that to switch to on is required. Also, if you’re having issues powering it up, it might be a hardware issue as well so I would double check this with UpTone.

– Noris

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.