Problems with gigabit ethernet switches

I have been having problems with the music freezing since the most recent software upgrades.

The system first consisted of a router (Asus RT-AC68R) in another room connected by wire to a router configured as a wireless access point (Asus RT-AC68U). The access point was connected by wire to a PC running Roon and to a Raspberry Pi3 running Roon Bridge. This configuration freezes at odd intervals. However, I can run the system continuously to see if a modification has eliminated the freezing.

If I connect an older 100 MBPS Netgear FS605 (10/100 Mbps) switch to the AP, and wire the PC and RP3 to the switch instead of the AP, the system runs seems to run well.

Why does this make any difference? I’d like to keep the installation as simple as possible. Also, I don’t know the best way to connect the system once I get around to moving the PC out of the room with the main audio system.

Broken switch? Bad port? Port/switch/network has features like jumbo frames or port combining?

It could be a multitude of reasons… but clearly something is different… Your router has a gig-e switch, but your Netgear is only 100mbps… That’s comparing apples and oranges.

I’m on my second router-AP (also Asus), with the problem. So I doubt that the AP is broken. When configured as an access point, many of the configuration options disappear. I just found out that the configuration pages are still active, so I can see and modify switch options on the Asus anyway. Jumbo frames are disabled. But I don’t know what port sharing is or how to check it.

Next, I’ll try replacing the Netgear 100 Mbps switch with a gigabit switch to see if that makes a difference. The PC has a gigabit network adapter, but the RP3 can only do 100 Mbps.

The PC is 100 Mbps instead of gigabit. I tried substituting a gigabit switch for the 100 Mbps, and it seemed to work fine. When I returned to connecting everything to the AP, it froze quickly. I turned off the firewall settings in the AP. It went for a long time, but eventually froze.

Any suggestions about settings to change in the AP? Jumbo frames and Qos are off already.

Sounds like your PC can’t handle auto negotiating 100mbps on a 1000mbps switch. Any AP switches or standalone switches with 1000mbps will auto-negotiate to the right rate. If no 1000mbps switches are working, AP or not, then the answer seems clear.

I have two solutions to report. But first, a failure: the setup with a gigabit switch between the AP-router and the PC eventually froze. So a separate gigabit switch had no advantage over the gigabit switch built into the AP-router. This is consistent with @danny’s idea that the auto-negotiate was unreliable.

Connecting the 100 megabit switch between the gigabit AP-router and the 100 megabit ethernet adapter built into the PC did eliminate the freezes, as reported earlier.

Also, adjusting settings for the PC ethernet adapter eliminated the freezes, even when it was connected directly to the AP-router. Based on a number of internet reports, I tried changing the ethernet speed setting from auto-negotiate to 100 megabit per second, full duplex. This reduced, but didn’t eliminate freezes. But when I changed the settings to also disable adapter power saving, the system ran more than 24 hours without a freeze. Success.

Thanks @danny for your help.


@Esskay – what PC ethernet adapter was it? What OS? What driver & version?

OS is Windows 10 Home, V1703.

Adapter is “Realtek PCIe FE Family Controller” built into a Dell Inspiron 5558 laptop motherboard. Driver is Realtek 10.1.505.2015. There are lots of online complaints about Realtek adapters.