Problems with Roon and Devialet Expert 440

Using Roon through Windows 10
Tidal music through Roon

I have been using a Devialet 220 Expert Pro as an integrated amp with Roon Ready and it has worked without incident for months. I recently upgraded by adding another 220 to make a 440 pro. I configured everything the same and the device comes on as usual with Roon Ready as the source. I can see Devialet 440 as an option in the Roon Ready area of Roon. However, whenever I attempt to play music there is no sound. Furthermore, as you watch the seconds advance on the track to know it is playing, it pauses and jumps erratically. For example, it shows 10 second into the track and then jumps to 18 second, etc. All my other devices work fine with Roon. I’ve reviewed my audio settings for this device and the settings are similar to my other devices. I’m just not sure how to problem solve this further. Any assistance would be greatly appreciated.

Since it sounds like the 440 Pro is recently acquired, is it working correctly via any other inputs? That is, is the problem only with Roon? If so, does it work with Roon AIR but not Roon Ready?

Correct, the second 220 was recently acquired but I’ve been using the other 220 with Roon Ready for months without any problems. I only use Roon with this device so I’ve not tested any other inputs. I’ve tried Roon AIR but that doesn’t work either. The system boots up as a 440 and both units have Roon Ready selected as the source input. It also shows up in Roon Ready on the Roon app. However, it just won’t play music. Not sure how to further problem solve it at the moment.

Just guessing, because I do not have a Devialet device.
You say both units have Roon as input. But shouldn’t a 440 be configured in a master & slave configuration? Then there would only be one device with an input.

Could it be a Devialet Configurator problem? If neither AIR nor Roon Ready work, my bet is that your 440 is not configured quite right, but that’s just a guess. I will say that I’ve had some real issues with the Configurator for my 440. Be sure that you always start with a new configuration. Devialet has acknowledged a bug with the Configurator that messes up when you attempt to edit an existing configuration for any dual-mono Expert Pro.

But I’d see if you could find another input source for your 440 (TV, old CD player, etc…) to verify that it is properly working before trying to troubleshoot Roon.

@Arlen - you are correct, but both Master and Companion will display the name of whichever input is selected.

Thank you for your responses. mdconnelly- I agree that it is probably a configurator issue. I was aware of the need to always start a new configuration and not modify an existing one due to a bug in the configurator. I’ve also done a complete firmware update on the new 220 and it matches exactly to the original 220 and is the latest firmware available. Yes, the master unit displays “master” on it and the companion displays “S1” and both have an input of Roon Ready on them as the source. Since it must be a Devialet issue, I think I will configure each unit back to a 220 and see if I can get them to work independently. If so, I will have narrowed it down to a 440 configuration issue and attempt to problem solve from there. Thanks again for your feedback and assistance. I appreciate it!

I had similar problems, usually when applying a firmware update. The solution that worked was full power off for Roon Core and Devialet (with disconnection from the wall outlet).

Good idea. Start with your new 220 just to make sure it works properly. You could even just swap in the configuration you used on your original 220. If that checks out, then start to work on getting the basic 440 Pro setup.

I also started with a 220 then added a 2nd one to comprise the 440 Pro. Happy to help anyway I can.

Hello @Listenup23, and my apologies for the frustration here. I wanted to confirm that the issue was limited to the Devialet? Does it happen outside of Roon?

Lastly, could you reproduce the issue one more time and let me know what track you used to reproduce and let me know what date and time you reproduced so I can enable diagnostics for your account? Thanks!

Thanks for getting back to me. The issue has evolved to a point that Roon doesn’t work on any of my devices and I have isolated it to a Roon issue and not my Devialet Expert 440 Pro integrated amp. The reason I know it is isolated to Roon is that my Devialet and all my other devices (Marantz and Denon receivers) all play fine with Spotify that is bypassing Roon.

To be honest, I spent hours and hours trying to get Roon to work on Friday, Saturday and Sunday. I did everything imaginable to try to reset it. I’ve attached a screenshot of my iphone of a track I was trying to get to play and the messages from Roon are displayed on the screen. The time is also displayed and it was Friday at 8:30 pm.

Hello @Listenup23, I’ll enable diagnostics now for your account so we can get the info over to the QA team but I didn’t get the screenshots. Can you post them here on the forum? Thanks!

Roon Customer Support: When should I expect you to communicate you are working on this problem? Please consider letting me know you are doing something to at least show a good faith effort you are attempting to resolve my issue. My patience is being tested as each day passes without resolution or communication.

Hello @Listenup23, and thanks for the screenshot. I have now sent this information and the diagnostic report over to our QA team for an investigation and once I have their feedback I will update this thread and help you find a resolution to the issue.

In the meantime, you were going to try the new 220 by itself here:

While the QA team reviews this issue, could you please give this a try and let me know the results?

For clarification, Roon isn’t working on any of my devices, not just the Devialet and it’s been like that for over a week. Here is another screen shot from this morning showing it isn’t working. Is there any customer support that allows me to talk to a person or have an email for direct communication? This isn’t being resolved and we need to discuss other options at this time.

Add images

Hello @Listenup23, I apologize for the difficulties you are having here, and I appreciate your feedback about our support process.

We sometimes hear from people wondering about phone support, email support, or other more traditional methods, and we almost always win them over by resolving problems here every day. I can tell you that we stand behind our products and our support 100%.

Every support thread on this site is tracked by someone on our staff, and they frequently loop in senior staff or developers for feedback. Nearly everyone in our company spends time on this site.

With that being said, I have reviewed this thread with our QA team in with none of the endpoints working anymore are you able to test with a hotspot so we can rule out a networking issue. We recommend this based off the symptoms and the log trace below:

01/08 20:30:09 Info: [zone Denon Living Room] OnPlayFeedback StoppedEndOfMediaUnnatural
01/08 20:30:09 Info: [zone Denon Living Room] Canceling Pending Sleep
01/08 20:30:09 Trace: [Denon Living Room] [Inactive] [STOPPED @ 0:00] No Regrets - Mighty Mo Rodgers
01/08 20:30:09 Info: Alert: TIDAL: tidal_account_error
01/08 20:30:09 Info: Alert: TIDAL: tidal_account_error
01/08 20:30:09 Info: Alert: Transport: stopping_too_many_failures
01/08 20:30:09 Info: Alert: Transport: stopping_too_many_failures
01/08 20:30:10 Warn: [tidal/http] GET => NotFound 
01/08 20:30:10 Warn: [tidal/media] could not get playback info for 168:0:4032549: Result[Status=NotFound]
01/08 20:30:10 Info: Alert: TIDAL: tidal_account_error
01/08 20:30:10 Info: Alert: TIDAL: tidal_account_error
01/08 20:30:16 Debug: [easyhttp] [69] GET to returned after 9053 ms, status code: 502
01/08 20:30:16 Error: System.InvalidOperationException: code is invalid. code:10 format:positive fixint
   at MessagePack.Decoders.InvalidMapHeader.Read(Byte[] bytes, Int32 offset, Int32& readSize)
   at MessagePack.Formatters.Roon_ServiceProxies_MetadataService2_AlbumsContainerFormatter21.Deserialize(Byte[] , Int32 , IFormatterResolver , Int32& )
   at MessagePack.MessagePackSerializer.Deserialize[T](Byte[] bytes, IFormatterResolver resolver)
   at Roon.ServiceProxies.BaseProxy.<Get>d__28`1.MoveNext()
01/08 20:30:21 Info: [stats] 5782mb Virtual, 526mb Physical, 90mb Managed, 2060 Handles, 106 Threads
01/08 20:30:36 Info: [stats] 5754mb Virtual, 536mb Physical, 90mb Managed, 2035 Handles, 99 Threads
01/08 20:30:51 Info: [stats] 5750mb Virtual, 536mb Physical, 93mb Managed, 2032 Handles, 98 Threads
01/08 20:31:06 Info: [stats] 5750mb Virtual, 536mb Physical, 93mb Managed, 2020 Handles, 98 Threads
01/08 20:31:21 Info: [stats] 5766mb Virtual, 535mb Physical, 93mb Managed, 2057 Handles, 102 Threads
01/08 20:31:36 Info: [stats] 5758mb Virtual, 535mb Physical, 94mb Managed, 2048 Handles, 100 Threads
01/08 20:31:51 Info: [stats] 5758mb Virtual, 525mb Physical, 95mb Managed, 2041 Handles, 100 Threads
01/08 20:32:06 Info: [stats] 5754mb Virtual, 535mb Physical, 95mb Managed, 2033 Handles, 99 Threads
01/08 20:32:21 Info: [stats] 5758mb Virtual, 533mb Physical, 88mb Managed, 1983 Handles, 100 Threads
01/08 20:32:36 Trace: [broker/accounts] [heartbeat] now=1/9/2021 3:32:36 AM nextauthrefresh=1/9/2021 4:27:36 AM nextmachineallocate=1/9/2021 7:27:36 AM
01/08 20:32:36 Info: [stats] 5754mb Virtual, 533mb Physical, 88mb Managed, 1974 Handles, 99 Threads
01/08 20:32:51 Info: [stats] 5762mb Virtual, 533mb Physical, 88mb Managed, 2001 Handles, 101 Threads
01/08 20:33:06 Info: [stats] 5750mb Virtual, 533mb Physical, 88mb Managed, 1988 Handles, 98 Threads
01/08 20:33:21 Info: [stats] 5750mb Virtual, 533mb Physical, 87mb Managed, 1989 Handles, 98 Threads
01/08 20:33:36 Info: [stats] 5746mb Virtual, 533mb Physical, 87mb Managed, 1989 Handles, 97 Threads
01/08 20:33:52 Info: [stats] 5754mb Virtual, 533mb Physical, 89mb Managed, 2027 Handles, 99 Threads
01/08 20:34:07 Info: [stats] 5742mb Virtual, 532mb Physical, 89mb Managed, 2016 Handles, 96 Threads
01/08 20:34:22 Info: [stats] 5742mb Virtual, 532mb Physical, 89mb Managed, 2021 Handles, 96 Threads
01/08 20:34:37 Info: [stats] 5738mb Virtual, 532mb Physical, 90mb Managed, 2017 Handles, 95 Threads
01/08 20:34:52 Info: [stats] 5750mb Virtual, 533mb Physical, 90mb Managed, 2049 Handles, 98 Threads
01/08 20:35:07 Info: [stats] 5746mb Virtual, 533mb Physical, 88mb Managed, 2050 Handles, 97 Threads
01/08 20:35:09 Trace: [musicpowerstate] music has not been playing for 5 minutes, allowing idle sleep
01/08 20:35:22 Info: [stats] 5746mb Virtual, 533mb Physical, 84mb Managed, 1974 Handles, 97 Threads
01/08 20:35:31 Trace: [raat_ll/client] [Treg’s iphone] no data received for >10000ms. Killing connection.
01/08 20:35:31 Trace: [raatserver] [Treg’s iphone] lost client connection. Retrying
01/08 20:35:31 Info: [raatserver] [Treg’s iphone] connecting (attempt 1)
01/08 20:35:31 Trace: [push] restarting connection (Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)
01/08 20:35:31 Trace: [push] retrying connection in 24579ms
01/08 20:35:31 Info: [transport] destroyed zone Treg’s iphone was playing? False
01/08 20:35:31 Trace: [zone Treg’s iphone] Suspend
01/08 20:35:31 Info: [zone Treg’s iphone] Canceling Pending Sleep
01/08 20:35:31 Info: [zone Treg’s iphone] Canceling Pending Sleep
01/08 20:35:33 Trace: [rnet/RnetJsonClient] no data received for >10000ms. Killing connection.
01/08 20:35:33 Trace: [raatserver] [RaatServer Tregs-iphone @] lost client connection. Retrying
01/08 20:35:33 Trace: [raatserver] [RaatServer Tregs-iphone @] connecting (attempt 1)
01/08 20:35:33 Warn: [raat_ll/client] [Treg’s iphone] failed to connect Object reference not set to an instance of an object.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.