Problems with Roon Remote on my iPhone

I have been using Roon for about 6 months and have had no trouble using the Roon Remote on my iPhone 7. I use Roon with my stereo system in my “man cave”. I also have a media room where I do not listen to Roon.

There was a connectivity problem in my media room affecting the remote for the media room system. this has nothing to do with my man cave. The technicians came out and determined that the Ethernet card in my TV was bad, and disconnected the TV from the Ethernet. During their troubleshooting they connected their laptop to my modem/router. I am not sure it they made any changes to the router. When they left, I found that my iPhone could no longer connect to my desktop core. Roon works fine, just the remote app won’t connect.

I rebooted my computer and made sure that Roon was set to accept remote commands. I deleted the Roon Remote app from my iPhone, rebooted the iPhone and reinstalled the Roon remote app. I launched the app, and during setup, it could see my desktop with the core, but could not connect. I kept saying connecting and then connection failed. I would do this for several minutes until I closed the app.

I can print from my iPhone to my wireless network printer, so I know that my iPhone is interacting with my network. I can print from my desktop to the same I know that the desktop is connecting to the network. Internet works on both units. I have tried setting up Roon Remote on my wife’s iPhone with the same result.

It seems to me that the AV techs made a change to my router setup. I am reluctant to call them out again since they will charge me for a service call and probably won’t know what they are dealing with.

Any help is appreciated.


Hi @gdolin ----- Thank you for the report and sharing your feedback with us, both are appreciated.

Moving forward, may I kindly ask you to please provide me with the following:

  1. I see from your post that you have tried: power cycling your core, confirming the core was set to accept remote connections, and reinstalled the application on the mentioned devices :thumbsup: By chance during your troubleshooting, did you try also power cycling your networking hardware as well (i.e. your router, along with any other devices)?

  2. Details/specs of the device hosting your Roon core.

  3. Please describe your network configuration/topology, as well as providing insight into any networking hardware you may be implementing (i.e router(s), switches, repeaters, powerline adaptors, etc). I want to have a clear understanding of how your devices are communicating across your network and what “tools” are being used to make those connections possible.