Problems with streaming 192 kHz, 24 Bit files from Qobuz

Roon Core Machine

Roon Core on Windows Server 2016 Networking Gear & Setup Details Fritzbox 7490 SOtM Switch Roon Remote Control Apps on Macbook Pro, iPad Air, iPhone 12 Pro Connected Audio Devices Linn Klimax DS

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I always had an issue with 192 kHz 24 Bit Tracks when streamed from Qobuz. When streamed from my NAS - no problem.
The issue is, that the tracks get stuck while playing after a while and the seconds later continue or do not continue at all. I thought this was due to my slow Internet connection.
Quite a while ago this was upgraded to a 50 Mbit/s connection. The problem was still there.
Then I updated Roon to the version before the actual one and my search function problem was gone and also I had no more issues with playing 192 kHz tracks.
Recently I upgraded to the actual version and here it is again - 192 kHz 24 Bit tracks only play from my NAS without interruption, not from Qobuz.
Please advise - or even better: get the problem fixed with a coming release, as it appears that with the version before the actual one everything just worked fine.

Thanks and regards,


1 Like

Hey @Bernd_Dahlheimer,

We just released a qobuz-related fix earlier this week, please update to the latest roon build and let me know if you run into similar issues. :+1:

The update improved the abilty to stream 192 kHz files from Qobuz without interruptions. But not 100%.
There are certain titles, where I still experience annoying interruptions.
Here is one of them with repetitive problems:

I should add, that after the interrupt the cursor for elapsed time stays frozen at the time where the first interruption occured, even if the title continues after a few seconds.
This does not happen, if playing it with another app.

I also had the problem with

Hey @Bernd_Dahlheimer,

Thanks for the additional info. Can you provide more information around your network setup, and how your core is connected to your network?

Please test out hardwiring your core directly to your router before anything else. From there, give your core and router both a reboot, and let me know if your issue persists.

If you run into this issue again, jot down the date and time it happened as well as the track name. This is useful information to have as we continue to run diagnostics on your account.


Hi Benjamin,
before going into details:
Last Friday (February.17th) all 192 kHz titles had continuous problems - really annoying. I had visitors in the house - no time for documentation, etc.
Yesterday afternoon/evening, (Sunday February 19th) I tried again and there was zero issue playing all titles.
Today the issues are back. Not as annoying as on Friday, but still not OK.
My setup should be no issue. The 192 kHz titles from Qobuz play without any interrupts using for example the Linn App or Linn Kazoo.
The interrupt problems only occur when using Roon.
The normal setup is Fritzbox - SotM Switch - Core - Linn Klimax DS.
My setup yesterday was exactly the same and it worked flawlessly.
Please also note, that the cursor showing elapsed time stops moving after the first interrupt. It stays “frozen”, even if the title resumes playing after a while.
This is the title with most interrupts today:

Hey @Bernd_Dahlheimer,

Thanks for sharing the above info. After enabling diagnostics on your account, I was able to take a closer look around the time you put on Chet Baker.

What pops up hundreds of times is:

Debug: [prebuffer] sleeping in read -- this isn't good

“Sleeping in read” generally indicates that the Core isn’t getting the media fast enough from where it’s being streamed and is likely related to your network setup. I am seeing that your buffer is going down and that you’re also failing to connect to some of our services in that trace further indicating that this is networking related.

Did you test out the above? I see you use a SotM Network Switch in your network chain. I would temporarily remove this and see how things run.

One other suggestion is to take a look at the router configuration itself in case that’s the bottleneck. You will want to make sure IPV4 and IPV6 multicast streams are enabled.

You may also want to take a look at “IGMP Snooping” or “IGMP Proxying” as I have seen those router setting help in the past with similar issues.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.