Problems with WQXR

Anyone else having troubles with WQXR? I can search it, add it, but the stream fails to start.

Hello @Chris_Murphy, I was able to play it with the mp3 stream but the 64k aac stream wouldn’t start. I’ve changed it, try now.

Tried all three streams with no success. It does work on other stations, so I’m not quite sure where to look for the problem.

Hmm. The mp3 .pls stream can be slow to start and Roon will move over to one of the others. Now the others are all .aac wnich makes me suspect something…

Can we check your codecs via stations that have only 1 stream…
95bfm (flac)
CJSW (aac)
WRFG (mp3)

And what is your core running on? Is it a QNAP by any chance?

(In the meantime, I have changed the .pls stream - it should start quicker now)

(Moving this to its own thread)

Indeed, running on a QNAP… I’ll check those other stations. I corrected several other stations by defaulting to other streams but no luck with QXR.

Then I suspect you have this problem

The codecs in your NAS will not decode .aac streams. There is a solution in that thread, but if you are unsure about carrying out the fix, @crieke has kindly offered to help.

The latest Roon update came through on Qnap the other day

1 Like

95bfm and WRFG worked fine. It is, indeed, the aac stream of CJSW that isn’t working. I now have the latest Roon version on my QNAP. WQXR’s MP3 stream is now working. I do see the ffmpeg option on the Roon Overview page. I’ll take a look at the solution thread. And nice find on those other stations!

Did you get things working?

Yes and no. I was able to switch over the live music stations to default to non-AAC. But now problems are really kicking in with AAC files in my music library. I was able to convert most of it to .wav, but there’s still enough in there to crash playback. I suppose the only way to solve this is to either re-rip (some CD’s I’ve lost track of) or install a different version of ffmpeg as you was pointed out. I’m not sure I understand how to do this, but I’ll try to figure it out, as it’s quite frustrating for music files.

@crieke video here walks you through it. If you are still apprehensive please contact him, I know he will be pleased to help.

Thanks, Brian, I’ll give it a try.