Procedural EQ Causes Some Albums To Be Muted In One Zone Only... Vexation

Howdy All - This makes no sense to me but… with a Procedural EQ parameter, in the DSP, enabled… some of my albums are completely muted… in only one of the two zones in my setup.
Only 2 albums of 500 are affected. All of the tracks in each of the affected albums are muted. The vast majority of albums play normally in both zones while the affected albums play normally in one zone but not in the other, when the Procedual EQ is enabled.
The same albums play normally, in both zones, when the Pro EQ is disabled.
The affected albums are sourced exactly the same as the unaffected albums and reside on a NAS.
Logic tells me there must be something about my setup in the one zone but, I don’t know what. Has anyone got an idea how to go about troubleshooting this annoyance?

Moving this to #support for a start

Hi @Mike_Hart,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you also please share a screenshot of your Signal Path when you have all your DSP turned on?

[quote=“noris, post:4, topic:115943, full:true”]
Hi @Mike_Hart,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

[quote=“Mike_Hart, post:1, topic:115943”]
with a Procedural EQ parameter, in the DSP, enabled… some of my

Qnap NAS TVS471 core machine using ssd for Roon database.
11783 tracks.
Linksys Mesh wifi - bridge mode - Google Fiber router
Zone - 1 (is unaffected by problem) - Mac Mini Catalina to Heed Abacus to Lebon amp.
Zone - 2 (affected by problem) - Linksys node wired to Zenmini to Liberty DAC to Peachtree-150 amp, to speakers.

Qnap NAS TVS471 core machine using ssd for Roon database.
11783 tracks.
Linksys Mesh wifi - bridge mode - Google Fiber router
Zone - 1 (is unaffected by problem) - Mac Mini Catalina to Heed Abacus to Lebon amp.
Zone - 2 (affected by problem) - Linksys node wired to Zenmini to Liberty DAC to Peachtree-150 amp, to speakers.

The simple workaround is to just disable the Procedural EQ but since you asked, I’ve uploaded a screenshot while playing one of the problematic album tracks.

Thanks

Are both affected albums mono and if yes, do you have more than this two albums in mono which play correctly through your problematic zone?
If no, then the fact that these albums are mono seems to be the root cause. Sadly I don’t know if this is then considered as a bug or a feature.

Thanks Blackjack,
You may be on to something. I should have said that I’ve only found 2 to be affected, thus far. In fact, both affected albums are originally mono recordings. I have other mono tracks which are not affected but they are mono tracks on, otherwise, stereo recordings… like Meet The Beatles, etc…
I just found a third album with the same problem, Les Paul’s “After You’ve Gone” and it’s originally a mono recording too.
I think you are, definetly, on to something.
It might be worth re-noting that not all my mono albums are affected and the ones that are affected are affected in only 1 of the 2 zones in my setup. That’s the weird part.
Also, I digitized the albums, myself, from vinyl… so maybe I recorded the affected albums in mono and the unaffected ones in stereo from the original mono vinyls? I don’t remember, at this point.
Thanks.

HI @Mike_Hart,

If you try to play to the Mac Mini System Output zone, do you notice any issues there?
This should be to the Mac’s internal speakers.

Are you running newest firmware for all these devices?

No. The same files play normally in that zone. There’s a Heed DAC and a Leben amp with speakers in that zone so it’s not using the Mac’s speakers at all. I left that info. out of the description, as the issue does not occur in that zone. The files reside on a wifi connected NAS.
I use both zones simultaneously and can walk from zone-1, where it plays normally, to zone-2 where the same 1-channel mono albums do not. Roon’s waveform display just flatlines in zone-2 as the album plays away normally in zone-1.
My only guess is the Procedural EQ wants 2-channels to equalize but, that seems like it would occur in both zones… if that were the case.
Fortunately, it’s not a big issue to simply disable it. It’s just kind of a head scratcher.
Thanks.

Yes. I updated all devices.

Hi @Mike_Hart,

Thanks for confirming that the issue only occurs on the Liberty DAC!

Can I please ask that you private message me an example of a track/album which reproduces this issue? You can click on my name -> message to send a private message.

Also, please share a screenshot of your Procedural EQ settings from the DSP tab and I’ll forward both to QA for closer review, thanks!

Hi @Mike_Hart,

Thanks for sending me that screenshot of the DSP! I’m wondering, is there any difference in how these zones are set up under the Device Setup menu? Do they have different channel layouts?

Noris,
They are both set to “downmix as needed” in the Multi Channel Mixing setting. Is that what you mean?
MH

Noris,
The DSD Playback Strategy is set to DoP in the untroubled zone and Convert To PCM in the troubled zone.

Hi @Mike_Hart,

Can you please share a screenshot of the Device Setup tab from both zones? Please be sure to include the “Advanced” section.