Processing speeds for DSD256 < 1x

Continuing the discussion from Processing speed of DSD256/512 files dropped to <1x after Roon v1.8 upgrade:

Hi - Did this ever get resolved? I am suddenly seeing < 1x processing speeds on DSD256 files. My Roon core is on an i& NUC. Never had problems before and I am pretty sure I have played DSD256 at around 3 to 4x after the 1.8 update. Nothing has changed in my setup except that I am now using the 2021 Audeze preset for LCD-X. Signal path is as below. Rebooting NUC and restarting Core did not help.

I have to say my processing speed went the other way…lol
At dsd 256 I used to be at 1.3x, now I’m at 1.8x.

So your situation is odd.

What happens if you disable that Audeze preset?

1 Like

At home I stream DSD 256 and am seeing around 2.8x speed when I’m playing music but if I’m browsing heavily in Roon at the same time then my processing speed drops.

I will say that I don’t use crossfeed or a preset but I do have on headroom adjustment and am using a convolution filter.

It’s possible that DoP and the preset filter takes more resources, I’m converting to straight DSD 256.

Whatever the explanations, I have not changed any settings and processing speeds have suddenly come down drastically, so much so that I am unable to play DSD256 content anymore.

Would @support kindly chime in and help diagnose the problem?

While awaiting for support did you disable that audeze preset to see if any change?


Enable Parallelize Sigma Delta Modulator.

If that does not fix it, disable Native DSD Processing.

The problem is with using linear filter over the default low latency one in the Audeze preset. Have let them know in the relevant thread.

Hey @zenyatta80,

Could you please clarify what is the “relevant thread”? Our team would need a bit more information to be able to help.

Thanks :pray:

Sure. Here it is.

Hey @zenyatta80,

Sorry I’m only getting back to you today — I was out the office until yesterday.

Thanks for pointing me in the right direction. I’ve added the information to the ticket submitted to our QA team.

I’ll follow up as soon as I hear back :nerd_face:

Hey @zenyatta80,

Just as much as you, or maybe even more, I wish that we had the answer I’m about to share didn’t take this long and that it was a lot different than what it is.

You’ve reported this in great detail and it’s been immensely helpful for us. A big thank you! It will serve us well in improving Roon. In the meantime, what would help on a day to day is:

  • removing one of the steps
  • downsampling to 128

As I said in the beginning, I wish this wasn’t the answer I had for you… :pensive:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.