Progress bar ticks slower than real while playing with down-sample from 192kHz to 96kHz, output to HQPlayer

Core Machine (Operating system/System info/Roon build number)
Macbook Pro/macOS High Sierra version 10.13.8
Roon Version 1.6 (build 416) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Core + HQPlayer Desktop4 <---CAT6---Velop_mesh(LINKSYS)---CAT6---> Sonore MicroRendu

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Sonore MicroRendu <---USB--> ISO/SPDIF ----coax---> dCS delius DAC

Description Of Issue
At playing back flac file of 192kHz, down-sample to 96kHz with “Sample Rate Conversion” DSP, progress bar ticks slower (about half of the real one) than it should be. (please find it screen shot below).

at 10/01 18:06:18, HQPlayer shows begin_sec="38" while Roon ticks is 0:18 instead of 0.38.

Hi @Steven_Yamada,

Just to verify, if you were to remove HQPlayer from the chain, does the same behavior occur?

Do you mean that testing if the issue is reproduced with RAAT (Roon client on MicroRendu)
? The result is negative, i.e., it ticks as expected.

Just for your information, here is the Sample Rate Conversion setting for HQPlayer output.

Hi @Steven_Yamada,

What kind of time output do you have set on HQPlayer? HQPlayer has multiple options of displaying the play time - “time”, “remain” and “total remain”. You will want to select the first option of “time” in HQPlayer for the playback bar to properly progress in Roon.

Hi @noris , HQPlayer setting for play time option is set to “time”. (as written in
For additional information, playback bar proceeds to the half point (at the middle of whole length) at the end of track playing, and continues proceeding more – even though the next track is playing. It seems like that Roon counts frames of original sampling rate (192kHz) not down-sampled one (96kHz).

Hi @Steven_Yamada,

Thanks for confirming that aspect. I have filed a ticket regarding this issue for review with the technical team and have requested they schedule some time to attempt to reproduce your findings. I will be sure to let you know once I have more information to share. Thanks again for the report!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.