PS Audio Direcstream Junior uncertified



I have perform their latest software updates both for FIRMWARE and BRIDG.

I have been sucessfull in configurating Roon and create an OUTPUT for my DJ.

However it is written in the Roon UI that this device is “uncertified”.

It is a surprise for me because from PS AUDIO perspective their software is ROON READY.

Can you tell me yoour official status about supporting DIRECSTREAM JUNIOR now or in near future

Best Regards

Jean-Marc from France

If it’s a recently released device there’s sometimes a lag until the model shows up as certified in a sudsequent Roon release. Perhaps this is the case?

Hi Steve.

How can I send you an image / screenshot ?

Steve is not an employee of Roon and thus cannot make changes to the program or provide an official answer.

If you want a way to upload a screenshot. Try

Follow this link on the Roon website. It clearly shows that the DSJ is RoonReady. So you are good.

The situation is likely as @hifi_swlon explained it.


Admittedl, It was disturbing for a Roon novice …

My PS DSJr. works fine with no messages on Roon 1.3-203. No problems with not certified message. This is on a MAC i7 2011 2.7ghz.

Well that’s curious. It IS RoonReady, and showing up for you, but no showing as such in Roon for the OP. Odd…


Thanks for the info.

I ru the latest Roon release for Windows 64 bits (Windows 8.1).

This is very true. I can try to help though…:slight_smile:

Indeed. :wink:

Jean-Marc have tried to power off DSJr for a minute and then power on again?


Yes … and it solved this issue :smile:


1 Like

It’s because the device was momentarily identifying itself to Roon as “CDMCM-210” instead of its real name.

I think this sometimes happens after firmware updates of these devices. Maybe something to take up with PS Audio…


Thanks for your answer.

Btw, do you have any plan to support your iPad app on older version of iPad 2 & 3 (with recent iOS) ?

Best regards

No, I don’t think we ever will. We require OpenGL 3.0 on iOS, and the older devices don’t have it.

Reviewing my Roon setup I now find my PS Audio Perfectwave DAC Bridge 2 is ‘uncertified’. Does anyone know what happened?

Same here with my PWII DAC and Bridge II. After 1.5 update (which is wonderful) the Bridge is Uncertified. When I select the Bridge as my zone, what used to be a nice icon of my DAC is now the generic icon of a speaker.

Doesn’t seem to affect functionality, but would like to straighten it out nonetheless.

Hi @TheLooster and @Rusty_Miller,

Looks like the PerfectWave DAC entry in the new Roon device database is missing/incomplete.

@john, Is this something you can check/fix?

I had a similar issue with my Naim Uniti Nova showing “Uncertified” after the upgrade to 1.5. Rebooting the Nova or computer several times did nothing.

I had to first disable then re-enable the Nova via the Audio menu in Roon. That solved the problem for me.