PS Jr Bridge / Roon failed - unable to reestablish connection[Solved]

I have been using Roon to PS Jr. Bridge for the last month or two. Last night, i was getting an intermittent connection - music would play and then stop. I’d check Roon (on ipad) and see that PS Audio was missing as a source. After a few seconds it would reconnect, until it didn’t.

I’ve turned off PS Audio, restarted Roon, restarted the computer, let everything sit over night off and reset in the AM, etc. and Roon still no longer recognizes PS Jr. I should add the ethernet cable from Roon to the router seems to be fine. Both the router and Roon’s ethernet connection have LEDs flashing…

Details of Setup:
Roon: 1.2 161 64bit
Win 10
Desktop PC - 4GB ram
PS Audio Jr.
Bridge updated last month - no other update available
PS Audio Jr. firmware 94, with Torrey


Hey @hshrader – can you us the version numbers described here?

Also, can you give us a little more information about your network, especially what hardware is involved, including any routers, switches, etc.

Finally, can you confirm whether any Windows 10 updates have been installed lately, and whether you’ve tried disabling the Windows Firewall, or any other firewall running on the PC?

Hi Mike,

Version numbers on PS Jr:
Torreys: 0.0.0
Main: 00.94
FPGA: 00.113
USB: 00.33
Boot: 01.13

Network Set up DHCP: DHCP IP (i think this had numbers in before failure)

My Network
The fiber line attaches to a modem in the music room. Two ethernet cable runs from that modem, 1) to the PS JR and 2) to a Netgear Router a couple of rooms over. The Netgear router has a ethernet cable connected to my PC where Roon is running. The modem is no brand and provided by my service provider. My Netgear router is called Nighthawk (really?).

My PC and Win 10
My PC is i3 core, 4gb, 500g HDD. I run my library on external drives. I have had updates to Win 10 recently.

I run AVG virus protection and have allowed Roon RAAT an exception. I don’t use AVG firewall. I do have WIN 10 Firewall on.

Anticipating you’d ask me to turn off the WIN 10 firewall, i did and restarted the PC. When Roon restarted, still no PS Jr recognized. :cry:


Hi @hshrader ----- Thank you for taking the time to answer our questions and sharing your observations with us.

Moving forward, I would like to confirm if your PS Jr Bridge works with DNLA. May I please ask you to try the following:

For an IOS device:
Go to the Apple store - > Download and install mConnect or mControl by Converse digital. Then in the application hit the Play to tab at the bottom. Then if your bridge shows up select it. Then press the player tab, and press the gear at the upper left and it will give you device information. If you have a uPnp server on you network, hit the browser tab. Then select a song and it should play on your DAC.


I have mConnectfree on my iPad mini but PS jr does not register. An airplay device and my iPad do register.

The odd thing is that it was working flawlessly and then over the course of 10min, it fluttered in and out. And then it stopped. Other than WIn 10 updates, there has been no change in configuration or devices.

Seen anything like that? Any thoughts?


Hi @hshrader ----- Thank you for getting back to me and trying the proposed test. Moving forward, can you confirm that you can successfully ping the PS Jr Bridge from your windows machine?


Hi Eric, can you advise the steps necessary to do this?



Hi @hshrader ---- Steps listed below :sunglasses:

To ping another network device using a computer running Windows, complete the following:

  1. To bring up the run dialog, press the Windows key + R.
  2. Type: cmd and press Enter.
  3. Type: "ping " and press Enter.

For example, to ping, you would type “ping”

If the ping is successful, you should receive replies from the address that you are trying to ping.


Eric - where do I find the ping address for the PS Audio? Please note post 2 where DHCP is

@Eric can mean that the device has assigned itself that ip because the address request for dhcp has failed. Check to make sure your dhcp service is running or the ps can reach the dhcp server, usually the router.

1 Like

Hi @hshrader ----- Thank you for the follow up. I would agree with @Rugby’s advice here in regard to confirming that your DHCP service is running / the PS Jr bridge can reach the router (DHCP server).


Dear Eric,

Please advise on how i do as Daniel advises?

Can i give you a ring now so we might work though these issues on the phone and where we don’t need a day or two provide and try to follow instructions?



You can quickly test if PS jr being plugged into the fiber modem is the culprit by getting a long ethernet cable and plugging the ps jr into the Nighthawk router directly.
You can also look to see if both the fiber modem and the Netgear are running DHCP. You only want one DHCP service running.

Thanks Daniel. 14m cable I don’t have. Will see if each has DHCP on. If they both do, which to turn off? Also, no one has been in the settings of the modem or router. Why would it just stop working…? I will try and check the DHCP settings…

The first thing I"d try, if you haven’t already, is simply moving the ps jr’s cable to a different port on the fiber modem if there is one or even a different cable. Ports or Cables can be the culprit. Just the past week or so, I spent a lot of time diagnosing packet loss coming into our server room only to finally discover that during a new comcast cabling job for a different tenet in the building one of the installers zip tied my cables to the point of breakage. Had to run new cable to fix the issue.

I would use DHCP on the fibre modem, simply because both units are wired to it.

I would still suggest getting a 15 meter cable to test if the DHCP issue doesn’t resolve things. They are pretty cheap and handy to have around, that way you’d know for sure whether the problem lies with the fiber modem and the current setup.

1 Like

Clear. I will switch ports and see if that makes a difference.

As i looked into the modem and router for DHCP being on, i realized that the cable from the modem does not go to the “Internet” input on the Nighthawk, but rather one of the four ethernet ports. Would that make a difference?

Also, I was able to get into the router a couple of min ago and it told me there was no internet connection. I removed the cable running from the modem from the Nighthawk’s ethernet port and put into the internet port. That got me no where, but when i corrected and restarted the Modem, it does not answer to the IP address…Says it is taking too long to connect. Now that this is the case, i wonder if switching cables on the modem will make a difference. I might need to communicate with the Nighthawk first…?

Whow. I moved the PS Jr.'s cable to a different port on the fiber modem and it worked!

I will “find” my Nighthawk modem eventually. At this point all audio and internet seem to be working.

Do you think the port just gave out? It is a very cheap Chinese made modem.

Many thanks Sir Daniel!