Puzzling restore (was: Migration hell)

Ok, I had Roon happily running from my MacBook Pro with an attached 2TB USB drive, where my music collection was. Coming from Meridian, I find Roon awesome.

I recently purchased a Nucleus + to free the Mac and have more convenience.

I followed the standard procedure as I saw it in the KB, essentially:

1 Backed up my database from the Mac

2 Restored the database to the Nucleus +

Everything went fine.

Problems started when copying the music from the USB to the internal SSD in the Nucleus + 4.

What I did:

  1. I formatted the SSD card inside the Nucleus +
  2. I disabled the USB drive as storage location
  3. I quit Roon
  4. I copied the music to the SSD.
  5. I relauched Roon.

I soon saw some random albums had been split (not albums that I merged, btw, but albums that had always been in one piece) . Did I want to merge them all again? No, so I thought perhaps I should try restoring the dB again.

So I did that. Only this time, the restore was made whith the music files already available to Roon in the SSD storage. This should not be a problem, should it?)

But I relaunched Roon and discovered that a lot (although not all) of my edits were gone. Crucially, albums and artists had reverted to the original attributes assigned by Roon that I had changed (however, my customised genres still existed in the Roon genre list). Other choices, like artwork, had also been reverted to the original Roon choice.

By chance I reconnected the USB drive where my collection originally was to the Nucleus + I re-enabled the relevant folder…and I discovered that all my albums appeared as duplicates: Roon was showing two copies of each: the one in the USB drive, the other in the internal SSD. One (the
one in the USB drive?) showed all my edits correctly. The other copy (the one in the SSD, I guess) did not.

I wonder

  1. How can I proceed now to store my music in the SSD drive? (reformat and copied it again?)

  2. Why restoring a roon database on top of an existing music collection would create havoc?



@support is required.

Thanks for reaching out, @Antonio_Ballesteros!

It sounds like there may have been 2 storage locations active at once — The internal storage and the USB drive. If the internal drive was active while the USB drive was active, Roon would see the files on the internal drive as new files rather than the existing files in a new location. You can read more about the process in our KB.

The best option is to restore the original backup in Roon and then (as described in the migration article linked above) verify that both the internal storage is disabled and the USB drive is removed. Then enable the internal storage and Roon will recognize these as your previous files.

If you have any questions about this please let me know!


Thank you very much, Dylan, I will try your suggestion as soon as I finish another test I’m running: Roon is about to finish importing a third copy of my music collection from a fully updated backup that I have in a NAS.

In any case, I had indeed disabled the USB drive as storage in the Roon application, switched off the Nucleus, physically disconnected the Drive from it and took it elsewhere, before I switched the Nucleus on again, relaunched Roon and opened the storage in the internal SSD, where I had copied the music.

Only when, hours later, I reconnected the USB drive and re-enabled it, all the music appeared duplicated, as I explained.



It seems Roon is giving non-identical information on different instances of the same music collection: I have three identical copies of my music folders and files in three locations: Internal SSD, External USB drive, and a NAS, which I created between yesterday and today using DropSync 3.

Thus, now I can disable/enable each of them in turn, and observe what Roon gives. I have observed significant differences in the information shown by Roon about the same album in different locations. Here are just a couple examples. There are many more I have taken screenshots.

For example, I have taken the flamenco music out of the Latin genre / subgenres. When I open the collection in the NAS, this appears as it should: 44 Latin albums, none of them Flamenco. If I disable the NAS folder and enable the SSD folder, all my Flamenco albums appear listed. The Latin genre includes 98 albums. See the screenshots below:

BTW, note also the total number of albums in my collection, 2054 in the SSD folder, 1969 in the NAS folder. Rembember that both folders are copies supposedly identical. The difference is probably due, in my view, to the fact that some albums are merged in one, but not in the other. Again, the database is not behaving consistently.

I have created a tag for the Complete Rubinstein Collection. With the music folder in the NAS, the tag is attached to 120 albums. With the music folder in the SSD, the tag is attached to 80 albums. You can even open the same album in the two locations, in one it has the tag attached, in the other it does not. Here are the two screenshots, as a telling example.

Hey @Antonio_Ballesteros,

Just to confirm — You’ve never had the internal SSD and another watched folder active at the same time, correct?

Can you share a screenshot of Settings > Library > Clean Up Library (Note - Don’t actually proceed with this function, we just want to see the numbers listed here).


No, I never had the internal SSD and another watched folder active at the same time.

Do you mean this?



I appreciate the screenshot, @Antonio_Ballesteros!

First, can you confirm the total number of tracks in your library? The screenshot you shared shows 42,145 tracks — Is that correct?

Moving forward, I’d like to enable some diagnostics and get a report open with the technical team to review. Before doing so, I want to make sure that the team will have everything they need properly investigate what you’re experiencing, so I’d like to reproduce this behavior once more first. Please see the steps below:

  1. Restore the backup from before the migration once more. Make a note of the time the backup is restored.
  2. Once the backup is restored, before making any changes, take screenshots of the following:
    • Settings > Storage in Roon
    • Settings > Library > Clean Up Library
  3. Remove the old storage location from Settings > Storage. Make a note of the time that you do this.
  4. Enable the internal SSD watched folder, making a note of this time as well.
  5. Once this has been done review the library and let me know if things are still not looking correct.
  6. Take a screenshot once more of Settings > Library > Clean up library.

Once this is done, if the migration is still not properly working, I will pass along the screenshots you’ve provided and enable diagnostics on your account. The technical team will review the diagnostics report in relation to the timestamps you’ve provided.


You know, I am now using two storage areas, alternatively: the “problematic” one (in the internal SSD inside the Nucleus +), and the “good” one in a NAS. I switch between the two to see their differences (See Screenshot below):

The two folders should be identical, except for two albums I added to the NAS yesterday.

Ok, Roon tells me the following:

When I have the SSD folder enabled, and the NAS folder disabled:

41723 tracks imported
Clean up 41763 files

When I have the NAS folder enabled, and the SSD folder disabled:

41742 tracks imported
Clean up 41741 files

Unfortunately, I do not know how to identify the backup that I did just before creating the storage in the Nucleus SSD. I have three backups made around that date (Sep 16, Sep 20. Sep. 22).

Reformatting the SSD, copying the whole music folder back there from my NAS and launching Roon could not do the trick, in your opinion? I say this because the “good” library is the one that I see when I have the NAS open. Also, going back to an earlier copy of the Roon databasse would mean losing the edits I have been doing the last days with the NAS storage enabled.

Visually, not many things beat the following: Below, two screenshots showing the 13 tags I have created. The first shows the tags when I have the SSD storage enabled, and the NAS storage disabled.The second, the same tags when I have the NAS storage enabled, and the SSD disabled. The second one is the correct one. Note the different number of albums in the same categories, depending on the storage that is open in each case. Both screenshots were taken with a couple minutes interval.

Thanks for the updates here, @Antonio_Ballesteros!

First, I want to provide a little background here. The reason you’re seeing this behavior is because your files are being tracked twice — Once for the files on the NAS and once for the files on the SSD. This most likely happened because when you restored the backup on the Nucleus initially, the NAS was still enabled, and the internal storage is also enabled by default. Since the internal storage already had the files on them, these were re-imported to Roon as new files.

To resolve this, there are a couple of options.

The first option, as mentioned above, is to return to the point before this occurred and redo the process. With this option you will lose any of the recent edits you’ve made on the NAS.

The second option, which from the sounds of what you’ve said above is the better option for you, is to remove Roon’s tracking of the duplicate files and re-enable the internal storage. In this case, the data from the internal storage files will be lost (Note — Not the actual files, but if you made any edits, plays, etc. on those files they will be permanently gone). This should be okay since you want only what is being tracked on the NAS, but I just want to make sure that’s clear.

To do this, you’ll want to follow these steps:

  1. Make a backup.
  2. Disable Internal Storage and leave only the NAS watched folder active (i.e. the “good” storage will be active).
  3. Go to Settings > Library > Clean Up Library, check the 3rd box (files associated with disabled storage locations), and choose Clean Up Library. This will remove the tracking of the files currently on the SSD internal storage.
  4. Disable the NAS watched folder.
  5. Enable the Internal Storage watched folder.

Once you do the above, the migration should occur and Roon will link the files on internal storage SSD to what’s currently in the Roon database.

If you have any questions please let me know!


Awesome. It is solved. Everything looks exactly as it should. I will now use the NAS as a backup for the music files.

Thus it seems that, at some point, I had indeed two storage locations simultaneously enabled (Although I do not recall that and, in fact, I always tried to avoid it). Now I have learnt what the cleanup library actually means.



1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.