QNAP NAS Core: Some tracks/albums won't play

Core Machine (Operating system/System info/Roon build number)

QNAP NAS, Roon Server Version : 1.8 (build 764) stable
QPKG-Version : 2020-07-15

PC Client:
1.8 build 764

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

PC Ethernet > QNAP NAS (also acting as a switch) > Asus AX88U router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

This setup has been working well for about a year, but suddenly random chunks of my library are unplayable. Some files play and others don’t, and I can’t see any rhyme or reason behind it. It seems to be whole albums though, not individual files.

I run a Roon Server on my QNAP NAS and use Roon on my PC for playback. It is connecting via USB to my ADI-2 DAC and I had it setup using their ASIO driver.

I’m pretty sure this is not a server or connectivity issue. I can browse the NAS from my PC using File Explorer just fine, and I can play all tracks individually by opening them in Foobar/VLC just fine. Also, if I open Roon on my iPhone it can connect to the server and play all files straight out of the phone itself just fine.

So that points to some sort of issue where the player on my PC just won’t play certain albums. But why?

I’ve tried uninstalling and reinstalling on my PC, including re-selecting the core, with no luck. I also tried different output modes such as WASAPI and the default windows system output with no luck. It’s the same result each time.

Hello @Kevin_Hustler and welcome to the forum.

Please update to version 2021-02-01, install the ffmpeg codec and try again. For package and installation instructions see below:

Thanks, that did it. Hopefully this is resolved in the future so that maintaining ffmpeg manually in the future is not needed :slight_smile:

1 Like

Looks like the way it is, is the future. :slightly_frowning_face:
But as long as the codec is working, we shouldn’t have to update it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.