Qnap NAS TS-453A/ latest Roon Server: Out of a sudden "No audio devices found" issue

I was successfully installing Roon Core on my Qnap TS-453A NAS with the latest software package and trying out the software for a couple of day. I really enjoyed the experience and became fully convinced, ready to shell out the $ 500 for a lifetime membership … until this happened out of a sudden …

“No audio devices found” Since then whenever I launch a Roon client I get this same message, unable to play any music or even manage the library. I have tried everything I can image and what others had recommended in this forum.

These are my settings:

  1. Qnap NAS TS-453A running QTS 4.3.3 (build 0262 2017/07/27) with Roon Core (v1.3, build 262 V2017-02-02)
  2. Access to server with latest Roon clients on Mac OS iMac, iOS (iPhone/ iPad)
  3. Network: TP-Link Archer C1200 Gigabit Ethernet Router
  4. Audio: Output via network to Denon AVR 2313 receiver
  5. Firewall on device 3) turned on, SPI (Stateful Packet Inspection)

Situation:

  1. I was enjoying Roon for a couple of days without any glitches. Then out of a sudden, the music stopped playing. Since then, whenever I launch a client I get the message from the Roon Core that ‘No Audio Devices found’.
  2. No other software is affected, the LAN and Internet connections work flawlessly (in daily use, the NAS is serving content 24h etc., I can stream audio to the Denon receiver without problems, all other devices recognize the Denon receiver via Airplay without problems)
  3. No updates to the hardware were applied during the time since the first install of Roon Core on Qnap NAS

I tried the following to fix the situation (indicating if successful):

  1. NO: Power cycling all involved equipment
  2. NO: Logged out and back in into Roon account
  3. NO: Disabled any non-core functionality on Qnap (Plex, Web server/ WebDAV, Firewall)
  4. NO: Disabled any non-core functionality on TP-Link Router (NAT, Port forwarding, Dyn DNS, Firewall)
  5. NO: Removed Roon Core from Qnap NAS and re-installed freshly (installing with the previous RoonServer shared folder still there, but also removing the existing shared folder and creating a new one)
  6. NO: Detached the NAS HDMI connection with the Denon receiver

However, when I installed for testing purposes a second Roon Core on my iMac running on macOS (10.12.6), doing a fresh install from scratch, all connected audio devices are recognized. But this was also the case when I did a fresh install a couple of days ago on my Qnap NAS. That begs the question how long it might take before I run into the same problems with the macOS installation. But anyhow, this is not a solution to my problem, because I recently purchased a NAS just because I don’t want to use my desktop computer to manage my multimedia library.

These are the devices found when the Core is installed on the iMac:

I have created a zip file of all logs and uploaded it on Dropbox: https://www.dropbox.com/sh/sefv8j514ehlgfy/AADharVcCI7tYYC6l-hcN4v-a?dl=0

I would really appreciate any support/ help/ ideas of how to fix this. Otherwise, I am afraid, I will have to postpone my lifetime membership with Roon labs until this issue is solved (from other community forum entries I could see that I am not alone, but as described above, none of the usual workarounds resolved the issue).

Hi @Never_Ever ---- Thank you for the very detailed report and my apologies to hear of the troubles here. Confirming that the logs have been received, we’ll take a look and see what we can come up with.

At first glance, this feels like something could be blocking RAATServer. I see from your list of troubleshooting exercises you disabled your firewalls, which is always a good first step :thumbsup: I am curious though. Under, “these are my settings”, “#5” you note that there is a firewall on the device. Can you confirm that you have security exceptions in place for all instance of Roon and RAATServer?

-Eric

Dear Eric,

I am currently traveling for business and therefore cannot work on the Roon labs installation.

Nevertheless, indeed something is blocking the RAATServer. However, it is not the Firewall on the TP-Link C1200 router as it worked just fine for many days with the firewall on. And the Firewall activated on the router is just a SPI (Stateful Packet Inspection) firewall which is not blocking/ unblocking traffic on application level but further down in the protocol layer on packet level, irrespective of application. Therefore there is no way to white- or blacklist any specific applications.

Anyhow, just before leaving home I tried something else and it worked. The server now sees the audio devices again and can stream to them.
What I did? Previously - and not completely in line what I had written in the previous community post - I had just renamed the shared folder on my Qnap NAS from RoonServer to RoonServer_old (instead of actually removing it) and then deleted and re-installed the server package.
I cannot now reconstruct the details completely, but creating a new RoonServer shared folder on the NAS did not make a difference next to the re-named old shared folder, and the server could not find any audio devices.
But this time I deleted the shared folders completely - both via the UI in the Control Manager of the NAS and via ssh any remaining files leftover from Roon labs. Then I restarted the NAS and re-installed the server package again. This solved the issue. But by then I had lost my previous library and had to re-add my audio files to the library.

This time, however, I activated the scheduled backups, in case I run into this problem again and to be able to try out if going back to an earlier backup would enable me to re-connect to my audio devices. Having to re-build my library from scratch every time this would happen would not be convenient at all …

So, the point is, it seems that something in the files/ databases the RAATServer keeps, is going wrong/ getting corrupted and prevents it from scanning for audio devices in the first place. Does RAATServer keep a lock file and/ or Semaphore for access to audio devices? In case the the process that streams the audio crashes, but the lock file/ Semaphore remains, this could be blocking the RAATServer from scanning for audio devices. Just some thoughts … But my trials definitely confirm that the problem is with the files/ file structure kept by RAATServer and are not caused by any other software/ device.

As I mentioned before, I am currently traveling for business and will be back home only on Wednesday evening, 3 days before the trial period ends.

I would appreciate if you/ Roon labs could extend the trial period, so that I can try experimenting a little bit longer and see if I can replicate this and also see if it can be solved by reverting to a previous backup instead of having to re-add my files manually to the library.

Thank you & regards,
Christian

1 Like

Hi @Never_Ever ---- Thank you for touching base with me and sharing the results of your troubleshooting. The insight is very appreciated!

Moving forward, these observations you have made are indeed very interesting, and in order for us to try to understand what could’ve caused this behavior, we would need to see the Roon and RAATServer logs from the RoonServer_Old folder.

From you’re report it sounds like this content may have been deleted, but if you by chance, have a copy of the RoonServer_Old folder saved, please send us over a set of Roon and RAATServer logs using the instructions found here.

-Eric

Indeed Eric, in rushing to find a solution I deleted everything without making a copy beforehand.

I will try and replicate the error and in case successful, I will definitely keep the log files of the server when it happened.

Best,
Christian

1 Like